summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-02-10 00:37:28 +0000
committerMike Frysinger <vapier@gentoo.org>2007-02-10 00:37:28 +0000
commitb7ab3fcc8a3c759c2aee0e5a79cdcbc13fe809d6 (patch)
tree67bc562f9c8b67ed800602829ca91f9730b28a91 /sys-libs/libcap
parentuse mirror://debian/ #163311 (diff)
downloadgentoo-2-b7ab3fcc8a3c759c2aee0e5a79cdcbc13fe809d6.tar.gz
gentoo-2-b7ab3fcc8a3c759c2aee0e5a79cdcbc13fe809d6.tar.bz2
gentoo-2-b7ab3fcc8a3c759c2aee0e5a79cdcbc13fe809d6.zip
Include stdlib.h for proper exit() prototype.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-libs/libcap')
-rw-r--r--sys-libs/libcap/ChangeLog8
-rw-r--r--sys-libs/libcap/files/libcap-1.10-headers.patch20
-rw-r--r--sys-libs/libcap/libcap-1.10-r9.ebuild7
3 files changed, 30 insertions, 5 deletions
diff --git a/sys-libs/libcap/ChangeLog b/sys-libs/libcap/ChangeLog
index daf1595cc12c..a6038ffb4242 100644
--- a/sys-libs/libcap/ChangeLog
+++ b/sys-libs/libcap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libcap
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.40 2006/07/30 13:19:33 solar Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.41 2007/02/10 00:37:28 vapier Exp $
+
+ 10 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/libcap-1.10-headers.patch, libcap-1.10-r9.ebuild:
+ Include stdlib.h for proper exit() prototype.
*libcap-1.10-r9 (30 Jul 2006)
diff --git a/sys-libs/libcap/files/libcap-1.10-headers.patch b/sys-libs/libcap/files/libcap-1.10-headers.patch
new file mode 100644
index 000000000000..a936b882ea37
--- /dev/null
+++ b/sys-libs/libcap/files/libcap-1.10-headers.patch
@@ -0,0 +1,20 @@
+--- progs/sucap.c
++++ progs/sucap.c
+@@ -11,6 +11,7 @@
+ #include <sys/types.h>
+ #include <errno.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #undef _POSIX_SOURCE
+ #include <sys/capability.h>
+ #include <pwd.h>
+--- progs/execcap.c
++++ progs/execcap.c
+@@ -10,6 +10,7 @@
+ #include <sys/types.h>
+ #include <errno.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <sys/capability.h>
+ #include <unistd.h>
+ #include <string.h>
diff --git a/sys-libs/libcap/libcap-1.10-r9.ebuild b/sys-libs/libcap/libcap-1.10-r9.ebuild
index 5f3854421321..c399d6a054b7 100644
--- a/sys-libs/libcap/libcap-1.10-r9.ebuild
+++ b/sys-libs/libcap/libcap-1.10-r9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r9.ebuild,v 1.1 2006/07/30 13:19:33 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r9.ebuild,v 1.2 2007/02/10 00:37:28 vapier Exp $
inherit flag-o-matic eutils python multilib toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="http://www.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.4/${
LICENSE="GPL-2 BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 arm ~hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh ~sparc ~x86"
IUSE="python"
#patch is in recent 2.2 kernels so it works there
@@ -27,6 +27,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}-python.patch
epatch "${FILESDIR}"/libcap-1.10-r4-staticfix.diff
epatch "${FILESDIR}"/libcap-1.10-nostrip.patch
+ epatch "${FILESDIR}"/libcap-1.10-headers.patch
sed -i -e 's|WARNINGS=-ansi|WARNINGS=|' Make.Rules
}