summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStratos Psomadakis <psomas@gentoo.org>2011-12-08 08:22:37 +0000
committerStratos Psomadakis <psomas@gentoo.org>2011-12-08 08:22:37 +0000
commitdeaa77835ad8f868539a19641d8b59131d839fe1 (patch)
tree9ca5e8bceb538b561073f6869d65f1fff6181104 /sys-kernel
parentMask USE=vanilla for gcc, since that results in a broken compiler on Prefix (diff)
downloadgentoo-2-deaa77835ad8f868539a19641d8b59131d839fe1.tar.gz
gentoo-2-deaa77835ad8f868539a19641d8b59131d839fe1.tar.bz2
gentoo-2-deaa77835ad8f868539a19641d8b59131d839fe1.zip
Version bump
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/rt-sources/ChangeLog8
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.0.12_p30.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-kernel/rt-sources/ChangeLog b/sys-kernel/rt-sources/ChangeLog
index fe81e364fb6a..40186000877d 100644
--- a/sys-kernel/rt-sources/ChangeLog
+++ b/sys-kernel/rt-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/rt-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.10 2011/12/02 13:28:41 psomas Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.11 2011/12/08 08:22:37 psomas Exp $
+
+*rt-sources-3.0.12_p30 (08 Dec 2011)
+
+ 08 Dec 2011; Stratos Psomadakis <psomas@gentoo.org>
+ +rt-sources-3.0.12_p30.ebuild:
+ Version bump
*rt-sources-3.0.12_p29 (02 Dec 2011)
diff --git a/sys-kernel/rt-sources/rt-sources-3.0.12_p30.ebuild b/sys-kernel/rt-sources/rt-sources-3.0.12_p30.ebuild
new file mode 100644
index 000000000000..15a4f5b1ad48
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.0.12_p30.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".gz"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+
+CKV="$(get_version_component_range 1-3)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+RT_PATCHSET="${PV/*_p}"
+RT_KERNEL="${PV/_p[0-9]*}"
+RT_KERNEL="${RT_KERNEL/_/-}"
+RT_FILE="patch-${RT_KERNEL}-rt${RT_PATCHSET}.patch${COMPRESSTYPE}"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${KV_MAJOR}.${KV_MINOR}/${RT_FILE}"
+
+DESCRIPTION="Real-time patchset for the Linux Kernel"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/projects/rt/"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="deblob"
+
+KV_FULL="${PVR/_p/-rt}"
+EXTRAVERSION="-rt${RT_PATCHSET}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${RT_FILE}"
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."