summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-21 14:18:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-21 14:18:39 +0000
commitdb349374322d2a82ddfb574e4047d4e58c59d85f (patch)
treefa22239c9200577f17409cae2f98fdd14a414c52 /sys-fs
parentQuickly fix dependency over test-unit. (diff)
downloadgentoo-2-db349374322d2a82ddfb574e4047d4e58c59d85f.tar.gz
gentoo-2-db349374322d2a82ddfb574e4047d4e58c59d85f.tar.bz2
gentoo-2-db349374322d2a82ddfb574e4047d4e58c59d85f.zip
Fix building with -Wl,--as-needed wrt #278437 by Kacper Kowalik.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/s3fs/ChangeLog6
-rw-r--r--sys-fs/s3fs/files/s3fs-177-asneeded.patch9
-rw-r--r--sys-fs/s3fs/s3fs-177-r1.ebuild15
3 files changed, 26 insertions, 4 deletions
diff --git a/sys-fs/s3fs/ChangeLog b/sys-fs/s3fs/ChangeLog
index d1c9fc151476..78442bdd0fa9 100644
--- a/sys-fs/s3fs/ChangeLog
+++ b/sys-fs/s3fs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/s3fs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/ChangeLog,v 1.3 2009/06/21 15:42:30 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/ChangeLog,v 1.4 2009/12/21 14:18:39 ssuominen Exp $
+
+ 21 Dec 2009; Samuli Suominen <ssuominen@gentoo.org> s3fs-177-r1.ebuild,
+ +files/s3fs-177-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #278437 by Kacper Kowalik.
*s3fs-177-r1 (21 Jun 2009)
diff --git a/sys-fs/s3fs/files/s3fs-177-asneeded.patch b/sys-fs/s3fs/files/s3fs-177-asneeded.patch
new file mode 100644
index 000000000000..63e5446009ae
--- /dev/null
+++ b/sys-fs/s3fs/files/s3fs-177-asneeded.patch
@@ -0,0 +1,9 @@
+--- s3fs.orig/Makefile 2008-05-19 19:34:38.000000000 +0200
++++ s3fs/Makefile 2009-10-19 22:10:55.810129401 +0200
+@@ -1,5 +1,5 @@
+ all:
+- g++ -ggdb -Wall $(shell pkg-config fuse --cflags --libs) $(shell pkg-config libcurl --cflags --libs) $(shell xml2-config --cflags --libs) -lcrypto s3fs.cpp -o s3fs
++ $(CXX) $(CXXFLAGS) s3fs.cpp -o s3fs $(shell pkg-config fuse --cflags --libs) $(shell pkg-config libcurl --cflags --libs) $(shell xml2-config --cflags --libs) -lcrypto
+ @echo ok!
+
+ install: all
diff --git a/sys-fs/s3fs/s3fs-177-r1.ebuild b/sys-fs/s3fs/s3fs-177-r1.ebuild
index f0a5c1bf630c..1188462c5378 100644
--- a/sys-fs/s3fs/s3fs-177-r1.ebuild
+++ b/sys-fs/s3fs/s3fs-177-r1.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/s3fs-177-r1.ebuild,v 1.1 2009/06/21 15:42:30 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/s3fs-177-r1.ebuild,v 1.2 2009/12/21 14:18:39 ssuominen Exp $
+
+inherit eutils toolchain-funcs
MY_PV="r${PV}-source"
DESCRIPTION="Amazon mounting S3 via fuse"
HOMEPAGE="http://s3fs.googlecode.com/"
SRC_URI="http://s3fs.googlecode.com/files/${PN}-${MY_PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -22,10 +25,16 @@ DEPEND=">=net-misc/curl-7.17.1
RDEPEND="${DEPEND}
app-misc/mime-types"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
src_compile() {
- emake || die "emake failed"
+ emake CXX="$(tc-getCXX)" || die
}
src_install() {
- dobin s3fs
+ dobin s3fs || die
}