summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-07-31 14:25:18 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-07-31 14:25:18 +0000
commit122a612d471b481ad4c6b7fe8e9ce10b94940906 (patch)
treec73bf2337a7380f528c1c03108e3dcc43600e69f /sys-fs
parentRemove old. (diff)
downloadgentoo-2-122a612d471b481ad4c6b7fe8e9ce10b94940906.tar.gz
gentoo-2-122a612d471b481ad4c6b7fe8e9ce10b94940906.tar.bz2
gentoo-2-122a612d471b481ad4c6b7fe8e9ce10b94940906.zip
Remove old.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/copyfs/ChangeLog9
-rw-r--r--sys-fs/copyfs/copyfs-1.0.ebuild35
-rw-r--r--sys-fs/copyfs/files/copyfs-1.0-gentoo.patch42
3 files changed, 6 insertions, 80 deletions
diff --git a/sys-fs/copyfs/ChangeLog b/sys-fs/copyfs/ChangeLog
index 6d7c2ee6148d..ac6457ba0d81 100644
--- a/sys-fs/copyfs/ChangeLog
+++ b/sys-fs/copyfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/copyfs
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/copyfs/ChangeLog,v 1.6 2010/09/20 20:16:26 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/copyfs/ChangeLog,v 1.7 2012/07/31 14:25:18 kensington Exp $
+
+ 31 Jul 2012; Michael Palimaka <kensington@gentoo.org> -copyfs-1.0.ebuild,
+ -files/copyfs-1.0-gentoo.patch:
+ Remove old.
*copyfs-1.0.1 (20 Sep 2010)
@@ -27,4 +31,3 @@
+files/copyfs-1.0-gentoo.patch, +files/copyfs-1.0-unlink.patch,
+copyfs-1.0.ebuild:
Initial import
-
diff --git a/sys-fs/copyfs/copyfs-1.0.ebuild b/sys-fs/copyfs/copyfs-1.0.ebuild
deleted file mode 100644
index e32f2676ffce..000000000000
--- a/sys-fs/copyfs/copyfs-1.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/copyfs/copyfs-1.0.ebuild,v 1.5 2007/07/02 15:32:49 peper Exp $
-
-inherit eutils
-DESCRIPTION="fuse-based filesystem for maintaining configuration files"
-HOMEPAGE="http://invaders.mars-attacks.org/~boklm/copyfs/"
-SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE=""
-#RESTRICT="strip"
-DEPEND=">=sys-fs/fuse-2.0
- sys-apps/attr"
-#RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd ${S} || die
-
- # this patch fixes sandbox violations
- epatch ${FILESDIR}/${P}-gentoo.patch
-
- # this patch adds support for cleaning up the versions directory
- # the patch is experimental at best, but it's better than your
- # versions directory filling up with unused files
- #
- # patch by stuart@gentoo.org
- epatch ${FILESDIR}/${P}-unlink.patch
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-}
diff --git a/sys-fs/copyfs/files/copyfs-1.0-gentoo.patch b/sys-fs/copyfs/files/copyfs-1.0-gentoo.patch
deleted file mode 100644
index aabf14ee4855..000000000000
--- a/sys-fs/copyfs/files/copyfs-1.0-gentoo.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -u --recursive copyfs-1.0/Makefile.in copyfs-1.0-gentoo/Makefile.in
---- copyfs-1.0/Makefile.in 2004-12-10 13:34:08.000000000 +0000
-+++ copyfs-1.0-gentoo/Makefile.in 2004-12-16 20:34:44.724159540 +0000
-@@ -27,8 +27,9 @@
- all: $(TARGET)
-
- install: $(TARGET) $(SCRIPTS)
-- install -o root -g root -m 755 $(TARGET) /usr/local/bin
-- install -o root -g root -m 755 $(SCRIPTS) /usr/local/bin
-+ @mkdir -p $(DESTDIR)/usr/bin
-+ install -o root -g root -m 755 $(TARGET) $(DESTDIR)/usr/bin
-+ install -o root -g root -m 755 $(SCRIPTS) $(DESTDIR)/usr/bin
-
- clean:
- rm -f *~ $(OBJ) \#*\#
-diff -u --recursive copyfs-1.0/ea.c copyfs-1.0-gentoo/ea.c
---- copyfs-1.0/ea.c 2004-12-10 13:34:08.000000000 +0000
-+++ copyfs-1.0-gentoo/ea.c 2004-12-16 20:36:03.868144344 +0000
-@@ -1,10 +1,11 @@
- #include <sys/types.h>
- #include <sys/stat.h>
--#include <attr/xattr.h>
-+#include <sys/xattr.h>
- #include <string.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <fuse.h>
-+#include <sys/errno.h>
-
- #include "helper.h"
- #include "structs.h"
---- copyfs-1.0/interface.c 2004-12-16 20:37:56.214420764 +0000
-+++ copyfs-1.0-gentoo/interface.c 2004-12-16 20:38:03.196008992 +0000
-@@ -23,7 +23,7 @@
- #include <errno.h>
- #include <sys/stat.h>
- #include <stdlib.h>
--#include <attr/xattr.h>
-+#include <sys/xattr.h>
- #include <sys/time.h>
- #include <time.h>
-