summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2005-12-08 18:38:02 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2005-12-08 18:38:02 +0000
commitd7e38f19e3855846403b9fb022e0b23b798400a9 (patch)
tree87d1ebdb35729f5cd456714d77de091a662e91f4 /sys-fs/udev
parentStable on hppa. (diff)
downloadgentoo-2-d7e38f19e3855846403b9fb022e0b23b798400a9.tar.gz
gentoo-2-d7e38f19e3855846403b9fb022e0b23b798400a9.tar.bz2
gentoo-2-d7e38f19e3855846403b9fb022e0b23b798400a9.zip
077-r2 release, changes to udev-start.sh
(Portage version: 2.0.53)
Diffstat (limited to 'sys-fs/udev')
-rw-r--r--sys-fs/udev/ChangeLog12
-rw-r--r--sys-fs/udev/Manifest3
-rw-r--r--sys-fs/udev/files/digest-udev-077-r21
-rw-r--r--sys-fs/udev/files/udev-start-077-r2.sh164
-rw-r--r--sys-fs/udev/udev-077-r2.ebuild207
5 files changed, 386 insertions, 1 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 85b8a81aaf7c..d0038644fe66 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.158 2005/12/07 22:36:45 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.159 2005/12/08 18:38:02 gregkh Exp $
+
+*udev-077-r2 (08 Dec 2005)
+
+ 08 Dec 2005; Greg Kroah-Hartman <gregkh@gentoo.org>
+ +files/udev-start-077-r2.sh, +udev-077-r2.ebuild:
+ changes to udev-start.sh to handle the good features in the 2.6.15 kernel
+ release (only use netlink, faster startup time using uevent, etc.)
+
+ Everything should still work just fine for older kernel releases, if not,
+ please enter bugs.
*udev-077-r1 (07 Dec 2005)
diff --git a/sys-fs/udev/Manifest b/sys-fs/udev/Manifest
index cbf9ccce5d8c..9271881403d2 100644
--- a/sys-fs/udev/Manifest
+++ b/sys-fs/udev/Manifest
@@ -7,9 +7,11 @@ MD5 4e8f7bc5bce2959bd11ae13fdd04a247 files/digest-udev-072 61
MD5 76a7034314dedfa3554108a616210e88 files/digest-udev-073 61
MD5 918aa5f6b5b4a478bcda926d0a41f28a files/digest-udev-077 61
MD5 918aa5f6b5b4a478bcda926d0a41f28a files/digest-udev-077-r1 61
+MD5 918aa5f6b5b4a478bcda926d0a41f28a files/digest-udev-077-r2 61
MD5 f00e3e0d3382e93cbd0c64fcef99f826 files/udev-021-udev_add_c-gcc295-compat.patch 493
MD5 7b0a35c905183730e4dfdcf29f5a1816 files/udev-050-udev_volume_id.patch 388
MD5 3bcc6c8d9c7a3cf7ff0d3b5a36bde3d6 files/udev-parisc-path_id.patch 706
+MD5 dc1c3d4e7f5a5bba2c74e03a9e9d9259 files/udev-start-077-r2.sh 4078
MD5 1e0a70ed330f1c72a042ad41ce79fcf1 files/udev-start-077.sh 2570
MD5 622f085dff7fb6138f3e2c992d569593 files/udev-start.sh 2460
MD5 787f5b398376f9e3dbec228681150173 files/udev-stop.sh 2012
@@ -34,4 +36,5 @@ MD5 81f1035916968128390fef68bd7ae7a6 udev-071.ebuild 6759
MD5 1c2f39137e776ead6a5c022aa80f076b udev-072.ebuild 6983
MD5 2323e2f8802a6e2d5dd3c73d9669b83d udev-073.ebuild 6983
MD5 f69e426e47bd01dd952db7f7c952af2b udev-077-r1.ebuild 6889
+MD5 87eca002e841e055b153c48a8ec4e98e udev-077-r2.ebuild 6892
MD5 4cf7b677380f3571eec3dc7326e984b2 udev-077.ebuild 6845
diff --git a/sys-fs/udev/files/digest-udev-077-r2 b/sys-fs/udev/files/digest-udev-077-r2
new file mode 100644
index 000000000000..d4ff64912f29
--- /dev/null
+++ b/sys-fs/udev/files/digest-udev-077-r2
@@ -0,0 +1 @@
+MD5 61ec646daf7795e9777e8f33975408fe udev-077.tar.bz2 222315
diff --git a/sys-fs/udev/files/udev-start-077-r2.sh b/sys-fs/udev/files/udev-start-077-r2.sh
new file mode 100644
index 000000000000..d18764fb3bf1
--- /dev/null
+++ b/sys-fs/udev/files/udev-start-077-r2.sh
@@ -0,0 +1,164 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+udev_version() {
+ local version=0
+
+ if [[ -x /sbin/udev ]] ; then
+ version=$(/sbin/udev -V)
+ # We need it without a leading '0', else bash do the wrong thing
+ version=${version##0}
+ # Older udev's will print nothing
+ [[ -z ${version} ]] && version=0
+ fi
+
+ echo "${version}"
+}
+
+# This works for 2.6.15 kernels or greater
+trigger_events() {
+ list=""
+ # if you want real coldplug (with all modules being loaded for all
+ # devices in the system), uncomment out the next line.
+ #list="$list $(echo /sys/bus/*/devices/*/uevent)"
+ list="$list $(echo /sys/class/*/*/uevent)"
+ list="$list $(echo /sys/block/*/uevent /sys/block/*/*/uevent)"
+ for i in $list; do
+ case "$i" in
+ */device/uevent)
+ # skip followed device symlinks
+ continue
+ ;;
+ */class/mem/*|*/class/tty/*)
+ first="$first $i"
+ ;;
+ */block/md*)
+ last="$last $i"
+ ;;
+ */*)
+ default="$default $i"
+ ;;
+ esac
+ done
+
+ # trigger the sorted events
+ for i in $first $default $last; do
+ echo "add" > "$i"
+ done
+}
+
+populate_udev() {
+ # populate /dev with devices already found by the kernel
+ if [ "$(get_KV)" -gt "$(KV_to_int '2.6.14')" ] ; then
+ ebegin "Populating /dev with existing devices through uevents"
+ trigger_events
+ eend 0
+ else
+ ebegin "Populating /dev with existing devices with udevstart"
+ /sbin/udevstart
+ eend 0
+ fi
+
+ # loop until everything is finished
+ # there's gotta be a better way...
+ ebegin "Letting udev process events"
+ loop=0
+ while test -d /dev/.udev/queue; do
+ sleep 0.1;
+ test "$loop" -gt 300 && break
+ loop=$(($loop + 1))
+ done
+ #einfo "loop = $loop"
+ eend 0
+
+ ebegin "Finializing udev configuration"
+
+ # Not provided by sysfs but needed
+ ln -snf /proc/self/fd /dev/fd
+ ln -snf fd/0 /dev/stdin
+ ln -snf fd/1 /dev/stdout
+ ln -snf fd/2 /dev/stderr
+ [[ -e /proc/kcore ]] && ln -snf /proc/kcore /dev/core
+
+ # Create nodes that udev can't
+ [[ -x /sbin/dmsetup ]] && /sbin/dmsetup mknodes &>/dev/null
+ [[ -x /sbin/lvm ]] && \
+ /sbin/lvm vgscan -P --mknodes --ignorelockingfailure &>/dev/null
+ [[ -x /sbin/evms_activate ]] && /sbin/evms_activate -q &>/dev/null
+
+ # Create problematic directories
+ mkdir -p /dev/{pts,shm}
+
+ # copy over any persistant things
+ cp --preserve=all --recursive --update /lib/udev/devices/* /dev
+
+ # Same thing as /dev/.devfsd
+ touch /dev/.udev
+ eend 0
+
+ return 0
+}
+
+main() {
+ # Setup temporary storage for /dev
+ ebegin "Mounting /dev for udev"
+ if [[ ${RC_USE_FSTAB} == "yes" ]] ; then
+ mntcmd=$(get_mount_fstab /dev)
+ else
+ unset mntcmd
+ fi
+ if [[ -n ${mntcmd} ]] ; then
+ try mount -n ${mntcmd}
+ else
+ if egrep -qs tmpfs /proc/filesystems ; then
+ mntcmd="tmpfs"
+ else
+ mntcmd="ramfs"
+ fi
+ # many video drivers require exec access in /dev #92921
+ try mount -n -t ${mntcmd} udev /dev -o exec,nosuid,mode=0755
+ fi
+ eend $?
+
+ # Selinux lovin; /selinux should be mounted by selinux-patched init
+ if [[ -x /sbin/restorecon && -c /selinux/null ]] ; then
+ restorecon /dev &> /selinux/null
+ fi
+
+ # Actually get udev rolling
+ if [[ ${RC_DEVICE_TARBALL} == "yes" && \
+ -s /lib/udev-state/devices.tar.bz2 ]] ; then
+ ebegin "Populating /dev with saved device nodes"
+ try tar -jxpf /lib/udev-state/devices.tar.bz2 -C /dev
+ eend $?
+ fi
+
+ # Setup hotplugging (if possible)
+ ebegin "Setting up proper hotplug agent"
+ if [[ -e /proc/sys/kernel/hotplug ]] ; then
+ if [ "$(get_KV)" -gt "$(KV_to_int '2.6.14')" ] ; then
+ einfo " Using netlink for hotplug events..."
+ echo "" > /proc/sys/kernel/hotplug
+ elif [[ $(udev_version) -ge "48" ]] ; then
+ einfo " Setting /sbin/udevsend as hotplug agent ..."
+ echo "/sbin/udevsend" > /proc/sys/kernel/hotplug
+ elif [[ -x /sbin/hotplug ]] ; then
+ einfo " Using /sbin/hotplug as hotplug agent ..."
+ else
+ einfo " Setting /sbin/udev as hotplug agent ..."
+ echo "/sbin/udev" > /proc/sys/kernel/hotplug
+ fi
+ fi
+ eend 0
+
+ ebegin "Starting udevd"
+ /sbin/udevd --daemon
+ eend $?
+
+ populate_udev
+}
+
+main
+
+
+# vim:ts=4
diff --git a/sys-fs/udev/udev-077-r2.ebuild b/sys-fs/udev/udev-077-r2.ebuild
new file mode 100644
index 000000000000..9793ef4369ff
--- /dev/null
+++ b/sys-fs/udev/udev-077-r2.ebuild
@@ -0,0 +1,207 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-077-r2.ebuild,v 1.1 2005/12/08 18:38:02 gregkh Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="sys-apps/hotplug-base"
+RDEPEND="${DEPEND}
+ >=sys-apps/baselayout-1.8.6.12-r3"
+# We need some changes for devfs type layout
+PROVIDE="virtual/dev-manager"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # patches go here...
+ #epatch ${FILESDIR}/${P}-udev_volume_id.patch
+ epatch ${FILESDIR}/udev-parisc-path_id.patch
+
+ # No need to clutter the logs ...
+ sed -ie '/^DEBUG/ c\DEBUG = false' Makefile
+ # Do not use optimization flags from the package
+ sed -ie 's|$(OPTIMIZATION)||g' Makefile
+
+ # Make sure there is no sudden changes to udev.rules.gentoo
+ # (more for my own needs than anything else ...)
+ MD5=`md5sum < "${S}/etc/udev/gentoo/udev.rules"`
+ MD5=${MD5/ -/}
+ if [ "${MD5}" != "84fa41fd643ad2afeb922b3048cfd05f" ]
+ then
+ echo
+ eerror "gentoo/udev.rules has been updated, please validate!"
+ die "gentoo/udev.rules has been updated, please validate!"
+ fi
+}
+
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+ local myconf=
+ local extras="extras/scsi_id extras/volume_id extras/ata_id extras/run_directory extras/usb_id extras/floppy extras/cdrom_id extras/firmware"
+
+ use selinux && myconf="${myconf} USE_SELINUX=true"
+
+ # Not everyone has full $CHOST-{ld,ar,etc...} yet
+ local mycross=""
+ type -p ${CHOST}-ar && mycross=${CHOST}-
+
+ # Do not work with emake
+ make \
+ EXTRAS="${extras}" \
+ udevdir="/dev/" \
+ CROSS=${mycross} \
+ ${myconf} || die
+}
+
+src_install() {
+ # we install everything by "hand" and don't rely on the udev Makefile to do
+ # it for us (why? it's easier that way...)
+ dobin udevinfo
+ dobin udevtest
+ dobin udevmonitor
+ into /
+ dosbin udev
+ dosbin udevd
+ dosbin udevsend
+ dosbin udevstart
+ dosbin udevcontrol
+ dosbin extras/run_directory/udev_run_devd
+ dosbin extras/run_directory/udev_run_hotplugd
+ dosbin extras/ata_id/ata_id
+ dosbin extras/volume_id/vol_id
+ dosbin extras/scsi_id/scsi_id
+ dosbin extras/usb_id/usb_id
+ dosbin extras/cdrom_id/cdrom_id
+ dosbin extras/path_id
+ dosbin extras/floppy/create_floppy_devices
+ dosbin extras/firmware/firmware_helper
+
+ #exeinto /etc/udev/scripts
+ exeinto /lib/udev
+ #doexe extras/ide-devfs.sh
+ #doexe extras/scsi-devfs.sh
+ doexe extras/raid-devfs.sh
+
+ # Our udev config file
+ insinto /etc/udev
+ newins ${FILESDIR}/udev.conf.post_059 udev.conf
+
+ # Our rules files
+ insinto /etc/udev/rules.d/
+ #newins etc/udev/gentoo/udev.rules 50-udev.rules
+ newins ${FILESDIR}/udev.rules-077-r1 50-udev.rules
+
+ # scsi_id configuration
+ insinto /etc
+ doins extras/scsi_id/scsi_id.config
+
+ # set up symlinks in /etc/hotplug.d/default
+ dodir /etc/hotplug.d/default
+ dosym ../../../sbin/udevsend /etc/hotplug.d/default/10-udev.hotplug
+
+ # set up the /etc/dev.d directory tree
+ dodir /etc/dev.d/default
+ dodir /etc/dev.d/net
+ exeinto /etc/dev.d/net
+ doexe extras/run_directory/dev.d/net/hotplug.dev
+
+ # all of the man pages
+ doman *.8
+ doman extras/ata_id/ata_id.8
+ doman extras/edd_id/edd_id.8
+ doman extras/scsi_id/scsi_id.8
+ doman extras/volume_id/vol_id.8
+ doman extras/dasd_id/dasd_id.8
+ doman extras/cdrom_id/cdrom_id.8
+
+ # our udev hooks into the rc system
+ insinto /lib/rcscripts/addons
+ newins "${FILESDIR}"/udev-start-077-r2.sh udev-start.sh
+ doins "${FILESDIR}"/udev-stop.sh
+
+ dodoc ChangeLog FAQ README TODO RELEASE-NOTES
+ dodoc docs/{overview,udev_vs_devfs}
+ dodoc docs/writing_udev_rules/*
+
+ newdoc extras/volume_id/README README_volume_id
+}
+
+pkg_preinst() {
+ if [ -f "${ROOT}/etc/udev/udev.config" -a \
+ ! -f "${ROOT}/etc/udev/udev.rules" ]
+ then
+ mv -f ${ROOT}/etc/udev/udev.config ${ROOT}/etc/udev/udev.rules
+ fi
+
+ # delete the old udev.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/udev.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" -a -n "`pidof udevd`" ]
+ then
+ killall -15 udevd &>/dev/null
+ sleep 1
+ killall -9 udevd &>/dev/null
+ fi
+
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+ ewarn "Note: If you are upgrading from a version of udev prior to 046"
+ ewarn " and you rely on the output of udevinfo for anything, please"
+ ewarn " either run 'udevstart' now, or reboot, in order to get a"
+ ewarn " up-to-date udev database."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 050"
+ ewarn " and you had written some custom permissions rules, please"
+ ewarn " realize that the permission rules are now part of the main"
+ ewarn " udev rules files and are not stand-alone anymore. This means"
+ ewarn " you need to rewrite them."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 057"
+ ewarn " and you have written custom rules, and rely on the etc/dev.d/"
+ ewarn " functionality, please read the RELEASE-NOTES file for details"
+ ewarn " on what has changed with this feature, and how to change your"
+ ewarn " rules to work properly."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 059"
+ ewarn " and you have written custom rules, and rely on the etc/dev.d/"
+ ewarn " functionality, or the etc/hotplug.d functionality, or just"
+ ewarn " want to write some very cool and power udev rules, please "
+ ewarn " read the RELEASE-NOTES file for details on what has changed"
+ ewarn " with this feature, and how to change your rules to work properly."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 063"
+ ewarn " and you use the devfs-style names for your block devices"
+ ewarn " or use devfs-style names in /etc/inittab or /etc/securetty or"
+ ewarn " your GRUB or LILO kernel boot command line, you need to"
+ ewarn " change them back to LSB compliant names, as the devfs names are"
+ ewarn " now gone. If you wish to use some persistent names for your"
+ ewarn " block devices, look at the symlinks in /dev/disk/ for the names"
+ ewarn " you can use."
+
+ einfo
+ einfo "For more information on udev on Gentoo, writing udev rules, and"
+ einfo " fixing known issues visit:"
+ einfo " http://www.gentoo.org/doc/en/udev-guide.xml"
+}