summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-15 17:46:26 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-15 17:46:26 +0000
commitac473605b2a5b4138218869a7f6140686c664e1c (patch)
treeaeabad1544e1c315445e0d3361afa57a8e40b715 /sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild
parentadded filesystem related apps to sys-fs from sys-apps (diff)
downloadgentoo-2-ac473605b2a5b4138218869a7f6140686c664e1c.tar.gz
gentoo-2-ac473605b2a5b4138218869a7f6140686c664e1c.tar.bz2
gentoo-2-ac473605b2a5b4138218869a7f6140686c664e1c.zip
added filesystem related apps to sys-fs from sys-apps
Diffstat (limited to 'sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild')
-rw-r--r--sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild b/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild
new file mode 100644
index 000000000000..8334c778ebd5
--- /dev/null
+++ b/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.17-r1.ebuild,v 1.1 2003/09/15 17:46:24 seemant Exp $
+
+IUSE="static"
+
+DESCRIPTION="EXT2 and EXT3 filesystem resizing utilities"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://ext2resize.sourceforge.net/"
+KEYWORDS="x86 amd64 ~ppc ~sparc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ if [ "`use static`" ]; then
+ LDFLAGS="${LDFLAGS} -static"
+ fi
+
+ econf --exec-prefix="${D}/"|| die "Configure failed"
+
+ emake LDFLAGS="${LDFLAGS}"|| die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodir /usr/sbin
+ dosym /sbin/ext2online /usr/sbin/ext2online
+ dosym /sbin/ext2prepare /usr/sbin/ext2prepare
+ dosym /sbin/ext2resize /usr/sbin/ext2resize
+
+}