summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-08-31 06:11:13 +0000
committerTim Harder <radhermit@gentoo.org>2014-08-31 06:11:13 +0000
commitc6f58813ade81a5967159a46e4aee55346879271 (patch)
treee3142e6da9dea18a906d91729dfc8700a9d67b02 /sys-fs/avfs
parentVersion bump. (diff)
downloadgentoo-2-c6f58813ade81a5967159a46e4aee55346879271.tar.gz
gentoo-2-c6f58813ade81a5967159a46e4aee55346879271.tar.bz2
gentoo-2-c6f58813ade81a5967159a46e4aee55346879271.zip
Version bump (bug #516866).
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'sys-fs/avfs')
-rw-r--r--sys-fs/avfs/ChangeLog7
-rw-r--r--sys-fs/avfs/avfs-1.0.2.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-fs/avfs/ChangeLog b/sys-fs/avfs/ChangeLog
index 499a65d2a16f..2797011f2b26 100644
--- a/sys-fs/avfs/ChangeLog
+++ b/sys-fs/avfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/avfs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.50 2014/08/10 20:19:19 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.51 2014/08/31 06:11:12 radhermit Exp $
+
+*avfs-1.0.2 (31 Aug 2014)
+
+ 31 Aug 2014; Tim Harder <radhermit@gentoo.org> +avfs-1.0.2.ebuild:
+ Version bump (bug #516866).
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> avfs-1.0.1.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/sys-fs/avfs/avfs-1.0.2.ebuild b/sys-fs/avfs/avfs-1.0.2.ebuild
new file mode 100644
index 000000000000..9b9f4807a180
--- /dev/null
+++ b/sys-fs/avfs/avfs-1.0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-1.0.2.ebuild,v 1.1 2014/08/31 06:11:13 radhermit Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files"
+HOMEPAGE="http://sourceforge.net/projects/avf"
+SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs +lzma"
+
+RDEPEND=">=sys-fs/fuse-2.4
+ sys-libs/zlib
+ app-arch/bzip2
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-fuse \
+ --enable-library \
+ --enable-shared \
+ --with-system-zlib \
+ --with-system-bzlib \
+ $(use_enable static-libs static) \
+ $(use_with lzma xz)
+}
+
+src_install() {
+ default
+
+ # remove cruft
+ rm "${D}"/usr/bin/{davpass,ftppass} || die
+
+ # install docs
+ dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+
+ docinto scripts
+ dodoc scripts/{avfscoda*,*pass}
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ einfo "This version of AVFS includes FUSE support. It is user-based."
+ einfo "To execute:"
+ einfo "1) as user, mkdir ~/.avfs"
+ einfo "2) make sure fuse is either compiled into the kernel OR"
+ einfo " modprobe fuse or add to startup."
+ einfo "3) run mountavfs"
+ einfo "To unload daemon, type umountavfs"
+ einfo
+ einfo "READ the documentation! Enjoy :)"
+}