summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-09 00:04:37 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-09 00:04:37 +0000
commit34ca6f95c27f531a613b9037f5092f5027546315 (patch)
treedf11a9baf80544d945875cf86d62e2373e433838 /sys-devel/gdb
parentClean up sysroot handling a bit -- no real functional changes. (diff)
downloadgentoo-2-34ca6f95c27f531a613b9037f5092f5027546315.tar.gz
gentoo-2-34ca6f95c27f531a613b9037f5092f5027546315.tar.bz2
gentoo-2-34ca6f95c27f531a613b9037f5092f5027546315.zip
Convert python support to use python-single-r1 and allow python 2.7 and 3.3 versions #503852 by Nikoli.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/ChangeLog7
-rw-r--r--sys-devel/gdb/gdb-7.7.ebuild20
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild20
3 files changed, 16 insertions, 31 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 77e09fa35b4f..0e316ab4984f 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gdb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.261 2014/03/08 23:59:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.262 2014/03/09 00:04:37 vapier Exp $
+
+ 09 Mar 2014; Mike Frysinger <vapier@gentoo.org> gdb-7.7.ebuild,
+ gdb-9999.ebuild:
+ Convert python support to use python-single-r1 and allow python 2.7 and 3.3
+ versions #503852 by Nikoli.
08 Mar 2014; Mike Frysinger <vapier@gentoo.org> gdb-7.6.1.ebuild,
gdb-7.6.2.ebuild, gdb-7.6.ebuild, gdb-7.7.ebuild, gdb-9999.ebuild:
diff --git a/sys-devel/gdb/gdb-7.7.ebuild b/sys-devel/gdb/gdb-7.7.ebuild
index 69255bcdc599..d8ca55c4ac55 100644
--- a/sys-devel/gdb/gdb-7.7.ebuild
+++ b/sys-devel/gdb/gdb-7.7.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.7.ebuild,v 1.3 2014/03/08 23:59:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.7.ebuild,v 1.4 2014/03/09 00:04:37 vapier Exp $
EAPI="4"
+PYTHON_COMPAT=( python{2_7,3_3} )
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils python-single-r1
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -59,7 +60,7 @@ RDEPEND="!dev-util/gdbserver
sys-libs/readline
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
- python? ( =dev-lang/python-2* )
+ python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
app-arch/xz-utils
@@ -73,17 +74,6 @@ src_prepare() {
[[ -n ${RPM} ]] && rpm_spec_epatch "${WORKDIR}"/gdb.spec
use vanilla || [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
strip-linguas -u bfd/po opcodes/po
- if [[ ${CHOST} == *-darwin* ]] ; then
- # make sure we have a python-config that matches our install,
- # such that the python check doesn't fail just because the
- # gdb-provided copy isn't quite what our python installed
- # version is
- rm -f "${S}"/gdb/python/python-config.py || die
- pushd "${S}"/gdb/python > /dev/null || die
- ln -s "${EROOT}"/usr/bin/$(eselect python show --python2)-config \
- python-config.py || die
- popd > /dev/null || die
- fi
}
gdb_branding() {
@@ -141,7 +131,7 @@ src_configure() {
$(use_with lzma)
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
- $(use_with python python "${EPREFIX}/usr/bin/python2")
+ $(use_with python python "${EPYTHON}")
$(use_with zlib)
)
fi
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index ab725dbe355c..14655f445118 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.23 2014/03/08 23:59:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.24 2014/03/09 00:04:37 vapier Exp $
EAPI="4"
+PYTHON_COMPAT=( python{2_7,3_3} )
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils python-single-r1
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -59,7 +60,7 @@ RDEPEND="!dev-util/gdbserver
sys-libs/readline
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
- python? ( =dev-lang/python-2* )
+ python? ( ${PYTHON_DEPS} )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
app-arch/xz-utils
@@ -73,17 +74,6 @@ src_prepare() {
[[ -n ${RPM} ]] && rpm_spec_epatch "${WORKDIR}"/gdb.spec
use vanilla || [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
strip-linguas -u bfd/po opcodes/po
- if [[ ${CHOST} == *-darwin* ]] ; then
- # make sure we have a python-config that matches our install,
- # such that the python check doesn't fail just because the
- # gdb-provided copy isn't quite what our python installed
- # version is
- rm -f "${S}"/gdb/python/python-config.py || die
- pushd "${S}"/gdb/python > /dev/null || die
- ln -s "${EROOT}"/usr/bin/$(eselect python show --python2)-config \
- python-config.py || die
- popd > /dev/null || die
- fi
}
gdb_branding() {
@@ -141,7 +131,7 @@ src_configure() {
$(use_with lzma)
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
- $(use_with python python "${EPREFIX}/usr/bin/python2")
+ $(use_with python python "${EPYTHON}")
$(use_with zlib)
)
fi