summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-02-05 02:59:51 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-02-05 02:59:51 +0000
commit3529cc7369819af727aea866ec4aaa1f4e40e4e7 (patch)
treeb5e3417211101df90542db73a53c763e733236d4 /sys-cluster/osc-mpiexec
parentgoogle-gadgets-0.10.5 ~ppc64 for kde borkage (diff)
downloadgentoo-2-3529cc7369819af727aea866ec4aaa1f4e40e4e7.tar.gz
gentoo-2-3529cc7369819af727aea866ec4aaa1f4e40e4e7.tar.bz2
gentoo-2-3529cc7369819af727aea866ec4aaa1f4e40e4e7.zip
Adding sys-cluster/osc-mpiexec-0.83. Basically this is a revbump to sys-cluster/mpiexec and cleanup of the ebuild. However, we also move the installed mpiexec* files to osc-mpiexec* so that this package can coexist with the newer MPI implementations implementing MPI-2.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/osc-mpiexec')
-rw-r--r--sys-cluster/osc-mpiexec/ChangeLog13
-rw-r--r--sys-cluster/osc-mpiexec/metadata.xml5
-rw-r--r--sys-cluster/osc-mpiexec/osc-mpiexec-0.83.ebuild64
3 files changed, 82 insertions, 0 deletions
diff --git a/sys-cluster/osc-mpiexec/ChangeLog b/sys-cluster/osc-mpiexec/ChangeLog
new file mode 100644
index 000000000000..6973f610346b
--- /dev/null
+++ b/sys-cluster/osc-mpiexec/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sys-cluster/osc-mpiexec
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/osc-mpiexec/ChangeLog,v 1.1 2009/02/05 02:59:51 jsbronder Exp $
+
+*osc-mpiexec-0.83 (05 Feb 2009)
+
+ 05 Feb 2009; Justin Bronder <jsbronder@gentoo.org> +metadata.xml,
+ +osc-mpiexec-0.83.ebuild:
+ Adding sys-cluster/osc-mpiexec-0.83. Basically this is a revbump to
+ sys-cluster/mpiexec and cleanup of the ebuild. However, we also move the
+ installed mpiexec* files to osc-mpiexec* so that this package can coexist
+ with the newer MPI implementations implementing MPI-2.
+
diff --git a/sys-cluster/osc-mpiexec/metadata.xml b/sys-cluster/osc-mpiexec/metadata.xml
new file mode 100644
index 000000000000..8f0aa7fc46e8
--- /dev/null
+++ b/sys-cluster/osc-mpiexec/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>hp-cluster</herd>
+</pkgmetadata>
diff --git a/sys-cluster/osc-mpiexec/osc-mpiexec-0.83.ebuild b/sys-cluster/osc-mpiexec/osc-mpiexec-0.83.ebuild
new file mode 100644
index 000000000000..f1380dd85f24
--- /dev/null
+++ b/sys-cluster/osc-mpiexec/osc-mpiexec-0.83.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/osc-mpiexec/osc-mpiexec-0.83.ebuild,v 1.1 2009/02/05 02:59:51 jsbronder Exp $
+
+MY_PN=${PN#osc-}
+DESCRIPTION="replacement for mpirun, integrates MPI with PBS."
+SRC_URI="http://www.osc.edu/~pw/mpiexec/${MY_PN}-${PV}.tgz"
+HOMEPAGE="http://www.osc.edu/~pw/mpiexec/"
+
+DEPEND="sys-cluster/torque"
+RDEPEND="${DEPEND}
+ net-misc/openssh"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+RESTRICT="test"
+# The test suite that is included with the source requires
+# the ability to qsub a number of jobs. Such behavior
+# obviously does not belong in the ebuild.
+
+src_compile() {
+ local c="--with-default-comm=mpich-p4
+ --with-pbs=/usr/
+ --with-mpicc=/usr/bin/mpicc
+ --with-mpif77=/usr/bin/mpif77"
+
+ # The following at the recommendation of README, Cray specific.
+ c="${c} --disable-mpich-rai"
+
+ econf ${c} || die
+ emake || die "compile failed"
+}
+
+src_install() {
+ local f
+ emake DESTDIR="${D}" install
+
+ # And the following so that osc-mpiexec doesn't conflict with
+ # the packaged mpiexec's that all the MPI-2 implementations have.
+ for f in $(find "${D}" -name 'mpiexec*'); do
+ mv ${f} $(dirname ${f})/osc-$(basename ${f}) \
+ || die "Failed to prefix binary ${f} with osc-"
+ done
+
+ dodoc README README.lam ChangeLog
+}
+
+pkg_postinst() {
+ elog "The OSC Mpiexec package typically installs it's binaries"
+ elog "and manpages as 'mpiexec'. However, this ebuild renames"
+ elog "those to be prefixed with 'osc-' in order to avoid blocking"
+ elog "against the exact packages that osc-mpiexec is meant to"
+ elog "work with."
+ elog
+ elog "The default communication device has been set to mpich-p4"
+ elog "(ethernet). If you wish to use another communication"
+ elog "device, either set MPIEXEC_COMM in your environment or use"
+ elog "the --comm argument to mpiexec."
+}