summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-10-06 13:38:35 +0000
committerIan Delaney <idella4@gentoo.org>2013-10-06 13:38:35 +0000
commitccea577319aa05c5458fff1eb2f0cc8837f63ca4 (patch)
treefafec6c2ef877af1f465a936d900d8af76cb656e /sys-cluster/nova
parentrevbump (patch: fix stderr mess) (diff)
downloadgentoo-2-ccea577319aa05c5458fff1eb2f0cc8837f63ca4.tar.gz
gentoo-2-ccea577319aa05c5458fff1eb2f0cc8837f63ca4.tar.bz2
gentoo-2-ccea577319aa05c5458fff1eb2f0cc8837f63ca4.zip
add openstack herd to metadata.xml & disabled stub for test phase in 2013.1.3-r6
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'sys-cluster/nova')
-rw-r--r--sys-cluster/nova/ChangeLog7
-rw-r--r--sys-cluster/nova/metadata.xml1
-rw-r--r--sys-cluster/nova/nova-2013.1.3-r6.ebuild9
3 files changed, 13 insertions, 4 deletions
diff --git a/sys-cluster/nova/ChangeLog b/sys-cluster/nova/ChangeLog
index 571b29a752a3..13efe9cd31f9 100644
--- a/sys-cluster/nova/ChangeLog
+++ b/sys-cluster/nova/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/nova
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.30 2013/09/27 01:41:21 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.31 2013/10/06 13:38:35 idella4 Exp $
+
+ 06 Oct 2013; Ian Delaney <idella4@gentoo.org> metadata.xml,
+ nova-2013.1.3-r6.ebuild:
+ add openstack herd to metadata.xml & disabled stub for test phase in
+ 2013.1.3-r6
27 Sep 2013; Matthew Thode <prometheanfire@gentoo.org> metadata.xml,
nova-2012.2.4-r10.ebuild, nova-2013.1.3-r6.ebuild, nova-2013.1.9999.ebuild,
diff --git a/sys-cluster/nova/metadata.xml b/sys-cluster/nova/metadata.xml
index ead7f52988a3..e0397817f1d3 100644
--- a/sys-cluster/nova/metadata.xml
+++ b/sys-cluster/nova/metadata.xml
@@ -1,6 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <herd>openstack</herd>
<maintainer>
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
diff --git a/sys-cluster/nova/nova-2013.1.3-r6.ebuild b/sys-cluster/nova/nova-2013.1.3-r6.ebuild
index b509a1e2403f..90f4252a9391 100644
--- a/sys-cluster/nova/nova-2013.1.3-r6.ebuild
+++ b/sys-cluster/nova/nova-2013.1.3-r6.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.3-r6.ebuild,v 1.2 2013/09/27 01:41:21 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.3-r6.ebuild,v 1.3 2013/10/06 13:38:35 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 eutils multilib
-DESCRIPTION="Nova is a cloud computing fabric controller (main part of an
-IaaS system). It is written in Python."
+DESCRIPTION="A cloud computing fabric controller (main part of an IaaS system) written in Python."
HOMEPAGE="https://launchpad.net/nova"
SRC_URI="http://launchpad.net/${PN}/grizzly/${PV}/+download/${P}.tar.gz"
@@ -76,6 +75,10 @@ pkg_setup() {
enewuser nova -1 -1 /var/lib/nova nova
}
+#python_test() {
+# nosetests || die
+#}
+
python_install() {
distutils-r1_python_install
newconfd "${FILESDIR}/nova-confd" "nova"