summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-27 01:41:21 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-27 01:41:21 +0000
commit2cf3dfc52797cd337b10a0b13ec2357473a4caba (patch)
treeef4ed34e0c90b3053075d8b8189c7fe1e582d9f4 /sys-cluster/nova
parentinitial commit of novnc for nova (diff)
downloadgentoo-2-2cf3dfc52797cd337b10a0b13ec2357473a4caba.tar.gz
gentoo-2-2cf3dfc52797cd337b10a0b13ec2357473a4caba.tar.bz2
gentoo-2-2cf3dfc52797cd337b10a0b13ec2357473a4caba.zip
oslo-config, novnc deps, libvirt deps, kvm/xen deps, initscript name change
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster/nova')
-rw-r--r--sys-cluster/nova/ChangeLog7
-rw-r--r--sys-cluster/nova/metadata.xml2
-rw-r--r--sys-cluster/nova/nova-2012.2.4-r10.ebuild16
-rw-r--r--sys-cluster/nova/nova-2013.1.3-r6.ebuild17
-rw-r--r--sys-cluster/nova/nova-2013.1.9999.ebuild17
-rw-r--r--sys-cluster/nova/nova-9999.ebuild19
6 files changed, 55 insertions, 23 deletions
diff --git a/sys-cluster/nova/ChangeLog b/sys-cluster/nova/ChangeLog
index 50044aaa3e0d..571b29a752a3 100644
--- a/sys-cluster/nova/ChangeLog
+++ b/sys-cluster/nova/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/nova
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.29 2013/09/26 00:15:33 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.30 2013/09/27 01:41:21 prometheanfire Exp $
+
+ 27 Sep 2013; Matthew Thode <prometheanfire@gentoo.org> metadata.xml,
+ nova-2012.2.4-r10.ebuild, nova-2013.1.3-r6.ebuild, nova-2013.1.9999.ebuild,
+ nova-9999.ebuild:
+ oslo-config, novnc deps, libvirt deps, kvm/xen deps, initscript name change
*nova-2012.2.4-r10 (26 Sep 2013)
*nova-2013.1.3-r6 (26 Sep 2013)
diff --git a/sys-cluster/nova/metadata.xml b/sys-cluster/nova/metadata.xml
index e6379ce54911..ead7f52988a3 100644
--- a/sys-cluster/nova/metadata.xml
+++ b/sys-cluster/nova/metadata.xml
@@ -15,10 +15,12 @@
<flag name="compute">Installs the initscripts for the nova volume service</flag>
<flag name="conductor">Installs the initscripts for the nova conductor service</flag>
<flag name="consoleauth">Installs the initscripts for the nova consoleauth service</flag>
+ <flag name="kvm">qemu-kvm hypervisor support</flag>
<flag name="network">Installs the initscripts for the nova network service</flag>
<flag name="novncproxy">Installs the initscripts for the nova novncproxy service</flag>
<flag name="scheduler">Installs the initscripts for the nova scheduler service</flag>
<flag name="spicehtml5proxy">Installs the initscripts for the nova spicehtml5proxy service</flag>
+ <flag name="xen">xen hypervisor support</flag>
<flag name="xvpvncproxy">Installs the initscripts for the nova xvpvncproxy service</flag>
</use>
</pkgmetadata>
diff --git a/sys-cluster/nova/nova-2012.2.4-r10.ebuild b/sys-cluster/nova/nova-2012.2.4-r10.ebuild
index 365506624f39..7d49ffcd7385 100644
--- a/sys-cluster/nova/nova-2012.2.4-r10.ebuild
+++ b/sys-cluster/nova/nova-2012.2.4-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2012.2.4-r10.ebuild,v 1.1 2013/09/26 00:15:33 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2012.2.4-r10.ebuild,v 1.2 2013/09/27 01:41:21 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -15,8 +15,9 @@ SRC_URI="http://launchpad.net/${PN}/folsom/${PV}/+download/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+api +cert +compute +conductor +consoleauth +network +novncproxy +scheduler +spicehtml5proxy +xvpvncproxy sqlite mysql postgres"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
+IUSE="+api +cert +compute +conductor +consoleauth +kvm +network +novncproxy +scheduler +spicehtml5proxy +xvpvncproxy sqlite mysql postgres xen"
+REQUIRED_USE="|| ( mysql postgres sqlite )
+ || ( kvm xen )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
app-admin/sudo"
@@ -49,7 +50,12 @@ RDEPEND="~dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
>=dev-python/setuptools-git-0.4[${PYTHON_USEDEP}]
>=dev-python/python-glanceclient-0.5.0[${PYTHON_USEDEP}]
<dev-python/python-glanceclient-2[${PYTHON_USEDEP}]
- >=dev-python/python-neutronclient-2.1[${PYTHON_USEDEP}]"
+ >=dev-python/python-neutronclient-2.1[${PYTHON_USEDEP}]
+ app-emulation/libvirt[${PYTHON_USEDEP}]
+ novncproxy? ( www-apps/novnc )
+ kvm? ( app-emulation/qemu )
+ xen? ( app-emulation/xen
+ app-emulation/xen-tools )"
PATCHES=(
"${FILESDIR}/nova-folsom-4-CVE-2013-2030.patch"
@@ -75,7 +81,7 @@ python_install() {
use conductor && dosym /etc/init.d/nova /etc/init.d/nova-conductor
use consoleauth && dosym /etc/init.d/nova /etc/init.d/nova-consoleauth
use network && dosym /etc/init.d/nova /etc/init.d/nova-network
- use novncproxy &&dosym /etc/init.d/nova /etc/init.d/nova-nonvncproxy
+ use novncproxy &&dosym /etc/init.d/nova /etc/init.d/nova-novncproxy
use scheduler && dosym /etc/init.d/nova /etc/init.d/nova-scheduler
use spicehtml5proxy && dosym /etc/init.d/nova /etc/init.d/nova-spicehtml5proxy
use xvpvncproxy && dosym /etc/init.d/nova /etc/init.d/nova-xvpncproxy
diff --git a/sys-cluster/nova/nova-2013.1.3-r6.ebuild b/sys-cluster/nova/nova-2013.1.3-r6.ebuild
index 18889d120522..b509a1e2403f 100644
--- a/sys-cluster/nova/nova-2013.1.3-r6.ebuild
+++ b/sys-cluster/nova/nova-2013.1.3-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.3-r6.ebuild,v 1.1 2013/09/26 00:15:33 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.3-r6.ebuild,v 1.2 2013/09/27 01:41:21 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -15,8 +15,9 @@ SRC_URI="http://launchpad.net/${PN}/grizzly/${PV}/+download/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+api +cert +compute +conductor +consoleauth +network +novncproxy +scheduler +spicehtml5proxy +xvpvncproxy sqlite mysql postgres"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
+IUSE="+api +cert +compute +conductor +consoleauth +kvm +network +novncproxy +scheduler +spicehtml5proxy +xvpvncproxy xen sqlite mysql postgres"
+REQUIRED_USE="|| ( mysql postgres sqlite )
+ || ( kvm xen )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
app-admin/sudo"
@@ -57,7 +58,13 @@ RDEPEND=">=dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
>=dev-python/stevedore-0.7[${PYTHON_USEDEP}]
<dev-python/websockify-0.4[${PYTHON_USEDEP}]
>=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
- virtual/python-argparse[${PYTHON_USEDEP}]"
+ <dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ app-emulation/libvirt[${PYTHON_USEDEP}]
+ novncproxy? ( www-apps/novnc )
+ kvm? ( app-emulation/qemu )
+ xen? ( app-emulation/xen
+ app-emulation/xen-tools )"
PATCHES=(
"${FILESDIR}/2013.1.3-CVE-2013-4261.patch"
@@ -79,7 +86,7 @@ python_install() {
use conductor && dosym /etc/init.d/nova /etc/init.d/nova-conductor
use consoleauth && dosym /etc/init.d/nova /etc/init.d/nova-consoleauth
use network && dosym /etc/init.d/nova /etc/init.d/nova-network
- use novncproxy &&dosym /etc/init.d/nova /etc/init.d/nova-nonvncproxy
+ use novncproxy &&dosym /etc/init.d/nova /etc/init.d/nova-novncproxy
use scheduler && dosym /etc/init.d/nova /etc/init.d/nova-scheduler
use spicehtml5proxy && dosym /etc/init.d/nova /etc/init.d/nova-spicehtml5proxy
use xvpvncproxy && dosym /etc/init.d/nova /etc/init.d/nova-xvpncproxy
diff --git a/sys-cluster/nova/nova-2013.1.9999.ebuild b/sys-cluster/nova/nova-2013.1.9999.ebuild
index 1aa2da16b064..6b30ed997d7f 100644
--- a/sys-cluster/nova/nova-2013.1.9999.ebuild
+++ b/sys-cluster/nova/nova-2013.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.9999.ebuild,v 1.8 2013/09/26 00:15:33 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.9999.ebuild,v 1.9 2013/09/27 01:41:21 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -16,8 +16,9 @@ EGIT_BRANCH="stable/grizzly"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="+api +cert +compute +conductor +consoleauth +network +novncproxy +scheduler +spicehtml5proxy +xvpvncproxy sqlite mysql postgres"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
+IUSE="+api +cert +compute +conductor +consoleauth +kvm +network +novncproxy +scheduler +spicehtml5proxy +xvpvncproxy sqlite mysql postgres xen"
+REQUIRED_USE="|| ( mysql postgres sqlite )
+ || ( kvm xen )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
app-admin/sudo"
@@ -58,7 +59,13 @@ RDEPEND=">=dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
>=dev-python/stevedore-0.7[${PYTHON_USEDEP}]
<dev-python/websockify-0.4[${PYTHON_USEDEP}]
>=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
- virtual/python-argparse[${PYTHON_USEDEP}]"
+ <dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ app-emulation/libvirt[${PYTHON_USEDEP}]
+ novncproxy? ( www-apps/novnc )
+ kvm? ( app-emulation/qemu )
+ xen? ( app-emulation/xen
+ app-emulation/xen-tools )"
PATCHES=(
)
@@ -78,7 +85,7 @@ python_install() {
use conductor && dosym /etc/init.d/nova /etc/init.d/nova-conductor
use consoleauth && dosym /etc/init.d/nova /etc/init.d/nova-consoleauth
use network && dosym /etc/init.d/nova /etc/init.d/nova-network
- use novncproxy &&dosym /etc/init.d/nova /etc/init.d/nova-nonvncproxy
+ use novncproxy &&dosym /etc/init.d/nova /etc/init.d/nova-novncproxy
use scheduler && dosym /etc/init.d/nova /etc/init.d/nova-scheduler
use spicehtml5proxy && dosym /etc/init.d/nova /etc/init.d/nova-spicehtml5proxy
use xvpvncproxy && dosym /etc/init.d/nova /etc/init.d/nova-xvpncproxy
diff --git a/sys-cluster/nova/nova-9999.ebuild b/sys-cluster/nova/nova-9999.ebuild
index 8ae9b6dd7845..753cc368d5cb 100644
--- a/sys-cluster/nova/nova-9999.ebuild
+++ b/sys-cluster/nova/nova-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-9999.ebuild,v 1.9 2013/09/26 00:15:33 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-9999.ebuild,v 1.10 2013/09/27 01:41:21 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -15,8 +15,9 @@ EGIT_REPO_URI="https://github.com/openstack/nova.git"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="+api +cert +compute +conductor +consoleauth +network +novncproxy +scheduler +spicehtml5proxy +xvpvncproxy sqlite mysql postgres"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
+IUSE="+api +cert +compute +conductor +consoleauth +kvm +network +novncproxy +scheduler +spicehtml5proxy +xvpvncproxy sqlite mysql postgres xen"
+REQUIRED_USE="|| ( mysql postgres sqlite )
+ || ( kvm xen )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
app-admin/sudo"
@@ -62,9 +63,13 @@ RDEPEND=">=dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
>=dev-python/stevedore-0.10[${PYTHON_USEDEP}]
>=dev-python/websockify-0.5.1[${PYTHON_USEDEP}]
<dev-python/websockify-0.6[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
- virtual/python-argparse[${PYTHON_USEDEP}]"
-#oslo.config-1.2 is required but not released yet
+ >=dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ app-emulation/libvirt[${PYTHON_USEDEP}]
+ novncproxy? ( www-apps/novnc )
+ kvm? ( app-emulation/qemu )
+ xen? ( app-emulation/xen
+ app-emulation/xen-tools )"
PATCHES=(
)
@@ -84,7 +89,7 @@ python_install() {
use conductor && dosym /etc/init.d/nova /etc/init.d/nova-conductor
use consoleauth && dosym /etc/init.d/nova /etc/init.d/nova-consoleauth
use network && dosym /etc/init.d/nova /etc/init.d/nova-network
- use novncproxy &&dosym /etc/init.d/nova /etc/init.d/nova-nonvncproxy
+ use novncproxy &&dosym /etc/init.d/nova /etc/init.d/nova-novncproxy
use scheduler && dosym /etc/init.d/nova /etc/init.d/nova-scheduler
use spicehtml5proxy && dosym /etc/init.d/nova /etc/init.d/nova-spicehtml5proxy
use xvpvncproxy && dosym /etc/init.d/nova /etc/init.d/nova-xvpncproxy