summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-02-06 04:48:04 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-02-06 04:48:04 +0000
commit4ae4f94761aee727a3c0eaa879aa74c3bedcfcb2 (patch)
tree5bc947e04179ea68c9e109088f04d8a60c2bc669 /sys-auth
parentVersion bump. (diff)
downloadgentoo-2-4ae4f94761aee727a3c0eaa879aa74c3bedcfcb2.tar.gz
gentoo-2-4ae4f94761aee727a3c0eaa879aa74c3bedcfcb2.tar.bz2
gentoo-2-4ae4f94761aee727a3c0eaa879aa74c3bedcfcb2.zip
Repoman missed this the other day. Original message: Fix kerberos support in nss_ldap, bug #163362.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/nss_ldap/ChangeLog8
-rw-r--r--sys-auth/nss_ldap/files/digest-nss_ldap-253-r13
-rw-r--r--sys-auth/nss_ldap/nss_ldap-253-r1.ebuild69
3 files changed, 79 insertions, 1 deletions
diff --git a/sys-auth/nss_ldap/ChangeLog b/sys-auth/nss_ldap/ChangeLog
index e161a5125299..83ec5339dadf 100644
--- a/sys-auth/nss_ldap/ChangeLog
+++ b/sys-auth/nss_ldap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/nss_ldap
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.37 2007/01/27 03:27:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.38 2007/02/06 04:48:04 robbat2 Exp $
+
+*nss_ldap-253-r1 (31 Jan 2007)
+
+ 31 Jan 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +nss_ldap-253-r1.ebuild:
+ Fix kerberos support in nss_ldap, bug #163362.
27 Jan 2007; Jeroen Roovers <jer@gentoo.org> nss_ldap-253.ebuild:
Stable for HPPA (bug #158254).
diff --git a/sys-auth/nss_ldap/files/digest-nss_ldap-253-r1 b/sys-auth/nss_ldap/files/digest-nss_ldap-253-r1
new file mode 100644
index 000000000000..3aa847cff61c
--- /dev/null
+++ b/sys-auth/nss_ldap/files/digest-nss_ldap-253-r1
@@ -0,0 +1,3 @@
+MD5 e3d37f59402b01c9cbf8f7ee888b3e6a nss_ldap-253.tar.gz 228278
+RMD160 a129985fe6b27a481efa94e07e994cbcdbb6867c nss_ldap-253.tar.gz 228278
+SHA256 c2caa483d171304f08a7e9a6cad7569ace5bc7f4f297ddd470e940799c6f190c nss_ldap-253.tar.gz 228278
diff --git a/sys-auth/nss_ldap/nss_ldap-253-r1.ebuild b/sys-auth/nss_ldap/nss_ldap-253-r1.ebuild
new file mode 100644
index 000000000000..406c85103ab8
--- /dev/null
+++ b/sys-auth/nss_ldap/nss_ldap-253-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-253-r1.ebuild,v 1.1 2007/02/06 04:48:04 robbat2 Exp $
+
+inherit fixheadtails eutils multilib
+
+IUSE="debug sasl kerberos"
+
+DESCRIPTION="NSS LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/nss_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=net-nds/openldap-2.1.30-r5
+ sasl? ( dev-libs/cyrus-sasl )
+ kerberos? ( virtual/krb5 )"
+RDEPEND="${DEPEND}
+ !<net-fs/autofs-4.1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/nsswitch.ldap.diff
+ epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
+ epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-252-reconnect-timeouts.patch
+ sed -i.orig \
+ -e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
+ ${S}/ldap.conf || die "failed to clean up initial version marker"
+ # fix head/tail stuff
+ ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ # fix build borkage
+ for i in Makefile.{in,am}; do
+ sed -i.orig \
+ -e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
+ ${S}/$i
+ done
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debugging"
+ use kerberos && myconf="${myconf} --enable-configurable-krb5-ccname-gssapi"
+ econf \
+ --with-ldap-lib=openldap \
+ --libdir=/$(get_libdir) \
+ --enable-schema-mapping \
+ --enable-paged-results \
+ --enable-rfc2307bis \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /$(get_libdir)
+
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+
+ insinto /etc
+ doins ldap.conf
+
+ dodoc ldap.conf ANNOUNCE NEWS ChangeLog AUTHORS \
+ COPYING CVSVersionInfo.txt README nsswitch.ldap certutil
+ docinto docs; dodoc doc/*
+}