summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2011-01-26 19:43:12 +0000
committerJustin Bronder <jsbronder@gentoo.org>2011-01-26 19:43:12 +0000
commitbdecd62da29f608e51c9d289e4043e0c7e355a19 (patch)
treec424f979d91ba17838dafeb3a6973377aee0b69c /sys-apps
parent[dev-libs/soprano] Version bump for kde sc 4.6.0 (diff)
downloadgentoo-2-bdecd62da29f608e51c9d289e4043e0c7e355a19.tar.gz
gentoo-2-bdecd62da29f608e51c9d289e4043e0c7e355a19.tar.bz2
gentoo-2-bdecd62da29f608e51c9d289e4043e0c7e355a19.zip
Version bump, fix tests, push docs to correct directory
(Portage version: 2.1.9.33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwloc/ChangeLog7
-rw-r--r--sys-apps/hwloc/hwloc-1.1.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index e6eaaa1f6876..e2b8cd4b3620 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.6 2011/01/24 16:14:03 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.7 2011/01/26 19:43:12 jsbronder Exp $
+
+*hwloc-1.1.1 (26 Jan 2011)
+
+ 26 Jan 2011; Justin Bronder <jsbronder@gentoo.org> +hwloc-1.1.1.ebuild:
+ Version bump, fix tests, push docs to correct directory
24 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> hwloc-1.0.3.ebuild:
Mark ~ppc64 wrt #345231
diff --git a/sys-apps/hwloc/hwloc-1.1.1.ebuild b/sys-apps/hwloc/hwloc-1.1.1.ebuild
new file mode 100644
index 000000000000..7582f2f4e2c1
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.1.1.ebuild,v 1.1 2011/01/26 19:43:12 jsbronder Exp $
+
+EAPI=2
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/hwloc/v1.1/downloads/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cairo svg static-libs xml X"
+SLOT="0"
+LICENSE="BSD"
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${P} \
+ $(use_enable cairo) \
+ $(use_enable static-libs static) \
+ $(use_enable xml) \
+ $(use_with X x) \
+ --disable-silent-rules
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README VERSION || die
+}
+
+src_test() {
+ # autotools-utils broke tests, the first of which being
+ # PASS: 256ppc-8n8s4t-nosys.output
+ emake check || die
+}