summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-08-24 13:57:25 +0000
committerRoy Marples <uberlord@gentoo.org>2006-08-24 13:57:25 +0000
commit983911d179bb16584c8db295ab156d584b81c9d7 (patch)
tree90dfc0ee17ec95bc5308c55f0373bee8ece655ce /sys-apps
parentChange the docs cleaning rm to use rather than the name of the package. (diff)
downloadgentoo-2-983911d179bb16584c8db295ab156d584b81c9d7.tar.gz
gentoo-2-983911d179bb16584c8db295ab156d584b81c9d7.tar.bz2
gentoo-2-983911d179bb16584c8db295ab156d584b81c9d7.zip
Fix the Debian patch mangling the unimaps directory.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kbd/ChangeLog8
-rw-r--r--sys-apps/kbd/files/digest-kbd-1.12-r86
-rw-r--r--sys-apps/kbd/files/kbd-1.12-unimap.patch16
-rw-r--r--sys-apps/kbd/kbd-1.12-r8.ebuild110
4 files changed, 139 insertions, 1 deletions
diff --git a/sys-apps/kbd/ChangeLog b/sys-apps/kbd/ChangeLog
index 0fae5a2c7553..e4bdf86506d8 100644
--- a/sys-apps/kbd/ChangeLog
+++ b/sys-apps/kbd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/kbd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/ChangeLog,v 1.45 2006/06/28 15:15:47 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/ChangeLog,v 1.46 2006/08/24 13:57:25 uberlord Exp $
+
+*kbd-1.12-r8 (24 Aug 2006)
+
+ 24 Aug 2006; Roy Marples <uberlord@gentoo.org>
+ +files/kbd-1.12-unimap.patch, +kbd-1.12-r8.ebuild:
+ Fix the Debian patch mangling the unimaps directory.
*kbd-1.12-r7 (28 Jun 2006)
diff --git a/sys-apps/kbd/files/digest-kbd-1.12-r8 b/sys-apps/kbd/files/digest-kbd-1.12-r8
new file mode 100644
index 000000000000..7bbb85a86bcb
--- /dev/null
+++ b/sys-apps/kbd/files/digest-kbd-1.12-r8
@@ -0,0 +1,6 @@
+MD5 7892c7010512a9bc6697a295c921da25 kbd-1.12.tar.gz 884827
+RMD160 260ed9b79b5a679730fc16f1d3ce9360f4ad63fd kbd-1.12.tar.gz 884827
+SHA256 f3bc6747dba7d1a35cd125ca0bd4649f88704be211cf7e47d36b43c7f44ce803 kbd-1.12.tar.gz 884827
+MD5 c3bc810b784880c9bb5a6fe80d95a696 svorakln.tar.gz 3030
+RMD160 4ee5d1bdab312eb33cbde9195e6d4cdf28eb9a6e svorakln.tar.gz 3030
+SHA256 7c4015dcd1f4310ba1b872c9a9e57c43d45da822330853ae465e628d3bca8ee3 svorakln.tar.gz 3030
diff --git a/sys-apps/kbd/files/kbd-1.12-unimap.patch b/sys-apps/kbd/files/kbd-1.12-unimap.patch
new file mode 100644
index 000000000000..c7ea73cca656
--- /dev/null
+++ b/sys-apps/kbd/files/kbd-1.12-unimap.patch
@@ -0,0 +1,16 @@
+That silly Debian patch changes the default dir to TRANSDIR.
+This patch corrects that oversight so both work if we ever
+use console-data, also by Debian.
+
+--- kbd-1.12/src/loadunimap.c.orig 2006-08-24 13:48:11.000000000 +0100
++++ kbd-1.12/src/loadunimap.c 2006-08-24 13:49:07.000000000 +0100
+@@ -28,7 +28,7 @@
+ extern char *progname;
+ extern int force;
+
+-static char *unidirpath[] = { "", DATADIR "/" TRANSDIR "/", 0 };
+-static char *unisuffixes[] = { "", ".sfm", ".uni", 0 };
++static char *unidirpath[] = { "", DATADIR "/" UNIMAPDIR "/", DATADIR "/" TRANSDIR "/", 0 };
++static char *unisuffixes[] = { "", ".uni", ".sfm", 0 };
+
+ #ifdef MAIN
diff --git a/sys-apps/kbd/kbd-1.12-r8.ebuild b/sys-apps/kbd/kbd-1.12-r8.ebuild
new file mode 100644
index 000000000000..7ca69f3a8e51
--- /dev/null
+++ b/sys-apps/kbd/kbd-1.12-r8.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-1.12-r8.ebuild,v 1.1 2006/08/24 13:57:25 uberlord Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="http://freshmeat.net/projects/kbd/"
+SRC_URI="ftp://ftp.cwi.nl/pub/aeb/kbd/${P}.tar.gz
+ ftp://ftp.win.tue.nl/pub/home/aeb/linux-local/utils/kbd/${P}.tar.gz
+ nls? ( http://www.users.one.se/liket/svorak/svorakln.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ local a
+ # Workaround problem on JFS filesystems, see bug 42859
+ for a in ${A} ; do
+ echo ">>> Unpacking ${a} to ${WORKDIR}"
+ gzip -dc "${DISTDIR}"/${a} | tar xf -
+ assert
+ done
+
+ cd "${S}"
+ sed -i \
+ -e "/^CFLAGS/ s:-O2:${CFLAGS}:g" \
+ -e "/^LDFLAGS/ s:-s:${LDFLAGS}:" \
+ -e "s:install -s:install:" \
+ src/Makefile.in \
+ openvt/Makefile
+
+ if tc-is-cross-compiler; then
+ tc-export CC
+ # Cross-compiling: don't run test programs
+ sed -i -e "s:&& ./conftest::" configure || \
+ die "Could not do sed configure for cross-compile"
+ fi
+
+ # Other patches from RH
+ epatch "${FILESDIR}"/${PN}-1.08-terminal.patch
+
+ epatch "${FILESDIR}"/${P}-configure-LANG.patch #128253
+
+ # Fixes a problem where loadkeys matches dvorak the dir, and not the
+ # .map inside
+ epatch "${FILESDIR}"/${P}-find-map-fix.patch
+
+ # Sparc have not yet fixed struct kbd_rate to use 'period' and not 'rate'
+ epatch "${FILESDIR}"/${P}-kbd_repeat-v2.patch
+
+ # misc fixes from debian
+ epatch "${FILESDIR}"/${P}-debian.patch
+
+ # fix unimap path issue caused by Debian patch
+ epatch "${FILESDIR}/${P}"-unimap.patch
+
+ # Provide a QWERTZ and QWERTY cz map #19010
+ cp data/keymaps/i386/{qwerty,qwertz}/cz.map || die "cz qwerty"
+ epatch "${FILESDIR}"/${P}-cz-qwerty-map.patch
+
+ # Fix jp map to recognize Ctrl-[ as Escape #71870
+ epatch "${FILESDIR}"/${P}-jp-escape.patch
+
+ # Patches from Fedora
+ epatch "${FILESDIR}"/${P}-Meta_utf8.patch
+ ## Fix runtime with gcc4 (setfont: Input file: trailing garbage)
+ epatch "${FILESDIR}"/${P}-alias.patch
+ epatch "${FILESDIR}"/${P}-setfont-man.patch
+
+ # cross-compile fails for powerpc targets bug #133856
+ epatch "${FILESDIR}"/${P}-xcompile.patch
+}
+
+src_compile() {
+ local myconf=
+ # Non-standard configure script; --disable-nls to
+ # disable NLS, nothing to enable it.
+ use nls || myconf="--disable-nls"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share \
+ ${myconf} || die
+
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ mv "${D}"/usr/bin/setfont "${D}"/bin/
+ dosym /bin/setfont /usr/bin/setfont
+
+ dodoc CHANGES CREDITS README
+ dodir /usr/share/doc/${PF}/html
+ cp -dR doc/* "${D}"/usr/share/doc/${PF}/html/
+
+ if use nls ; then
+ cd ${WORKDIR}/mnt/e/SvorakLN
+ insinto /usr/share/keymaps/i386/dvorak/
+ doins .svorakmap svorak.map.gz
+ dodoc Svorak.txt
+ fi
+}