summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-10-11 05:53:28 +0000
committerMike Frysinger <vapier@gentoo.org>2007-10-11 05:53:28 +0000
commit92c6ffd2040ab064540e6c6a8a334498e9b6eaef (patch)
tree86fc222e052bb7c207aed7d861134046adfe37bc /sys-apps
parentamd64 stable bug 195387 (diff)
downloadgentoo-2-92c6ffd2040ab064540e6c6a8a334498e9b6eaef.tar.gz
gentoo-2-92c6ffd2040ab064540e6c6a8a334498e9b6eaef.tar.bz2
gentoo-2-92c6ffd2040ab064540e6c6a8a334498e9b6eaef.zip
Version bump #195236.
(Portage version: 2.1.3.12)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pciutils/ChangeLog8
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.2.73
-rw-r--r--sys-apps/pciutils/files/pciutils-2.2.7-build.patch30
-rw-r--r--sys-apps/pciutils/pciutils-2.2.7.ebuild46
4 files changed, 86 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 5635965ece8c..d700288d78ef 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.110 2007/07/28 21:34:23 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.111 2007/10/11 05:53:27 vapier Exp $
+
+*pciutils-2.2.7 (11 Oct 2007)
+
+ 11 Oct 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/pciutils-2.2.7-build.patch, +pciutils-2.2.7.ebuild:
+ Version bump #195236.
28 Jul 2007; Torsten Veller <tove@gentoo.org> ChangeLog:
pciutils-2.2.4-r3 stable on x86 (by diox, #180554)
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.2.7 b/sys-apps/pciutils/files/digest-pciutils-2.2.7
new file mode 100644
index 000000000000..10b9e48aa092
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.2.7
@@ -0,0 +1,3 @@
+MD5 0fd75a5df05100f60fb3c5498d523160 pciutils-2.2.7.tar.gz 229424
+RMD160 5d334078572cde947da0a33158733c8d64cdd578 pciutils-2.2.7.tar.gz 229424
+SHA256 3c8536fd30d3288b1baffc75ae0521dfeed6eb72a27d800992d1bfabcc8b2441 pciutils-2.2.7.tar.gz 229424
diff --git a/sys-apps/pciutils/files/pciutils-2.2.7-build.patch b/sys-apps/pciutils/files/pciutils-2.2.7-build.patch
new file mode 100644
index 000000000000..2ee22462aca0
--- /dev/null
+++ b/sys-apps/pciutils/files/pciutils-2.2.7-build.patch
@@ -0,0 +1,30 @@
+ - fix some build paths
+ - build libpci.a with PIC (yes this sucks, but a non-stable ABI in
+ libpic.so sucks too and libpci.a is how Debian goes about it)
+
+--- Makefile
++++ Makefile
+@@ -7,10 +7,10 @@
+ VERSION=2.2.3
+ DATE=2006-05-05
+
+-PREFIX=/usr/local
++PREFIX=/usr
+ SBINDIR=$(PREFIX)/sbin
+ SHAREDIR=$(PREFIX)/share
+-IDSDIR=$(SHAREDIR)
++IDSDIR=$(SHAREDIR)/misc
+ MANDIR:=$(shell if [ -d $(PREFIX)/share/man ] ; then echo $(PREFIX)/share/man ; else echo $(PREFIX)/man ; fi)
+ INSTALL=install
+ DIRINSTALL=install -d
+--- lib/Makefile
++++ lib/Makefile
+@@ -3,6 +3,8 @@
+
+ include config.mk
+
++CFLAGS += -fPIC
++
+ OBJS=access.o generic.o dump.o names.o filter.o
+ INCL=internal.h pci.h config.h header.h sysdep.h types.h
+
diff --git a/sys-apps/pciutils/pciutils-2.2.7.ebuild b/sys-apps/pciutils/pciutils-2.2.7.ebuild
new file mode 100644
index 000000000000..67668da741bd
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.2.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.7.ebuild,v 1.1 2007/10/11 05:53:27 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.7-build.patch
+ epatch "${FILESDIR}"/pcimodules-${PN}-2.2.6.patch
+ epatch "${FILESDIR}"/${PN}-2.2.6-link.patch #160421
+ epatch "${FILESDIR}"/${PN}-2.2.4-update-pciids.patch
+ sed -i "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
+}
+
+src_compile() {
+ export ZLIB=$(use zlib && echo yes || echo no)
+ tc-export AR CC RANLIB
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install install-lib DESTDIR="${D}" || die
+
+ use network-cron || return 0
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids || die
+}
+
+pkg_postinst() {
+ cd "${ROOT}"/usr/share/misc
+ rm -f pci.ids{,.gz}.old
+ use zlib && rm -f pci.ids || rm -f pci.ids.gz
+}