summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-06-07 14:10:44 +0000
committerMichał Górny <mgorny@gentoo.org>2011-06-07 14:10:44 +0000
commit8a0dc47d6d889c505783340898978b6b57645367 (patch)
tree0bb6bf3b67ac62d0b8f72a0bb3fad73512e21449 /sys-apps
parentUnmask libobjc2, mask new gnustep-base/gnustep-make depending on it (diff)
downloadgentoo-2-8a0dc47d6d889c505783340898978b6b57645367.tar.gz
gentoo-2-8a0dc47d6d889c505783340898978b6b57645367.tar.bz2
gentoo-2-8a0dc47d6d889c505783340898978b6b57645367.zip
Support libcryptsetup, misc fixes.
(Portage version: 2.2.0_alpha37_p23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog6
-rw-r--r--sys-apps/systemd/metadata.xml2
-rw-r--r--sys-apps/systemd/systemd-28.ebuild18
3 files changed, 16 insertions, 10 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index bcf5d31fadb6..dc19f0e9a7b4 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.2 2011/06/06 11:25:01 dagger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.3 2011/06/07 14:10:44 mgorny Exp $
+
+ 07 Jun 2011; Michał Górny <mgorny@gentoo.org> systemd-28.ebuild,
+ metadata.xml:
+ Support libcryptsetup, misc fixes.
06 Jun 2011; Robert Piasek <dagger@gentoo.org> metadata.xml:
Add dagger to metadata as maintainer
diff --git a/sys-apps/systemd/metadata.xml b/sys-apps/systemd/metadata.xml
index d0b75465045f..773834efc66b 100644
--- a/sys-apps/systemd/metadata.xml
+++ b/sys-apps/systemd/metadata.xml
@@ -11,6 +11,8 @@
<name>Robert Piasek</name>
</maintainer>
<use>
+ <!-- XXX: describe those two better -->
<flag name='audit'>Enable support for <pkg>sys-process/audit</pkg></flag>
+ <flag name='cryptsetup'>Use libcryptsetup</flag>
</use>
</pkgmetadata>
diff --git a/sys-apps/systemd/systemd-28.ebuild b/sys-apps/systemd/systemd-28.ebuild
index 2b3526323807..9cd677719fcf 100644
--- a/sys-apps/systemd/systemd-28.ebuild
+++ b/sys-apps/systemd/systemd-28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-28.ebuild,v 1.1 2011/06/06 08:31:26 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-28.ebuild,v 1.2 2011/06/07 14:10:44 mgorny Exp $
EAPI=4
@@ -13,15 +13,14 @@ SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="audit gtk pam selinux tcpd"
-
-# XXX: libcryptsetup
+IUSE="audit cryptsetup gtk pam selinux tcpd"
COMMON_DEPEND=">=sys-apps/dbus-1.4.8-r1
>=sys-fs/udev-171
>=sys-apps/util-linux-2.19
sys-libs/libcap
audit? ( >=sys-process/audit-2 )
+ cryptsetup? ( sys-fs/cryptsetup )
gtk? (
dev-libs/dbus-glib
>=dev-libs/glib-2.26
@@ -61,7 +60,7 @@ pkg_setup() {
src_prepare() {
# Force the rebuild of .vala sources
- touch src/*.vala
+ touch src/*.vala || die
autotools-utils_src_prepare
}
@@ -71,6 +70,7 @@ src_configure() {
--with-rootdir=
--localstatedir=/var
$(use_enable audit)
+ $(use_enable cryptsetup libcryptsetup)
$(use_enable gtk)
$(use_enable pam)
$(use_enable selinux)
@@ -88,7 +88,7 @@ src_install() {
autotools-utils_src_install
dodoc "${D}"/usr/share/doc/systemd/*
- rm -rf "${D}"/usr/share/doc/systemd
+ rm -rf "${D}"/usr/share/doc/systemd || die
cd "${D}"/usr/share/man/man8/
for i in halt poweroff reboot runlevel shutdown telinit; do
@@ -97,13 +97,13 @@ src_install() {
# Drop the .pc file to avoid automagic depends.
# This a temporary workaround for gx86 packages.
- rm -f "${D}"/usr/share/pkgconfig/systemd.pc
+ rm -f "${D}"/usr/share/pkgconfig/systemd.pc || die
keepdir /run
}
check_mtab_is_symlink() {
- if test ! -L "${ROOT}"etc/mtab; then
+ if [[ ! -L "${ROOT}"etc/mtab ]]; then
ewarn "${ROOT}etc/mtab must be a symlink to ${ROOT}proc/self/mounts!"
ewarn "To correct that, execute"
ewarn " $ ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
@@ -115,7 +115,7 @@ systemd_machine_id_setup() {
if ! "${ROOT}"bin/systemd-machine-id-setup; then
ewarn "Setting up /etc/machine-id failed, to fix it please see"
ewarn " http://lists.freedesktop.org/archives/dbus/2011-March/014187.html"
- elif test ! -L "${ROOT}"var/lib/dbus/machine-id; then
+ elif [[ ! -L "${ROOT}"var/lib/dbus/machine-id ]]; then
# This should be fixed in the dbus ebuild, but we warn about it here.
ewarn "${ROOT}var/lib/dbus/machine-id ideally should be a symlink to"
ewarn "${ROOT}etc/machine-id to make it clear that they have the same"