summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-07-03 19:38:25 +0000
committerMike Frysinger <vapier@gentoo.org>2011-07-03 19:38:25 +0000
commit4614767ed79044b84e31f04ec38913fdd7fdb5f1 (patch)
tree758fa0997592c8a3081f3298731ca8a44624cba4 /sys-apps
parentversion bump (diff)
downloadgentoo-2-4614767ed79044b84e31f04ec38913fdd7fdb5f1.tar.gz
gentoo-2-4614767ed79044b84e31f04ec38913fdd7fdb5f1.tar.bz2
gentoo-2-4614767ed79044b84e31f04ec38913fdd7fdb5f1.zip
Version bump #373937 by Lars Wendler.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gawk/ChangeLog9
-rw-r--r--sys-apps/gawk/gawk-4.0.0.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index 9aaae839912e..703796d8fbbc 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/gawk
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.131 2010/08/15 21:30:52 truedfx Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.132 2011/07/03 19:38:25 vapier Exp $
+
+*gawk-4.0.0 (03 Jul 2011)
+
+ 03 Jul 2011; Mike Frysinger <vapier@gentoo.org> +gawk-4.0.0.ebuild:
+ Version bump #373937 by Lars Wendler.
15 Aug 2010; Harald van Dijk <truedfx@gentoo.org> gawk-3.1.8.ebuild:
Fix quoting
diff --git a/sys-apps/gawk/gawk-4.0.0.ebuild b/sys-apps/gawk/gawk-4.0.0.ebuild
new file mode 100644
index 000000000000..6b0fecb6e711
--- /dev/null
+++ b/sys-apps/gawk/gawk-4.0.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-4.0.0.ebuild,v 1.1 2011/07/03 19:38:25 vapier Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="GNU awk pattern-matching language"
+HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
+SRC_URI="mirror://gnu/gawk/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls"
+
+# older gawk's provided shared lib for baselayout-1
+RDEPEND="!<sys-apps/baselayout-2.0.1"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # use symlinks rather than hardlinks, and disable version links
+ sed -i \
+ -e '/^LN =/s:=.*:= $(LN_S):' \
+ -e '/install-exec-hook:/s|$|\nfoo:|' \
+ Makefile.in doc/Makefile.in
+}
+
+src_configure() {
+ export ac_cv_libsigsegv=no
+ econf \
+ --libexec='$(libdir)/misc' \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ # Keep important gawk in /bin
+ if use userland_GNU ; then
+ dodir /bin
+ mv "${D}"/usr/bin/gawk "${D}"/bin/ || die
+ dosym /bin/gawk /usr/bin/gawk
+
+ # Provide canonical `awk`
+ dosym gawk /bin/awk
+ dosym gawk /usr/bin/awk
+ dosym gawk.1 /usr/share/man/man1/awk.1
+ fi
+
+ # Install headers
+ insinto /usr/include/awk
+ doins *.h || die
+ rm "${D}"/usr/include/awk/config.h || die
+
+ dodoc AUTHORS ChangeLog FUTURES LIMITATIONS NEWS PROBLEMS POSIX.STD README README_d/*.*
+ for x in */ChangeLog ; do
+ newdoc ${x} ${x##*/}.${x%%/*}
+ done
+}