summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-07-26 15:23:39 +0000
committerMichael Januszewski <spock@gentoo.org>2008-07-26 15:23:39 +0000
commit20e682197b2ec69e0c316584bfa2c80fccc52580 (patch)
tree5f5aa05f9ba67957413e4423e148800d91d28a43 /sys-apps
parentVersion bump. (diff)
downloadgentoo-2-20e682197b2ec69e0c316584bfa2c80fccc52580.tar.gz
gentoo-2-20e682197b2ec69e0c316584bfa2c80fccc52580.tar.bz2
gentoo-2-20e682197b2ec69e0c316584bfa2c80fccc52580.zip
Version bump.
(Portage version: 2.2_rc3/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/v86d/ChangeLog7
-rw-r--r--sys-apps/v86d/v86d-0.1.6.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-apps/v86d/ChangeLog b/sys-apps/v86d/ChangeLog
index 2efe850e2b3b..79092ab6ff32 100644
--- a/sys-apps/v86d/ChangeLog
+++ b/sys-apps/v86d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/v86d
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.18 2008/07/16 20:55:48 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.19 2008/07/26 15:23:39 spock Exp $
+
+*v86d-0.1.6 (26 Jul 2008)
+
+ 26 Jul 2008; Michał Januszewski <spock@gentoo.org> +v86d-0.1.6.ebuild:
+ Version bump.
16 Jul 2008; Michał Januszewski <spock@gentoo.org> -v86d-0.1.3.ebuild,
-v86d-0.1.4.ebuild:
diff --git a/sys-apps/v86d/v86d-0.1.6.ebuild b/sys-apps/v86d/v86d-0.1.6.ebuild
new file mode 100644
index 000000000000..417487d37a45
--- /dev/null
+++ b/sys-apps/v86d/v86d-0.1.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.6.ebuild,v 1.1 2008/07/26 15:23:39 spock Exp $
+
+inherit linux-info multilib
+
+DESCRIPTION="A daemon to run x86 code in an emulated environment."
+HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
+SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug x86emu"
+
+DEPEND="dev-libs/klibc"
+RDEPEND=""
+
+S="${WORKDIR}/${P//_*/}"
+
+pkg_setup() {
+ if [ -z "$(grep V86D /usr/$(get_libdir)/klibc/include/linux/connector.h)" ]; then
+ eerror "You need to compile klibc against a kernel tree patched with uvesafb"
+ eerror "prior to merging this package."
+ die "Kernel not patched with uvesafb."
+ fi
+ linux-info_pkg_setup
+}
+
+src_compile() {
+ local myconf=""
+ if use x86emu ; then
+ myconf="--with-x86emu"
+ fi
+
+ ./configure --with-klibc $(use_with debug) ${myconf}
+ make KDIR=${KV_DIR} || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins misc/initramfs
+}
+
+pkg_postinst() {
+ elog "If you wish to place v86d into an initramfs image, you might want to use"
+ elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
+}