summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-07-09 00:19:55 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-07-09 00:19:55 +0000
commit09f0134042877d5cd6107786f0c62f58679900d4 (patch)
tree4a120c3ebaf3d73745182c7c6e7a24981955b47a /sys-apps
parentRemoved old ebuild and patches and beautified 3.2.0 ebuild a bit. (diff)
downloadgentoo-2-09f0134042877d5cd6107786f0c62f58679900d4.tar.gz
gentoo-2-09f0134042877d5cd6107786f0c62f58679900d4.tar.bz2
gentoo-2-09f0134042877d5cd6107786f0c62f58679900d4.zip
Initial import. Ebuild is submitted by Naohiro Aota, bug #271028.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ccs-tools/ChangeLog11
-rw-r--r--sys-apps/ccs-tools/ccs-tools-1.6.8_p20090623.ebuild63
-rw-r--r--sys-apps/ccs-tools/files/ccs-tools-1.6.8_p20090623-gentoo.patch234
-rw-r--r--sys-apps/ccs-tools/metadata.xml9
4 files changed, 317 insertions, 0 deletions
diff --git a/sys-apps/ccs-tools/ChangeLog b/sys-apps/ccs-tools/ChangeLog
new file mode 100644
index 000000000000..066a8b51c3e2
--- /dev/null
+++ b/sys-apps/ccs-tools/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-apps/ccs-tools
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ccs-tools/ChangeLog,v 1.1 2009/07/09 00:19:54 matsuu Exp $
+
+*ccs-tools-1.6.8_p20090623 (09 Jul 2009)
+
+ 09 Jul 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ccs-tools-1.6.8_p20090623.ebuild,
+ +files/ccs-tools-1.6.8_p20090623-gentoo.patch, +metadata.xml:
+ Initial import. Ebuild is submitted by Naohiro Aota, bug #271028.
+
diff --git a/sys-apps/ccs-tools/ccs-tools-1.6.8_p20090623.ebuild b/sys-apps/ccs-tools/ccs-tools-1.6.8_p20090623.ebuild
new file mode 100644
index 000000000000..452ccc4a0936
--- /dev/null
+++ b/sys-apps/ccs-tools/ccs-tools-1.6.8_p20090623.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ccs-tools/ccs-tools-1.6.8_p20090623.ebuild,v 1.1 2009/07/09 00:19:54 matsuu Exp $
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${P/_p/-}"
+DESCRIPTION="TOMOYO Linux tools"
+HOMEPAGE="http://www.sourcefoge.jp/projects/tomoyo/"
+SRC_URI="mirror://sourceforge.jp/tomoyo/30298/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="sys-libs/ncurses
+ sys-libs/readline"
+RDEPEND="${DEPEND}
+ sys-apps/which"
+
+S="${WORKDIR}/ccstools"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ sed -i \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "/^CFLAGS=/s:-O2:${CFLAGS}:" \
+ -e "s:/usr/lib/:/usr/$(get_libdir)/:g" \
+ Makefile || die
+
+ sed -i \
+ -e "s:/usr/lib/ccs:/usr/$(get_libdir)/ccs:g" \
+ init_policy.sh tomoyo_init_policy.sh || die
+
+ echo "CONFIG_PROTECT=\"/usr/$(get_libdir)/ccs/conf\"" > "${T}/50${PN}"
+}
+
+src_test() {
+ cd "${S}/kernel_test"
+ emake || die
+ ./testall.sh || die
+}
+
+
+src_install() {
+ emake INSTALLDIR="${D}" install || die
+
+ rm "${D}"/usr/$(get_libdir)/ccs/{COPYING.ccs,README.ccs,ccstools.conf} || die
+ insinto /usr/$(get_libdir)/ccs/conf
+ doins ccstools.conf || die
+ dosym conf/ccstools.conf /usr/$(get_libdir)/ccs/ccstools.conf || die
+
+ doenvd "${T}/50${PN}" || die
+
+ dodoc README.ccs
+}
diff --git a/sys-apps/ccs-tools/files/ccs-tools-1.6.8_p20090623-gentoo.patch b/sys-apps/ccs-tools/files/ccs-tools-1.6.8_p20090623-gentoo.patch
new file mode 100644
index 000000000000..990a29283f3d
--- /dev/null
+++ b/sys-apps/ccs-tools/files/ccs-tools-1.6.8_p20090623-gentoo.patch
@@ -0,0 +1,234 @@
+diff -Naur ccstools.orig/init_policy.sh ccstools/init_policy.sh
+--- ccstools.orig/init_policy.sh 2009-06-23 09:00:00.000000000 +0900
++++ ccstools/init_policy.sh 2009-07-05 11:36:47.000000000 +0900
+@@ -132,16 +132,26 @@
+ grep -qF "Fedora Core" /etc/issue && echo 'file_pattern /tmp/crontab.XXXX\?\?\?\?\?\?' # FC3
+ grep -qF "Debian" /etc/issue && echo 'file_pattern /tmp/crontab.\?\?\?\?\?\?/crontab' # Sarge
+
++ CRONTAB_PATH=`which crontab 2> /dev/null`
++ if [ -n "$CRONTAB_PATH" ]; then
++ # vixie-cron and cronie
++ grep -qF 'crontab.XXXXXXXXXX' $CRONTAB_PATH && echo 'file_pattern /tmp/crontab.XXXX\?\?\?\?\?\?'
++ # dcron
++ grep -qF 'crontab.XXXXXX' $CRONTAB_PATH && echo 'file_pattern /tmp/crontab.\?\?\?\?\?\?'
++ # fcron
++ grep -qF 'fcr-XXXXXX' $CRONTAB_PATH && echo 'file_pattern /tmp/fcr-\?\?\?\?\?\?'
++ fi
++
+ #
+ # Allow reading some data files.
+ #
+- for i in /etc/ld.so.cache /proc/meminfo /proc/sys/kernel/version /etc/localtime /usr/lib/gconv/gconv-modules.cache /usr/share/locale/locale.alias
++ for i in /etc/ld.so.cache /proc/meminfo /proc/sys/kernel/version /etc/localtime /usr/lib{,32,64}/gconv/gconv-modules.cache /usr/share/locale/locale.alias
+ do
+ FILE=`realpath $i`
+ [ -n "$FILE" -a -r "$FILE" -a ! -L "$FILE" ] && echo 'allow_read '$FILE
+ done
+ set -f
+- for dir in `realpath -n /usr/share/` `realpath -n /usr/lib/`
++ for dir in `realpath -n /usr/share/` `realpath -n /usr/lib/` `realpath -n /usr/lib32/` `realpath -n /usr/lib64/`
+ do
+ if [ -d $dir ]; then
+ # Allow reading font files.
+@@ -221,7 +231,7 @@
+ #
+ # You can add as you like to the list below.
+ #
+- for FILE in /sbin/cardmgr /sbin/getty /sbin/init /sbin/klogd /sbin/mingetty /sbin/portmap /sbin/rpc.statd /sbin/syslogd /sbin/udevd /usr/X11R6/bin/xfs /usr/bin/dbus-daemon-1 /usr/bin/jserver /usr/bin/mDNSResponder /usr/bin/nifd /usr/bin/spamd /usr/sbin/acpid /usr/sbin/afpd /usr/sbin/anacron /usr/sbin/apache2 /usr/sbin/apmd /usr/sbin/atalkd /usr/sbin/atd /usr/sbin/cannaserver /usr/sbin/cpuspeed /usr/sbin/cron /usr/sbin/crond /usr/sbin/cupsd /usr/sbin/dhcpd /usr/sbin/exim4 /usr/sbin/gpm /usr/sbin/hald /usr/sbin/htt /usr/sbin/httpd /usr/sbin/inetd /usr/sbin/logrotate /usr/sbin/lpd /usr/sbin/nmbd /usr/sbin/papd /usr/sbin/rpc.idmapd /usr/sbin/rpc.mountd /usr/sbin/rpc.rquotad /usr/sbin/sendmail.sendmail /usr/sbin/smartd /usr/sbin/smbd /usr/sbin/squid /usr/sbin/sshd /usr/sbin/vmware-guestd /usr/sbin/vsftpd /usr/sbin/xinetd
++ for FILE in /sbin/cardmgr /sbin/getty /sbin/init /sbin/klogd /sbin/mingetty /sbin/portmap /sbin/rpc.statd /sbin/syslogd /sbin/udevd /usr/X11R6/bin/xfs /usr/bin/dbus-daemon /usr/bin/dbus-daemon-1 /usr/bin/jserver /usr/bin/mDNSResponder /usr/bin/nifd /usr/bin/spamd /usr/sbin/acpid /usr/sbin/afpd /usr/sbin/anacron /usr/sbin/apache2 /usr/sbin/apmd /usr/sbin/atalkd /usr/sbin/atd /usr/sbin/cannaserver /usr/sbin/cpuspeed /usr/sbin/cron /usr/sbin/crond /usr/sbin/cupsd /usr/sbin/dhcpd /usr/sbin/exim4 /usr/sbin/gpm /usr/sbin/hald /usr/sbin/htt /usr/sbin/httpd /usr/sbin/inetd /usr/sbin/logrotate /usr/sbin/lpd /usr/sbin/nmbd /usr/sbin/papd /usr/sbin/rpc.idmapd /usr/sbin/rpc.mountd /usr/sbin/rpc.rquotad /usr/sbin/sendmail.sendmail /usr/sbin/smartd /usr/sbin/smbd /usr/sbin/squid /usr/sbin/sshd /usr/sbin/vmware-guestd /usr/sbin/vsftpd /usr/sbin/xinetd
+ do
+ FILE=`realpath $FILE 2> /dev/null`
+ [ -n "$FILE" -a -f "$FILE" -a -x "$FILE" -a ! -L "$FILE" ] && echo 'initialize_domain '$FILE
+@@ -256,6 +266,11 @@
+ echo 'file_pattern /var/spool/squid/\*/\*/'
+ echo 'file_pattern /var/spool/squid/\*/\*/\*'
+ fi
++ if [ -d /var/cache/squid/ ]; then
++ echo 'file_pattern /var/cache/squid/\*/'
++ echo 'file_pattern /var/cache/squid/\*/\*/'
++ echo 'file_pattern /var/cache/squid/\*/\*/\*'
++ fi
+
+ #
+ # Make patterns for spamd(1).
+@@ -369,6 +384,10 @@
+ if grep -qF '/tmp/whatis.XXXXXX' $MAKEWHATIS_PATH; then
+ echo 'file_pattern /tmp/whatis.\?\?\?\?\?\?'
+ fi
++ if grep -qF '/tmp/whatis.tmp.dir.$$' $MAKEWHATIS_PATH; then
++ echo 'file_pattern /tmp/whatis.tmp.dir.\$/'
++ echo 'file_pattern /tmp/whatis.tmp.dir.\$/w'
++ fi
+ fi
+
+ #
+@@ -514,6 +533,41 @@
+ echo 'file_pattern /var/run/nscd/db\?\?\?\?\?\?'
+ fi
+
++ if [ -e /etc/gentoo-release ]; then
++ echo 'file_pattern /var/cache/edb/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/eix'
++ echo 'file_pattern /var/cache/revdep-rebuild/\*.rr'
++ echo 'file_pattern /var/db/pkg/\*'
++ echo 'file_pattern /var/db/pkg/\*/\*'
++ echo 'file_pattern /var/db/pkg/\*/\*/\*'
++ echo 'file_pattern /var/lib/portage/\*'
++ echo 'file_pattern /var/tmp/portage/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ fi
++
+ if [ -d /var/lib/init.d/ ]; then
+ echo 'file_pattern /var/lib/init.d/mtime-test.\$'
+ echo 'file_pattern /var/lib/init.d/exclusive/\*.\$'
+@@ -525,6 +579,10 @@
+ echo 'file_pattern /etc/gshadow.\$'
+ echo 'file_pattern /etc/passwd.\$'
+ echo 'file_pattern /etc/shadow.\$'
++ echo 'file_pattern /etc/group.edit'
++ echo 'file_pattern /etc/gshadow.edit'
++ echo 'file_pattern /etc/passwd.edit'
++ echo 'file_pattern /etc/shadow.edit'
+ echo 'file_pattern /var/cache/logwatch/logwatch.\*/'
+ echo 'file_pattern /var/cache/logwatch/logwatch.\*/\*'
+ echo 'file_pattern /var/tmp/sqlite_\*'
+diff -Naur ccstools.orig/tomoyo_init_policy.sh ccstools/tomoyo_init_policy.sh
+--- ccstools.orig/tomoyo_init_policy.sh 2009-06-23 09:00:00.000000000 +0900
++++ ccstools/tomoyo_init_policy.sh 2009-07-05 11:36:40.000000000 +0900
+@@ -120,16 +120,26 @@
+ grep -qF "Fedora Core" /etc/issue && echo 'file_pattern /tmp/crontab.XXXX\?\?\?\?\?\?' # FC3
+ grep -qF "Debian" /etc/issue && echo 'file_pattern /tmp/crontab.\?\?\?\?\?\?/crontab' # Sarge
+
++ CRONTAB_PATH=`which crontab 2> /dev/null`
++ if [ -n "$CRONTAB_PATH" ]; then
++ # vixie-cron and cronie
++ grep -qF 'crontab.XXXXXXXXXX' $CRONTAB_PATH && echo 'file_pattern /tmp/crontab.XXXX\?\?\?\?\?\?'
++ # dcron
++ grep -qF 'crontab.XXXXXX' $CRONTAB_PATH && echo 'file_pattern /tmp/crontab.\?\?\?\?\?\?'
++ # fcron
++ grep -qF 'fcr-XXXXXX' $CRONTAB_PATH && echo 'file_pattern /tmp/fcr-\?\?\?\?\?\?'
++ fi
++
+ #
+ # Allow reading some data files.
+ #
+- for i in /etc/ld.so.cache /proc/meminfo /proc/sys/kernel/version /etc/localtime /usr/lib/gconv/gconv-modules.cache /usr/share/locale/locale.alias
++ for i in /etc/ld.so.cache /proc/meminfo /proc/sys/kernel/version /etc/localtime /usr/lib{,32,64}/gconv/gconv-modules.cache /usr/share/locale/locale.alias
+ do
+ FILE=`realpath $i`
+ [ -n "$FILE" -a -r "$FILE" -a ! -L "$FILE" ] && echo 'allow_read '$FILE
+ done
+ set -f
+- for dir in `realpath -n /usr/share/` `realpath -n /usr/lib/`
++ for dir in `realpath -n /usr/share/` `realpath -n /usr/lib/` `realpath -n /usr/lib32/` `realpath -n /usr/lib64/`
+ do
+ if [ -d $dir ]; then
+ # Allow reading font files.
+@@ -209,7 +219,7 @@
+ #
+ # You can add as you like to the list below.
+ #
+- for FILE in /sbin/cardmgr /sbin/getty /sbin/init /sbin/klogd /sbin/mingetty /sbin/portmap /sbin/rpc.statd /sbin/syslogd /sbin/udevd /usr/X11R6/bin/xfs /usr/bin/dbus-daemon-1 /usr/bin/jserver /usr/bin/mDNSResponder /usr/bin/nifd /usr/bin/spamd /usr/sbin/acpid /usr/sbin/afpd /usr/sbin/anacron /usr/sbin/apache2 /usr/sbin/apmd /usr/sbin/atalkd /usr/sbin/atd /usr/sbin/cannaserver /usr/sbin/cpuspeed /usr/sbin/cron /usr/sbin/crond /usr/sbin/cupsd /usr/sbin/dhcpd /usr/sbin/exim4 /usr/sbin/gpm /usr/sbin/hald /usr/sbin/htt /usr/sbin/httpd /usr/sbin/inetd /usr/sbin/logrotate /usr/sbin/lpd /usr/sbin/nmbd /usr/sbin/papd /usr/sbin/rpc.idmapd /usr/sbin/rpc.mountd /usr/sbin/rpc.rquotad /usr/sbin/sendmail.sendmail /usr/sbin/smartd /usr/sbin/smbd /usr/sbin/squid /usr/sbin/sshd /usr/sbin/vmware-guestd /usr/sbin/vsftpd /usr/sbin/xinetd
++ for FILE in /sbin/cardmgr /sbin/getty /sbin/init /sbin/klogd /sbin/mingetty /sbin/portmap /sbin/rpc.statd /sbin/syslogd /sbin/udevd /usr/X11R6/bin/xfs /usr/bin/dbus-daemon /usr/bin/dbus-daemon-1 /usr/bin/jserver /usr/bin/mDNSResponder /usr/bin/nifd /usr/bin/spamd /usr/sbin/acpid /usr/sbin/afpd /usr/sbin/anacron /usr/sbin/apache2 /usr/sbin/apmd /usr/sbin/atalkd /usr/sbin/atd /usr/sbin/cannaserver /usr/sbin/cpuspeed /usr/sbin/cron /usr/sbin/crond /usr/sbin/cupsd /usr/sbin/dhcpd /usr/sbin/exim4 /usr/sbin/gpm /usr/sbin/hald /usr/sbin/htt /usr/sbin/httpd /usr/sbin/inetd /usr/sbin/logrotate /usr/sbin/lpd /usr/sbin/nmbd /usr/sbin/papd /usr/sbin/rpc.idmapd /usr/sbin/rpc.mountd /usr/sbin/rpc.rquotad /usr/sbin/sendmail.sendmail /usr/sbin/smartd /usr/sbin/smbd /usr/sbin/squid /usr/sbin/sshd /usr/sbin/vmware-guestd /usr/sbin/vsftpd /usr/sbin/xinetd
+ do
+ FILE=`realpath $FILE 2> /dev/null`
+ [ -n "$FILE" -a -f "$FILE" -a -x "$FILE" -a ! -L "$FILE" ] && echo 'initialize_domain '$FILE
+@@ -244,6 +254,11 @@
+ echo 'file_pattern /var/spool/squid/\*/\*/'
+ echo 'file_pattern /var/spool/squid/\*/\*/\*'
+ fi
++ if [ -d /var/cache/squid/ ]; then
++ echo 'file_pattern /var/cache/squid/\*/'
++ echo 'file_pattern /var/cache/squid/\*/\*/'
++ echo 'file_pattern /var/cache/squid/\*/\*/\*'
++ fi
+
+ #
+ # Make patterns for spamd(1).
+@@ -357,6 +372,10 @@
+ if grep -qF '/tmp/whatis.XXXXXX' $MAKEWHATIS_PATH; then
+ echo 'file_pattern /tmp/whatis.\?\?\?\?\?\?'
+ fi
++ if grep -qF '/tmp/whatis.tmp.dir.$$' $MAKEWHATIS_PATH; then
++ echo 'file_pattern /tmp/whatis.tmp.dir.\$/'
++ echo 'file_pattern /tmp/whatis.tmp.dir.\$/w'
++ fi
+ fi
+
+ #
+@@ -502,6 +521,41 @@
+ echo 'file_pattern /var/run/nscd/db\?\?\?\?\?\?'
+ fi
+
++ if [ -e /etc/gentoo-release ]; then
++ echo 'file_pattern /var/cache/edb/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/edb/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/cache/eix'
++ echo 'file_pattern /var/cache/revdep-rebuild/\*.rr'
++ echo 'file_pattern /var/db/pkg/\*'
++ echo 'file_pattern /var/db/pkg/\*/\*'
++ echo 'file_pattern /var/db/pkg/\*/\*/\*'
++ echo 'file_pattern /var/lib/portage/\*'
++ echo 'file_pattern /var/tmp/portage/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ echo 'file_pattern /var/tmp/portage/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*/\*'
++ fi
++
+ if [ -d /var/lib/init.d/ ]; then
+ echo 'file_pattern /var/lib/init.d/mtime-test.\$'
+ echo 'file_pattern /var/lib/init.d/exclusive/\*.\$'
+@@ -513,6 +567,10 @@
+ echo 'file_pattern /etc/gshadow.\$'
+ echo 'file_pattern /etc/passwd.\$'
+ echo 'file_pattern /etc/shadow.\$'
++ echo 'file_pattern /etc/group.edit'
++ echo 'file_pattern /etc/gshadow.edit'
++ echo 'file_pattern /etc/passwd.edit'
++ echo 'file_pattern /etc/shadow.edit'
+ echo 'file_pattern /var/cache/logwatch/logwatch.\*/'
+ echo 'file_pattern /var/cache/logwatch/logwatch.\*/\*'
+ echo 'file_pattern /var/tmp/sqlite_\*'
diff --git a/sys-apps/ccs-tools/metadata.xml b/sys-apps/ccs-tools/metadata.xml
new file mode 100644
index 000000000000..5b14597b8ad0
--- /dev/null
+++ b/sys-apps/ccs-tools/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>matsuu@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
+