summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-06-01 04:51:09 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-06-01 04:51:09 +0000
commit4ca4d2212f0350d591d55fbd7caacaefd110dc4f (patch)
tree0fe3e6671259d3113786f6d20aed697f8e8a40a4 /sys-apps/xmbmon
parentAdd xmbmon to portage (diff)
downloadgentoo-2-4ca4d2212f0350d591d55fbd7caacaefd110dc4f.tar.gz
gentoo-2-4ca4d2212f0350d591d55fbd7caacaefd110dc4f.tar.bz2
gentoo-2-4ca4d2212f0350d591d55fbd7caacaefd110dc4f.zip
Add xmbmon to portage
Diffstat (limited to 'sys-apps/xmbmon')
-rw-r--r--sys-apps/xmbmon/ChangeLog9
-rw-r--r--sys-apps/xmbmon/Manifest4
-rw-r--r--sys-apps/xmbmon/files/digest-xmbmon-2.0.11
-rw-r--r--sys-apps/xmbmon/xmbmon-2.0.1.ebuild49
4 files changed, 61 insertions, 2 deletions
diff --git a/sys-apps/xmbmon/ChangeLog b/sys-apps/xmbmon/ChangeLog
new file mode 100644
index 000000000000..34a7ded4dd07
--- /dev/null
+++ b/sys-apps/xmbmon/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-apps/xmbmon
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xmbmon/ChangeLog,v 1.1 2003/06/01 04:50:44 lostlogic Exp $
+
+*xmbmon-2.0.1 (31 May 2003)
+
+ 31 May 2003; Brandon Low <lostlogic@gentoo.org> xmbmon-2.0.1.ebuild:
+ Add new package to portage, thanks to Damjan (Bug 19622 for the ebuild
+
diff --git a/sys-apps/xmbmon/Manifest b/sys-apps/xmbmon/Manifest
index 10cdc8ba5d88..a2049e765d82 100644
--- a/sys-apps/xmbmon/Manifest
+++ b/sys-apps/xmbmon/Manifest
@@ -1,3 +1,3 @@
-MD5 e10dd4d03356c12e460ceb699f6000d4 xmbmon-2.0.1.ebuild 1124
-MD5 10176a230162f8ecf7b6e2e35bd26d30 ChangeLog 391
+MD5 f6e9532aa15014f65f52f17d9fdae12b xmbmon-2.0.1.ebuild 1225
+MD5 d232271012103b20b8b69b51cdf26972 ChangeLog 389
MD5 0c84fd7edf198ccac16658e81a11848a files/digest-xmbmon-2.0.1 60
diff --git a/sys-apps/xmbmon/files/digest-xmbmon-2.0.1 b/sys-apps/xmbmon/files/digest-xmbmon-2.0.1
new file mode 100644
index 000000000000..02fc86b424d4
--- /dev/null
+++ b/sys-apps/xmbmon/files/digest-xmbmon-2.0.1
@@ -0,0 +1 @@
+MD5 1774fdd5ef6b6fa6b119ca5826381aac xmbmon201.tar.gz 95967
diff --git a/sys-apps/xmbmon/xmbmon-2.0.1.ebuild b/sys-apps/xmbmon/xmbmon-2.0.1.ebuild
new file mode 100644
index 000000000000..cf723e8692fd
--- /dev/null
+++ b/sys-apps/xmbmon/xmbmon-2.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xmbmon/xmbmon-2.0.1.ebuild,v 1.1 2003/06/01 04:50:44 lostlogic Exp $
+
+MY_P="${PN}${PV//.}"
+DESCRIPTION="Mother Board Monitor Program for X Window System"
+HOMEPAGE="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/download.html"
+SRC_URI="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/${MY_P}.tar.gz"
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X"
+
+DEPEND="virtual/glibc
+ X? ( virtual/x11 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+
+ econf || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+
+ dosbin mbmon
+ fperms 4555 /usr/sbin/mbmon
+ fowners root.wheel /usr/sbin/mbmon
+
+ if use X; then
+ dosbin xmbmon
+ fperms 4555 /usr/sbin/xmbmon
+ fowners root.wheel /usr/sbin/xmbmon
+ fi
+
+ dodoc 00README*
+}
+
+pkg_postinst() {
+
+ einfo "These programs access SMBus or ISA-IO port without any kind"
+ einfo "of checking. It is, therefore, very dangerous and may cause"
+ einfo "system-crash in worst cases. Make sure you read 00README.txt,"
+ einfo "section 4, How to use!"
+
+ ewarn "Binaries are setuid root!"
+}