summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-02-10 00:41:28 +0000
committerMike Frysinger <vapier@gentoo.org>2007-02-10 00:41:28 +0000
commitda2907e3fc793dc5aff1dac6224ba7740fb92c20 (patch)
treef77d938e1dd62fc3b82e7f2d8ded14cbd7175d8b /sys-apps/usbutils
parentfix typo (diff)
downloadgentoo-2-da2907e3fc793dc5aff1dac6224ba7740fb92c20.tar.gz
gentoo-2-da2907e3fc793dc5aff1dac6224ba7740fb92c20.tar.bz2
gentoo-2-da2907e3fc793dc5aff1dac6224ba7740fb92c20.zip
Add a -q (quiet) flag to update-usbids and have the cronjob use it #164800 by Horst Prote.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-apps/usbutils')
-rw-r--r--sys-apps/usbutils/ChangeLog16
-rw-r--r--sys-apps/usbutils/files/digest-usbutils-0.72-r13
-rw-r--r--sys-apps/usbutils/files/usbutils-0.72-update-usbids.patch31
-rwxr-xr-xsys-apps/usbutils/files/usbutils.cron2
-rw-r--r--sys-apps/usbutils/usbutils-0.72-r1.ebuild46
5 files changed, 96 insertions, 2 deletions
diff --git a/sys-apps/usbutils/ChangeLog b/sys-apps/usbutils/ChangeLog
index 50ff21e9a313..3e6f0e9c8f53 100644
--- a/sys-apps/usbutils/ChangeLog
+++ b/sys-apps/usbutils/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for sys-apps/usbutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.49 2007/01/19 04:20:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.50 2007/02/10 00:41:28 vapier Exp $
+
+ 10 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/usbutils-0.72-update-usbids.patch, files/usbutils.cron,
+ +usbutils-0.72-r1.ebuild:
+ Add a -q (quiet) flag to update-usbids and have the cronjob use it #164800
+ by Horst Prote.
+
+*usbutils-0.72-r1 (10 Feb 2007)
+
+ 10 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/usbutils-0.72-update-usbids.patch, files/usbutils.cron,
+ +usbutils-0.72-r1.ebuild:
+ Add a -q (quiet) flag to update-usbids and have th cronjob use it #164800 by
+ Horst Prote.
*usbutils-0.72 (19 Jan 2007)
diff --git a/sys-apps/usbutils/files/digest-usbutils-0.72-r1 b/sys-apps/usbutils/files/digest-usbutils-0.72-r1
new file mode 100644
index 000000000000..914cebdb1d21
--- /dev/null
+++ b/sys-apps/usbutils/files/digest-usbutils-0.72-r1
@@ -0,0 +1,3 @@
+MD5 ee345fe605ffcfce843dae4aed81122b usbutils-0.72.tar.gz 166354
+RMD160 7af32b146e196d1df3de8e403fa92137bfe3d4c7 usbutils-0.72.tar.gz 166354
+SHA256 00385353242173b878413e0423c1dddcbbb50a3cadc3bb9d0a6adcf335794423 usbutils-0.72.tar.gz 166354
diff --git a/sys-apps/usbutils/files/usbutils-0.72-update-usbids.patch b/sys-apps/usbutils/files/usbutils-0.72-update-usbids.patch
new file mode 100644
index 000000000000..f049c22dccd8
--- /dev/null
+++ b/sys-apps/usbutils/files/usbutils-0.72-update-usbids.patch
@@ -0,0 +1,31 @@
+--- update-usbids.sh
++++ update-usbids.sh
+@@ -2,12 +2,22 @@
+
+ # see also update-pciids.sh (fancier)
+
++[ "$1" = "-q" ] && quiet="true" || quiet="false"
++
+ set -e
+ SRC="http://www.linux-usb.org/usb.ids"
+ DEST=usb.ids
+
++# if usb.ids is read-only (because the filesystem is read-only),
++# then just skip this whole process.
++if ! touch ${DEST} >&2 >/dev/null ; then
++ ${quiet} || echo "${DEST} is read-only, exiting."
++ exit 0
++fi
++
+ if which wget >/dev/null ; then
+ DL="wget -O $DEST.new $SRC"
++ ${quiet} && DL="$DL -q"
+ elif which lynx >/dev/null ; then
+ DL="eval lynx -source $SRC >$DEST.new"
+ else
+@@ -33,4 +43,4 @@
+ fi
+ mv $DEST.new $DEST
+
+-echo "Done."
++${quiet} || echo "Done."
diff --git a/sys-apps/usbutils/files/usbutils.cron b/sys-apps/usbutils/files/usbutils.cron
index fd6da3b3ee7a..1018546d18fe 100755
--- a/sys-apps/usbutils/files/usbutils.cron
+++ b/sys-apps/usbutils/files/usbutils.cron
@@ -1,2 +1,2 @@
#!/bin/sh
-exec /usr/sbin/update-usbids
+exec /usr/sbin/update-usbids -q
diff --git a/sys-apps/usbutils/usbutils-0.72-r1.ebuild b/sys-apps/usbutils/usbutils-0.72-r1.ebuild
new file mode 100644
index 000000000000..fa07ead7c901
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-0.72-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-0.72-r1.ebuild,v 1.1 2007/02/10 00:41:28 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="http://linux-usb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/libusb"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-update-usbids.patch
+
+ # put usb.ids in same place as pci.ids (/usr/share/misc)
+ sed -i \
+ -e 's:/usr/share/usb.ids:/usr/share/misc/usb.ids:' \
+ lsusb.8 || die "sed lsusb.8"
+ sed -e '/^DEST=/s:=usb.ids:=/usr/share/misc/usb.ids:' \
+ update-usbids.sh > update-usbids
+}
+
+src_compile() {
+ econf \
+ --datadir=/usr/share/misc \
+ --enable-usbmodules \
+ || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dosbin update-usbids || die "update-usbids failed"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/usbutils.cron update-usbids || die
+}