summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-02-21 18:28:48 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-02-21 18:28:48 +0000
commitfbf2a063f8bc90f0a393ef852fa839442fd72824 (patch)
tree137282c566e4c30afd0ef6caa37af98d8a74391f /sys-apps/usb_modeswitch/usb_modeswitch-1.1.0.ebuild
parentVersion bump. (diff)
downloadgentoo-2-fbf2a063f8bc90f0a393ef852fa839442fd72824.tar.gz
gentoo-2-fbf2a063f8bc90f0a393ef852fa839442fd72824.tar.bz2
gentoo-2-fbf2a063f8bc90f0a393ef852fa839442fd72824.zip
Version bump per bug #306133
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/usb_modeswitch/usb_modeswitch-1.1.0.ebuild')
-rw-r--r--sys-apps/usb_modeswitch/usb_modeswitch-1.1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/usb_modeswitch/usb_modeswitch-1.1.0.ebuild b/sys-apps/usb_modeswitch/usb_modeswitch-1.1.0.ebuild
new file mode 100644
index 000000000000..7b90a762a694
--- /dev/null
+++ b/sys-apps/usb_modeswitch/usb_modeswitch-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/usb_modeswitch-1.1.0.ebuild,v 1.1 2010/02/21 18:28:48 robbat2 Exp $
+
+inherit multilib
+
+MY_PN="${PN/_/-}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="USB_ModeSwitch is a tool for controlling 'flip flop' (multiple devices) USB gear like UMTS sticks."
+HOMEPAGE="http://www.draisberghof.de/usb_modeswitch/"
+SRC_URI="http://www.draisberghof.de/usb_modeswitch/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=virtual/libusb-0*"
+RDEPEND="${DEPEND}
+ dev-lang/tcl"
+# TCL rdep is not an error. The runner script is written in it.
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ UDEVDIR="/$(get_libdir)/udev/"
+ dodir "${UDEVDIR}" /usr/share/man/man1 "${UDEVDIR}"/rules.d /etc/udev/rules.d/
+ emake files-install DESTDIR="${D}" UDEVDIR="${D}/${UDEVDIR}"
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}"/91-usb_modeswitch.rules.udev-ge-106 \
+ 91-usb_modeswitch.rules
+}
+
+pkg_postinst() {
+ einfo 'For automated mode switching via udev, use "lsusb"'
+ einfo 'to find the correct values for your device and modify'
+ einfo 'them in /etc/udev/rules.d/91-usb_modeswitch.rules'
+ einfo
+ einfo 'You should also read the documentation on'
+ einfo "${HOMEPAGE}"
+}