summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-04-13 10:19:41 +0000
committerMike Frysinger <vapier@gentoo.org>2007-04-13 10:19:41 +0000
commit53c1eeddded7b5348b799e90bd90b863039c2004 (patch)
treeddb133596f3e89070cc472f1272b0a64687b15d8 /sys-apps/man-db
parentold (diff)
downloadgentoo-2-53c1eeddded7b5348b799e90bd90b863039c2004.tar.gz
gentoo-2-53c1eeddded7b5348b799e90bd90b863039c2004.tar.bz2
gentoo-2-53c1eeddded7b5348b799e90bd90b863039c2004.zip
Version bump #173919 by Pierre-Yves Rofes.
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog10
-rw-r--r--sys-apps/man-db/files/digest-man-db-2.4.43
-rw-r--r--sys-apps/man-db/files/man-db-2.4.4-sections.patch8
-rw-r--r--sys-apps/man-db/man-db-2.4.4.ebuild41
4 files changed, 60 insertions, 2 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index 82bcb6b61536..ddab0ba6c76d 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/man-db
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.2 2006/10/06 02:37:55 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.3 2007/04/13 10:19:41 vapier Exp $
+
+*man-db-2.4.4 (13 Apr 2007)
+
+ 13 Apr 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/man-db-2.4.4-sections.patch, +man-db-2.4.4.ebuild:
+ Version bump #173919 by Pierre-Yves Rofes.
*man-db-2.4.3-r1 (06 Oct 2006)
diff --git a/sys-apps/man-db/files/digest-man-db-2.4.4 b/sys-apps/man-db/files/digest-man-db-2.4.4
new file mode 100644
index 000000000000..520d501cae44
--- /dev/null
+++ b/sys-apps/man-db/files/digest-man-db-2.4.4
@@ -0,0 +1,3 @@
+MD5 9d7952de1aeb9121497a8204c59c56d7 man-db-2.4.4.tar.gz 898364
+RMD160 9f7805a38ddef3772626a8ba34440d06b5c6e346 man-db-2.4.4.tar.gz 898364
+SHA256 e29157de108a993b910b4203f2545ed3e5cf1e869dfdeca4a05b98eaa3d32d14 man-db-2.4.4.tar.gz 898364
diff --git a/sys-apps/man-db/files/man-db-2.4.4-sections.patch b/sys-apps/man-db/files/man-db-2.4.4-sections.patch
new file mode 100644
index 000000000000..8547e799d3dd
--- /dev/null
+++ b/sys-apps/man-db/files/man-db-2.4.4-sections.patch
@@ -0,0 +1,8 @@
+--- src/man_db.conf.in
++++ src/man_db.conf.in
+@@ -109,4 +109,4 @@
+ # is that you only need to explicitly list extensions if you want to force a
+ # particular order. Sections with extensions should usually be adjacent to
+ # their main section (e.g. "1 1mh 8 ...").
+-SECTION 1 n l 8 3 2 5 4 9 6 7
++SECTION 1 1p n l 8 3 3p 2 5 4 9 6 7 0p 1x 2x 3x 4x 5x 6x 7x 8x
diff --git a/sys-apps/man-db/man-db-2.4.4.ebuild b/sys-apps/man-db/man-db-2.4.4.ebuild
new file mode 100644
index 000000000000..4f466efd02c1
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.4.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.4.4.ebuild,v 1.1 2007/04/13 10:19:41 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="http://download.savannah.nongnu.org/releases/man-db/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-libs/db"
+RDEPEND="sys-libs/db
+ !sys-apps/man"
+PROVIDE="virtual/man"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-sections.patch
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake -j1 || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc README docs/{ChangeLog,NEWS,ToDo}
+}