summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-11-05 02:52:16 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-11-05 02:52:16 +0000
commit4815ffb43efcc2a529f12d681bfbdf2ba0b70c35 (patch)
tree5ecb3c75cf765be3bbf8638997ad1fe23c943226 /sys-apps/iproute2
parentAdded dependencies (diff)
downloadgentoo-2-4815ffb43efcc2a529f12d681bfbdf2ba0b70c35.tar.gz
gentoo-2-4815ffb43efcc2a529f12d681bfbdf2ba0b70c35.tar.bz2
gentoo-2-4815ffb43efcc2a529f12d681bfbdf2ba0b70c35.zip
2 new important packages
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/files/digest-iproute2-2.2.41
-rw-r--r--sys-apps/iproute2/iproute2-2.2.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/iproute2/files/digest-iproute2-2.2.4 b/sys-apps/iproute2/files/digest-iproute2-2.2.4
new file mode 100644
index 000000000000..4bb3a63d1bcb
--- /dev/null
+++ b/sys-apps/iproute2/files/digest-iproute2-2.2.4
@@ -0,0 +1 @@
+MD5 70ef05a56f32f73a1ef67ef40d35c37e iproute2-2.2.4-now-ss001007.tar.gz
diff --git a/sys-apps/iproute2/iproute2-2.2.4.ebuild b/sys-apps/iproute2/iproute2-2.2.4.ebuild
new file mode 100644
index 000000000000..2cb0ccca833c
--- /dev/null
+++ b/sys-apps/iproute2/iproute2-2.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.2.4.ebuild,v 1.1 2000/11/05 02:52:16 drobbins Exp $
+
+A=iproute2-2.2.4-now-ss001007.tar.gz
+S=${WORKDIR}/iproute2
+DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
+SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/${A}"
+
+src_compile() {
+ try make
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
+}
+
+src_install() {
+ into /
+ cd ${S}/ip
+ dosbin ifcfg ip routef routel rtacct rtmon rtpr
+ cd ${S}/tc
+ dosbin tc
+ cd ${S}
+ dodoc README* RELNOTES examples/*
+ dodir /etc/iproute2
+ insinto /etc/iproute2
+ doins ${S}/etc/iproute2/*
+}
+
+