summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-08 03:57:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-08 03:57:44 +0000
commitb3c95113de33472c015f19d88f5614d42e9fee22 (patch)
treed96fa9f721d186ca5174984725b50fc32d1f6c86 /sys-apps/help2man
parentno longer need i64c() as newer shadow no longer utilizes it (diff)
downloadgentoo-2-b3c95113de33472c015f19d88f5614d42e9fee22.tar.gz
gentoo-2-b3c95113de33472c015f19d88f5614d42e9fee22.tar.bz2
gentoo-2-b3c95113de33472c015f19d88f5614d42e9fee22.zip
Make nls support conditional to GLIBC as it requires preloadable_intl.
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'sys-apps/help2man')
-rw-r--r--sys-apps/help2man/ChangeLog7
-rw-r--r--sys-apps/help2man/files/digest-help2man-1.35.12
-rw-r--r--sys-apps/help2man/help2man-1.35.1.ebuild16
3 files changed, 17 insertions, 8 deletions
diff --git a/sys-apps/help2man/ChangeLog b/sys-apps/help2man/ChangeLog
index d3afc26bc000..b0282f94bdbd 100644
--- a/sys-apps/help2man/ChangeLog
+++ b/sys-apps/help2man/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/help2man
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.22 2005/09/16 08:03:12 agriffis Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.23 2006/05/08 03:57:44 flameeyes Exp $
+
+ 08 May 2006; Diego Pettenò <flameeyes@gentoo.org> help2man-1.35.1.ebuild:
+ Make nls support conditional to GLIBC as it requires preloadable_intl.
16 Sep 2005; Aron Griffis <agriffis@gentoo.org> help2man-1.35.1.ebuild:
Mark 1.35.1 stable on alpha
diff --git a/sys-apps/help2man/files/digest-help2man-1.35.1 b/sys-apps/help2man/files/digest-help2man-1.35.1
index f0790765ae61..4cbd0fc53d56 100644
--- a/sys-apps/help2man/files/digest-help2man-1.35.1
+++ b/sys-apps/help2man/files/digest-help2man-1.35.1
@@ -1 +1,3 @@
MD5 e3c9e846dd163eb7f1d1661e2d0baa07 help2man-1.35.1.tar.gz 76472
+RMD160 eb681a5426efb85ec806769e3319ae77eae00e68 help2man-1.35.1.tar.gz 76472
+SHA256 b86e5a900338a18274098ff86df7955433d37d642e4719405c353493b8a90e85 help2man-1.35.1.tar.gz 76472
diff --git a/sys-apps/help2man/help2man-1.35.1.ebuild b/sys-apps/help2man/help2man-1.35.1.ebuild
index 4469e7d306fd..2eaabb6f7f25 100644
--- a/sys-apps/help2man/help2man-1.35.1.ebuild
+++ b/sys-apps/help2man/help2man-1.35.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/help2man-1.35.1.ebuild,v 1.5 2005/09/16 08:03:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/help2man-1.35.1.ebuild,v 1.6 2006/05/08 03:57:44 flameeyes Exp $
DESCRIPTION="GNU utility to convert program --help output to a man page"
HOMEPAGE="http://www.gnu.org/software/help2man"
@@ -8,16 +8,20 @@ SRC_URI="http://ftp.gnu.org/gnu/help2man/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha ~amd64 ~arm ~hppa ia64 ~m68k ~mips ~ppc ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="alpha ~amd64 ~arm ~hppa ia64 ~m68k ~mips ~ppc ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="nls"
RDEPEND="dev-lang/perl"
DEPEND="${RDEPEND}
- nls? ( dev-perl/Locale-gettext
- >=sys-devel/gettext-0.12.1-r1 )"
+ elibc_glibc? ( nls? ( dev-perl/Locale-gettext
+ >=sys-devel/gettext-0.12.1-r1 ) )"
src_compile() {
- econf $(use_enable nls) || die
+ local myconf
+ use elibc_glibc && myconf="${myconf} $(use_enable nls)" \
+ || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
emake || die "emake failed"
}