summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-11-23 06:29:51 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-11-23 06:29:51 +0000
commit0da60824b362e20edaf8d778aca27bf294b9b053 (patch)
tree4f16f923bfdd7ae0c73296e96d3fb315d5693c7c /sys-apps/hal
parentversion bump for HAL 0.5.10 (diff)
downloadgentoo-2-0da60824b362e20edaf8d778aca27bf294b9b053.tar.gz
gentoo-2-0da60824b362e20edaf8d778aca27bf294b9b053.tar.bz2
gentoo-2-0da60824b362e20edaf8d778aca27bf294b9b053.zip
version bump from upstream
(Portage version: 2.1.3.16)
Diffstat (limited to 'sys-apps/hal')
-rw-r--r--sys-apps/hal/ChangeLog9
-rw-r--r--sys-apps/hal/files/0.5.10-hald.conf6
-rw-r--r--sys-apps/hal/files/0.5.10-hald.rc39
-rw-r--r--sys-apps/hal/files/digest-hal-0.5.103
-rw-r--r--sys-apps/hal/files/hal-0.5.9-hide-recovery-partitions.patch14
-rw-r--r--sys-apps/hal/hal-0.5.10.ebuild288
6 files changed, 358 insertions, 1 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 2d1a20580aa2..87887da4f507 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.214 2007/11/22 18:29:46 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.215 2007/11/23 06:29:51 compnerd Exp $
+
+*hal-0.5.10 (23 Nov 2007)
+
+ 23 Nov 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/0.5.10-hald.conf, +files/0.5.10-hald.rc,
+ +files/hal-0.5.9-hide-recovery-partitions.patch, +hal-0.5.10.ebuild:
+ Version bump from upstream
22 Nov 2007; Doug Klima <cardoe@gentoo.org> metadata.xml:
Provide explicit USE flag descriptions in metadata.xml
diff --git a/sys-apps/hal/files/0.5.10-hald.conf b/sys-apps/hal/files/0.5.10-hald.conf
new file mode 100644
index 000000000000..941005a4b36e
--- /dev/null
+++ b/sys-apps/hal/files/0.5.10-hald.conf
@@ -0,0 +1,6 @@
+# /etc/conf.d/hald
+
+# Should HAL be verbose to syslog? Useful for debugging
+HALD_VERBOSE="no"
+
+# vim: ft=gentoo-conf-d
diff --git a/sys-apps/hal/files/0.5.10-hald.rc b/sys-apps/hal/files/0.5.10-hald.rc
new file mode 100644
index 000000000000..f9e53f4dc679
--- /dev/null
+++ b/sys-apps/hal/files/0.5.10-hald.rc
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/files/0.5.10-hald.rc,v 1.1 2007/11/23 06:29:51 compnerd Exp $
+
+depend() {
+ use logger acpid
+ need dbus consolekit
+ after coldplug dns nscd
+}
+
+start() {
+ [ -z "${HALD_VERBOSE}" ] && HALD_VERBOSE="no"
+ ebegin "Starting Hardware Abstraction Layer daemon"
+
+# REAL_ROOT=`mount -fv / | cut -d' ' -f1`
+# TEST_ROOT=`cat /proc/mounts | cut -d' ' -f1 | head -n 2 | tail -n 1`
+
+# if [ ! -e ${TEST_ROOT} ]; then
+# echo "You need a ${TEST_ROOT} that points to your ${REAL_ROOT}"
+# echo "See http://bugs.gentoo.org/show_bug.cgi?id=175243"
+# echo "Quick fix is: ln -s ${REAL_ROOT} ${TEST_ROOT}"
+# eend 2
+# fi
+
+ if [ -f /proc/acpi/event ]; then
+ chgrp haldaemon /proc/acpi/event
+ chmod 440 /proc/acpi/event
+ fi
+
+ start-stop-daemon --start -q --exec /usr/sbin/hald -- --use-syslog --verbose=${HALD_VERBOSE}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Hardware Abstraction Layer daemon"
+ start-stop-daemon --stop -q --pidfile /var/run/hald.pid
+ eend $?
+}
diff --git a/sys-apps/hal/files/digest-hal-0.5.10 b/sys-apps/hal/files/digest-hal-0.5.10
new file mode 100644
index 000000000000..0559695c8a34
--- /dev/null
+++ b/sys-apps/hal/files/digest-hal-0.5.10
@@ -0,0 +1,3 @@
+MD5 fce852c428e7cda0b937087c79eec63f hal-0.5.10.tar.gz 1591146
+RMD160 fafd90e671dbe95a8dd55a4ad257586a0289ef67 hal-0.5.10.tar.gz 1591146
+SHA256 5a71a18c40af2bac64f40f0b8add2b6789924b98d7f1cb79a0faf83cb77acb4c hal-0.5.10.tar.gz 1591146
diff --git a/sys-apps/hal/files/hal-0.5.9-hide-recovery-partitions.patch b/sys-apps/hal/files/hal-0.5.9-hide-recovery-partitions.patch
new file mode 100644
index 000000000000..21ff6af136b5
--- /dev/null
+++ b/sys-apps/hal/files/hal-0.5.9-hide-recovery-partitions.patch
@@ -0,0 +1,14 @@
+--- hal-0.5.9/fdi/policy/10osvendor/20-storage-methods.fdi 2007-05-01 21:39:31.000000000 +0000
++++ hal-0.5.9/fdi/policy/10osvendor/20-storage-methods.fdi 2007-05-01 21:51:14.000000000 +0000
+@@ -100,6 +100,11 @@
+ </match>
+ </match>
+
++ <!-- Hide partitions marked as Compaq Diagnostics -->
++ <match key="volume.partition.type" string="0x12">
++ <merge key="volume.ignore" type="bool">true</merge>
++ </match>
++
+ <!-- EFI firmware partitions -->
+ <match key="volume.fstype" string="vfat">
+ <match key="volume.label" string="EFI">
diff --git a/sys-apps/hal/hal-0.5.10.ebuild b/sys-apps/hal/hal-0.5.10.ebuild
new file mode 100644
index 000000000000..45fce0d38daf
--- /dev/null
+++ b/sys-apps/hal/hal-0.5.10.ebuild
@@ -0,0 +1,288 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.10.ebuild,v 1.1 2007/11/23 06:29:51 compnerd Exp $
+
+inherit eutils linux-info autotools flag-o-matic
+
+DESCRIPTION="Hardware Abstraction Layer"
+HOMEPAGE="http://www.freedesktop.org/Software/hal"
+SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 AFL-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 -mips -ppc64 ~x86"
+
+KERNEL_IUSE="kernel_linux kernel_FreeBSD"
+IUSE="acpi apm crypt debug dell disk-partition doc selinux ${KERNEL_IUSE}"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-libs/dbus-glib-0.61
+ >=dev-libs/expat-1.95.8
+ >=sys-apps/pciutils-2.2.7-r1
+ >=dev-libs/libusb-0.1.10a
+ >=dev-util/gperf-3.0.3
+ >=sys-auth/consolekit-0.2
+ >=sys-auth/policykit-0.6
+ sys-apps/usbutils
+ virtual/eject
+ amd64? ( >=sys-apps/dmidecode-2.7 )
+ dell? ( >=sys-libs/libsmbios-0.13.4 )
+ disk-partition? (
+ || (
+ ~sys-apps/parted-1.7.1
+ ~sys-apps/parted-1.8.6
+ ~sys-apps/parted-1.8.7
+ )
+ )
+ ia64? ( >=sys-apps/dmidecode-2.7 )
+ kernel_linux? (
+ >=sys-fs/udev-111
+ >=sys-apps/util-linux-2.13
+ >=sys-kernel/linux-headers-2.6.19
+ crypt? (
+ || (
+ >=sys-fs/cryptsetup-1.0.5
+ >=sys-fs/cryptsetup-luks-1.0.1
+ )
+ )
+ )
+ kernel_FreeBSD? ( dev-libs/libvolume_id )
+ x86? ( >=sys-apps/dmidecode-2.7 )
+ selinux? ( sys-libs/libselinux sec-policy/selinux-hal )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35
+ doc? (
+ app-doc/doxygen
+ app-text/docbook-sgml-utils
+ app-text/xmlto
+ dev-libs/libxml2
+ )"
+PDEPEND=">=app-misc/hal-info-20071011
+ >=sys-power/pm-utils-0.99.3"
+
+## HAL Daemon drops privledges so we need group access to read disks
+HALDAEMON_GROUPS_LINUX="haldaemon,plugdev,disk,cdrom,cdrw,floppy,usb"
+HALDAEMON_GROUPS_FREEBSD="haldaemon,plugdev,operator"
+
+function notify_uevent() {
+ ewarn
+ ewarn "You must enable Kernel Userspace Events in your kernel."
+ ewarn "For this you need to enable 'Hotplug' under 'General Setup' and"
+ ewarn "basic networking. They are marked CONFIG_HOTPLUG and CONFIG_NET"
+ ewarn "in the config file."
+ ewarn
+ ebeep 5
+}
+
+function notify_inotify() {
+ ewarn
+ ewarn "You must enable the Inotify system in your kernel."
+ ewarn "For this you need to enable 'Inotify support for userspace'"
+ ewarn "in 'File systems'. It is marked CONFIG_INOTIFY_USER in the config file."
+ ewarn
+ ebeep 5
+}
+
+function notify_acpi_procfs() {
+ ewarn
+ ewarn "You must enable support for the ACPI proc files in your kernel."
+ ewarn "For this you need to enable '/proc/acpi files' in"
+ ewarn "'ACPI Support (Advanced Configuration and Power Interface) Support'."
+ ewarn "It is marked ewarn CONFIG_ACPI_PROCFS in the config file."
+ ewarn
+ ebeep 5
+}
+
+function notify_acpi_proc_event() {
+ ewarn
+ ewarn "You have not enabled support for the /proc/acpi/event interface."
+ ewarn "For this you need to enable '/proc/acpi/event support' in"
+ ewarn "ACPI Support (Advanced Configuration and Power Interface) Support"
+ ewarn
+ ebeep 5
+}
+
+pkg_setup() {
+ if use kernel_linux; then
+ kernel_is ge 2 6 19 || ewarn "HAL requires a kernel version 2.6.19 or newer"
+
+ if ! ( linux_chkconfig_present HOTPLUG && linux_chkconfig_present NET )
+ then
+ notify_uevent
+ fi
+
+ linux_chkconfig_present INOTIFY_USER || notify_inotify
+
+ if use acpi ; then
+ linux_chkconfig_present ACPI_PROCFS || notify_acpi_procfs
+ linux_chkconfig_present ACPI_PROC_EVENT || notify_acpi_proc_event
+ fi
+ fi
+
+ # http://devmanual.gentoo.org/ebuild-writing/functions/
+ # http://bugs.gentoo.org/show_bug.cgi?id=191605
+
+ # Create groups for hotplugging and HAL
+ enewgroup haldaemon || die "Problem adding haldaemon group"
+ enewgroup plugdev || die "Problem adding plugdev group"
+
+ # HAL drops priviledges by default now ...
+ # ... so we must make sure it can read disk/cdrom info (ie. be in ${HALDAEMON_GROUPS} groups)
+ if use kernel_linux; then
+ enewuser haldaemon -1 "-1" /dev/null ${HALDAEMON_GROUPS_LINUX} \
+ || die "Problem adding haldaemon user"
+ elif use kernel_FreeBSD; then
+ enewuser haldaemon -1 "-1" /dev/null ${HALDAEMON_GROUPS_FREEBSD} \
+ || die "Problem addding haldaemon user"
+ fi
+
+ # Make sure that the haldaemon user is in the ${HALDAEMON_GROUPS}
+ # If users have a problem with this, let them file a bug
+ if [[ ${ROOT} == / ]] ; then
+ if use kernel_linux; then
+ usermod -G ${HALDAEMON_GROUPS_LINUX} haldaemon
+ elif use kernel_FreeBSD; then
+ pw usermod haldaemon -G ${HALDAEMON_GROUPS_FREEBSD}
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Hide recovery partitions
+ epatch "${FILESDIR}/hal-0.5.9-hide-recovery-partitions.patch"
+
+ # Enable plugdev support
+ epatch "${FILESDIR}/0.5.9/96_plugdev_allow_send.patch"
+}
+
+src_compile() {
+ local acpi="$(use_enable acpi)"
+ local backend=
+ local hardware=
+
+ append-flags -rdynamic
+
+ if use kernel_linux ; then
+ backend="linux"
+ elif use kernel_FreeBSD ; then
+ backend="freebsd"
+ else
+ eerror "Invalid backend"
+ fi
+
+ if use kernel_linux ; then
+ if use acpi ; then
+ # Using IBM ACPI and Toshiba ACPI results in double notification as this
+ # was merged into the Linux Kernel 2.6.22
+ if kernel_is lt 2 6 22 ; then
+ acpi="$acpi --enable-acpi-ibm --enable-acpi-toshiba"
+ else
+ acpi="$acpi --disable-acpi-ibm --disable-acpi-toshiba"
+ fi
+
+ acpi="$acpi --enable-acpi-proc --enable-acpi-acpid"
+ else
+ acpi="$acpi --disable-acpi-ibm --disable-acpi-toshiba"
+ acpi="$acpi --disable-acpi-proc --disable-acpi-acpid"
+ fi
+
+ hardware="--with-cpufreq --with-usb-csr --with-keymaps"
+ use arm && hardware="$hardware --enable-omap"
+
+ if use dell ; then
+ hardware="$hardware --with-dell-backlight"
+ else
+ hardware="$hardware --without-dell-backlight"
+ fi
+ else
+ hardware="--without-cpufreq --without-usb-csr --without-keymaps"
+ hardware="$hardware --disable-omap"
+ hardware="$hardware --without-dell-backlight"
+ hardware="$hardware --enable-acpi-ibm --enable-acpi-toshiba"
+ fi
+
+ econf --with-backend=${backend} \
+ --with-os-type=gentoo \
+ --with-pid-file=/var/run/hald.pid \
+ --with-hwdata=/usr/share/misc \
+ --with-socket-dir=/var/run/hald \
+ --enable-umount-helper \
+ --enable-man-pages \
+ --enable-policy-kit \
+ --enable-console-kit \
+ --enable-acl-management \
+ --enable-pci \
+ --enable-sonypic \
+ $(use_enable apm) \
+ $(use_enable arm pmu) \
+ $(use_enable arm omap) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable disk-partition parted) \
+ $(use_enable doc docbook-docs) \
+ $(use_enable doc doxygen-docs) \
+ --docdir=/usr/share/doc/${PF} \
+ --localstatedir=/var \
+ ${acpi} ${hardware} \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # remove dep on gnome-python
+ mv "${D}"/usr/bin/hal-device-manager "${D}"/usr/share/hal/device-manager/
+
+ # hal umount for unclean unmounts
+ exeinto /lib/udev/
+ newexe "${FILESDIR}"/hal-unmount.dev hal_unmount
+
+ # initscript
+ newinitd "${FILESDIR}"/0.5.10-hald.rc hald
+
+ # configuration
+ cp "${FILESDIR}"/0.5.10-hald.conf "${WORKDIR}"/
+
+ if use debug; then
+ sed -e 's:HALD_VERBOSE="no":HALD_VERBOSE="yes":' \
+ -i "${WORKDIR}"/0.5.10-hald.conf
+ fi
+ newconfd "${WORKDIR}"/0.5.10-hald.conf hald
+
+ # We now create and keep /media here as both gnome-mount and pmount
+ # use these directories, to avoid collision.
+ keepdir /media
+
+ # We also need to create and keep /etc/fdi/{information,policy,preprobe}
+ # or else hal bombs.
+ keepdir /etc/hal/fdi/{information,policy,preprobe}
+
+ # HAL stores it's fdi cache in /var/lib/cache/hald
+ keepdir /var/lib/cache/hald
+
+ # HAL keeps its unix socket here
+ keepdir /var/run/hald
+ keepdir /var/lib/hal
+}
+
+pkg_postinst() {
+ # Despite what people keep changing this location. Either one works.. it doesn't matter
+ # http://dev.gentoo.org/~plasmaroo/devmanual/ebuild-writing/functions/
+
+ elog "The HAL daemon needs to be running for certain applications to"
+ elog "work. Suggested is to add the init script to your start-up"
+ elog "scripts, this should be done like this :"
+ elog "\`rc-update add hald default\`"
+ echo
+ elog "Looking for automounting support? Add yourself to the plugdev group"
+
+ elog "IF you have additional applications which consume ACPI events, you"
+ elog "should consider installing acpid to allow applications to share ACPI"
+ elog "events."
+}