summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-04 00:02:20 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-04 00:02:20 +0000
commit77aae46261bbbbe085ba129b1e475095ac548efc (patch)
treedd265450e13ac1779728959a985654f8edb6daf5 /sys-apps/groff
parentNew version (Manifest recommit) (diff)
downloadgentoo-2-77aae46261bbbbe085ba129b1e475095ac548efc.tar.gz
gentoo-2-77aae46261bbbbe085ba129b1e475095ac548efc.tar.bz2
gentoo-2-77aae46261bbbbe085ba129b1e475095ac548efc.zip
Add patch to resolve tempfile access issues #68404.
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog8
-rw-r--r--sys-apps/groff/files/digest-groff-1.19.1-r21
-rw-r--r--sys-apps/groff/files/groff-1.19.1-tmpfile.patch24
-rw-r--r--sys-apps/groff/groff-1.19.1-r2.ebuild111
4 files changed, 143 insertions, 1 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index 4ab7ebcc33b9..f14153ae86fe 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/groff
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.47 2004/11/01 19:08:30 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.48 2004/11/04 00:02:20 vapier Exp $
+
+*groff-1.19.1-r2 (03 Nov 2004)
+
+ 03 Nov 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/groff-1.19.1-tmpfile.patch, +groff-1.19.1-r2.ebuild:
+ Add patch to resolve tempfile access issues #68404.
01 Nov 2004; Gustavo Zacarias <gustavoz@gentoo.org> groff-1.19.1-r1.ebuild:
Stable on sparc
diff --git a/sys-apps/groff/files/digest-groff-1.19.1-r2 b/sys-apps/groff/files/digest-groff-1.19.1-r2
new file mode 100644
index 000000000000..3c6ac6b3507b
--- /dev/null
+++ b/sys-apps/groff/files/digest-groff-1.19.1-r2
@@ -0,0 +1 @@
+MD5 57d155378640c12a80642664dfdfc892 groff-1.19.1.tar.gz 2629152
diff --git a/sys-apps/groff/files/groff-1.19.1-tmpfile.patch b/sys-apps/groff/files/groff-1.19.1-tmpfile.patch
new file mode 100644
index 000000000000..e341f2e13f03
--- /dev/null
+++ b/sys-apps/groff/files/groff-1.19.1-tmpfile.patch
@@ -0,0 +1,24 @@
+--- groff-1.18.1.1.orig/contrib/groffer/groffer.sh
++++ groff-1.18.1.1/contrib/groffer/groffer.sh
+@@ -3228,17 +3228,12 @@
+ do
+ if is_not_empty "$d"; then
+ if obj d is_dir && obj d is_writable; then
+- _TMP_DIR="${d}/${_PROGRAM_NAME}${_PROCESS_ID}";
+- if obj _TMP_DIR is_dir; then
+- rm -f "${_TMP_DIR}"/*;
++ _TMP_DIR="$(mktemp -d "${d}/${_PROGRAM_NAME}.XXXXXX")"
++ if test $? = 0; then
+ break;
+ else
+- mkdir "${_TMP_DIR}";
+- if obj _TMP_DIR is_not_dir; then
+- _TMP_DIR='';
+- continue;
+- fi;
+- break;
++ _TMP_DIR='';
++ continue;
+ fi;
+ fi;
+ if obj _TMP_DIR is_not_writable; then
diff --git a/sys-apps/groff/groff-1.19.1-r2.ebuild b/sys-apps/groff/groff-1.19.1-r2.ebuild
new file mode 100644
index 000000000000..b65e7b231066
--- /dev/null
+++ b/sys-apps/groff/groff-1.19.1-r2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1-r2.ebuild,v 1.1 2004/11/04 00:02:20 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MB_PATCH="groff_1.18.1-7" #"${P/-/_}-7"
+DESCRIPTION="Text formatter used for man pages"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+SRC_URI="mirror://gnu/groff/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="X"
+
+DEPEND="virtual/libc
+ >=sys-apps/texinfo-4.7-r1"
+PDEPEND=">=sys-apps/man-1.5k-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix the info pages to have .info extensions,
+ # else they do not get gzipped.
+ epatch ${FILESDIR}/groff-1.18-infoext.patch
+
+ # Do not generate example files that require us to
+ # depend on netpbm.
+ epatch ${FILESDIR}/groff-1.18-no-netpbm-depend.patch
+
+ # Make dashes the same as minus on the keyboard so that you
+ # can search for it. Fixes #17580 and #16108
+ # Thanks to James Cloos <cloos@jhcloos.com>
+ epatch ${FILESDIR}/${PN}-man-UTF-8.diff
+
+ # Fix stack limit (inifite loop) #64117
+ epatch ${FILESDIR}/${P}-stack.patch
+
+ # Fix tempfile usage #68404
+ epatch ${FILESDIR}/${P}-tmpfile.patch
+}
+
+src_compile() {
+ local myconf=
+
+ # Fix problems with not finding g++
+ export CC="$(tc-getCC)"
+ export CXX="$(tc-getCXX)"
+
+ # -Os causes segfaults, -O is probably a fine replacement
+ # (fixes bug 36008, 06 Jan 2004 agriffis)
+ replace-flags -Os -O
+
+ # -march=2.0 makes groff unable to finish the compile process
+ use hppa && replace-cpu-flags 2.0 1.0
+
+# myconf="${myconf} `use_enable cjk multibyte`"
+
+ # this is incredibly broken, i have no idea why people are trying to use
+ # it... even the documentation on it states that -fnew-ra is "meant only
+ # for testing. Users should not specify this option, since it is not yet
+ # ready for production use."
+ filter-flags -fnew-ra
+
+ # many fun sandbox errors with econf
+ myconf="${myconf} --host=${CHOST} --prefix=/usr \
+ --mandir=/usr/share/man --infodir=\${inforoot}"
+ ./configure ${myconf} || die
+
+ # Parallel build doesn't work. Patched wanted.
+ emake -j1 || die
+
+ # Only build X stuff if we have X installed, but do
+ # not depend on it, else we get circular deps.
+ if use X && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ xmkmf || die
+ make depend all || die
+ fi
+}
+
+src_install() {
+ dodir /usr /usr/share/doc/${PF}/{examples,html}
+ make prefix=${D}/usr \
+ manroot=${D}/usr/share/man \
+ inforoot=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF} \
+ install || die
+
+ if use X && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ make DESTDIR=${D} \
+ BINDIR=/usr/bin \
+ MANPATH=/usr/share/man \
+ install \
+ install.man || die
+ fi
+
+ # The following links are required for xman
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+ dosym soelim /usr/bin/zsoelim
+
+ cd ${S}
+ dodoc BUG-REPORT ChangeLog FDL MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+}