summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-11-03 13:01:42 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-11-03 13:01:42 +0000
commit27096d71f68fb4abb875b43d82ad7051c1a9391f (patch)
tree32ab21aa6bbb1650f03fa16e3a6e701548a0616f /sys-apps/elfix
parentVersion bump (diff)
downloadgentoo-2-27096d71f68fb4abb875b43d82ad7051c1a9391f.tar.gz
gentoo-2-27096d71f68fb4abb875b43d82ad7051c1a9391f.tar.bz2
gentoo-2-27096d71f68fb4abb875b43d82ad7051c1a9391f.zip
Version bump, fixes bug #525240
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/ChangeLog7
-rw-r--r--sys-apps/elfix/elfix-0.9.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-apps/elfix/ChangeLog b/sys-apps/elfix/ChangeLog
index 62dba83a988e..a4e5b2f13136 100644
--- a/sys-apps/elfix/ChangeLog
+++ b/sys-apps/elfix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/elfix
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/ChangeLog,v 1.86 2014/09/09 02:38:28 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/ChangeLog,v 1.87 2014/11/03 13:01:42 blueness Exp $
+
+*elfix-0.9.0 (03 Nov 2014)
+
+ 03 Nov 2014; Anthony G. Basile <blueness@gentoo.org> +elfix-0.9.0.ebuild:
+ Version bump, fixes bug #525240
09 Sep 2014; Patrick Lauer <patrick@gentoo.org> -elfix-0.8.1.ebuild,
-elfix-0.8.3.ebuild, -elfix-0.8.5.ebuild:
diff --git a/sys-apps/elfix/elfix-0.9.0.ebuild b/sys-apps/elfix/elfix-0.9.0.ebuild
new file mode 100644
index 000000000000..f43eb176bf9f
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.9.0.ebuild,v 1.1 2014/11/03 13:01:42 blueness Exp $
+
+EAPI="5"
+
+DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
+ http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+# These only work with a properly configured PaX kernel
+RESTRICT="test"
+
+DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf --disable-tests \
+ $(use_enable ptpax) \
+ $(use_enable xtpax)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}