summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-07-08 01:44:18 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-07-08 01:44:18 +0000
commit588bdc196c01ea134cd9e15fcb726dd2051f9fe0 (patch)
tree0aceab2add72e9e14e07856697706241774c6173 /sci-mathematics
parentStable for HPPA (bug #276677). (diff)
downloadgentoo-2-588bdc196c01ea134cd9e15fcb726dd2051f9fe0.tar.gz
gentoo-2-588bdc196c01ea134cd9e15fcb726dd2051f9fe0.tar.bz2
gentoo-2-588bdc196c01ea134cd9e15fcb726dd2051f9fe0.zip
Version bump (fixes bug #264757).
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog11
-rw-r--r--sci-mathematics/octave/files/octave-3.2.0_parallel_make.patch12
-rw-r--r--sci-mathematics/octave/octave-2.1.69.ebuild4
-rw-r--r--sci-mathematics/octave/octave-3.2.0.ebuild103
4 files changed, 127 insertions, 3 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 1bd6caa3c15c..f0c630507ee7 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.69 2009/06/21 18:47:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.70 2009/07/08 01:44:18 markusle Exp $
+
+*octave-3.2.0 (07 Jul 2009)
+
+ 07 Jul 2009; Markus Dittrich <markusle@gentoo.org> +octave-3.2.0.ebuild,
+ +files/octave-3.2.0_parallel_make.patch:
+ Version bump. The octave-3.2 ebuild is currently lacking support
+ for GraphicsMagick (currently missing from the tree) and arpack which
+ needs to be keyworded by all the relevant arches first.
+ This fixes bug #264757.
21 Jun 2009; Hans de Graaff <graaff@gentoo.org> octave-2.1.73-r2.ebuild,
octave-3.0.2.ebuild, octave-3.0.3.ebuild:
diff --git a/sci-mathematics/octave/files/octave-3.2.0_parallel_make.patch b/sci-mathematics/octave/files/octave-3.2.0_parallel_make.patch
new file mode 100644
index 000000000000..bcc2f7d29a2a
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.2.0_parallel_make.patch
@@ -0,0 +1,12 @@
+diff -Naur octave-3.2.0/doc/Makefile.in octave-3.2.0.new/doc/Makefile.in
+--- octave-3.2.0/doc/Makefile.in 2009-06-03 07:55:40.000000000 -0400
++++ octave-3.2.0.new/doc/Makefile.in 2009-07-07 18:20:14.000000000 -0400
+@@ -30,6 +30,8 @@
+ all: conf.texi $(SUBDIRS)
+ .PHONY: all
+
++$(SUBDIRS): conf.texi
++
+ conf.texi: conf.texi.in $(TOPDIR)/Makeconf
+ @$(do-subst-texinfo-vals)
+
diff --git a/sci-mathematics/octave/octave-2.1.69.ebuild b/sci-mathematics/octave/octave-2.1.69.ebuild
index a8d67ed999eb..23b922f0c129 100644
--- a/sci-mathematics/octave/octave-2.1.69.ebuild
+++ b/sci-mathematics/octave/octave-2.1.69.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.13 2009/03/04 21:31:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.14 2009/07/08 01:44:18 markusle Exp $
inherit flag-o-matic fortran
diff --git a/sci-mathematics/octave/octave-3.2.0.ebuild b/sci-mathematics/octave/octave-3.2.0.ebuild
new file mode 100644
index 000000000000..3681736e3a77
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.2.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.0.ebuild,v 1.1 2009/07/08 01:44:18 markusle Exp $
+
+EAPI="2"
+inherit flag-o-matic fortran xemacs-elisp-common
+
+DESCRIPTION="High-level interactive language for numerical computations"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="emacs readline zlib doc hdf5 curl fftw xemacs sparse"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/lapack
+ dev-libs/libpcre
+ sys-libs/ncurses
+ sci-visualization/gnuplot
+ >=sci-mathematics/glpk-4.15
+ media-libs/qhull
+ fftw? ( >=sci-libs/fftw-3.1.2 )
+ zlib? ( sys-libs/zlib )
+ hdf5? ( sci-libs/hdf5 )
+ curl? ( net-misc/curl )
+ xemacs? ( app-editors/xemacs )
+ sparse? ( sci-libs/umfpack
+ sci-libs/colamd
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod
+ sci-libs/cxsparse )
+ !sci-mathematics/octave-forge"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ sys-apps/texinfo
+ || ( dev-texlive/texlive-genericrecommended
+ app-text/ptex )
+ dev-util/gperf
+ dev-util/pkgconfig"
+
+FORTRAN="gfortran ifc g77 f2c"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}_parallel_make.patch
+}
+
+src_compile() {
+ econf \
+ --localstatedir=/var/state/octave \
+ --enable-shared \
+ --with-blas="$(pkg-config --libs blas)" \
+ --with-lapack="$(pkg-config --libs lapack)" \
+ $(use_with hdf5) \
+ $(use_with curl) \
+ $(use_with zlib) \
+ $(use_with fftw) \
+ $(use_with sparse umfpack) \
+ $(use_with sparse colamd) \
+ $(use_with sparse ccolamd) \
+ $(use_with sparse cholmod) \
+ $(use_with sparse cxsparse) \
+ $(use_enable readline)
+
+ emake || die "emake failed"
+
+ if use xemacs; then
+ cd "${S}/emacs"
+ xemacs-elisp-comp *.el
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ if use doc; then
+ einfo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins $(find doc -name \*.pdf)
+ fi
+
+ if use emacs || use xemacs; then
+ cd emacs
+ exeinto /usr/bin
+ doexe octave-tags || die "Failed to install octave-tags"
+ doman octave-tags.1 || die "Failed to install octave-tags.1"
+ if use xemacs; then
+ xemacs-elisp-install ${PN} *.el *.elc
+ fi
+ cd ..
+ fi
+
+ echo "LDPATH=/usr/$(get_libdir)/octave-${PV}" > 99octave
+ doenvd 99octave || die
+
+ # Fixes ls-R files to remove /var/tmp/portage references.
+ #sed -i \
+ # -e "s:${D}::g" \
+ # "${D}"/usr/*/${PN}/ls-R \
+ # || die "Failed to fix ls-R files."
+}