summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-06-15 21:23:54 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-06-15 21:23:54 +0000
commitc21b039b2b49bcb4c95b01b9a9f6ce9c5ec797a8 (patch)
tree8cd0d7441e9c390eb277169780eeaf4f2e4f9880 /sci-libs
parentVersion bump (diff)
downloadgentoo-2-c21b039b2b49bcb4c95b01b9a9f6ce9c5ec797a8.tar.gz
gentoo-2-c21b039b2b49bcb4c95b01b9a9f6ce9c5ec797a8.tar.bz2
gentoo-2-c21b039b2b49bcb4c95b01b9a9f6ce9c5ec797a8.zip
fix bug #513348, bump to EAPI 5, add ~amd64, thanks to Georg Rudoy
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/beagle/ChangeLog9
-rw-r--r--sci-libs/beagle/beagle-3.0.3.ebuild10
-rw-r--r--sci-libs/beagle/files/beagle-3.0.3-gcc47.patch10
3 files changed, 21 insertions, 8 deletions
diff --git a/sci-libs/beagle/ChangeLog b/sci-libs/beagle/ChangeLog
index 964baedf03f7..b1d1edc6ca42 100644
--- a/sci-libs/beagle/ChangeLog
+++ b/sci-libs/beagle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/beagle
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/ChangeLog,v 1.13 2012/04/26 15:40:11 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/ChangeLog,v 1.14 2014/06/15 21:23:54 jauhien Exp $
+
+ 15 Jun 2014; Jauhien Piatlicki <jauhien@gentoo.org>
+ +files/beagle-3.0.3-gcc47.patch, beagle-3.0.3.ebuild:
+ fix bug #513348, bump to EAPI 5, add ~amd64, thanks to Georg Rudoy
26 Apr 2012; Justin Lecher <jlec@gentoo.org> beagle-3.0.3.ebuild,
metadata.xml:
@@ -61,4 +65,3 @@
13 May 2004; Thomas Veith <xtv@gentoo.org> beagle-2.1.3.ebuild :
Initial import.
-
diff --git a/sci-libs/beagle/beagle-3.0.3.ebuild b/sci-libs/beagle/beagle-3.0.3.ebuild
index 3ef6944b9b9d..d0d79d302557 100644
--- a/sci-libs/beagle/beagle-3.0.3.ebuild
+++ b/sci-libs/beagle/beagle-3.0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/beagle-3.0.3.ebuild,v 1.4 2012/04/26 15:40:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/beagle/beagle-3.0.3.ebuild,v 1.5 2014/06/15 21:23:54 jauhien Exp $
-EAPI=4
+EAPI=5
inherit autotools-utils
@@ -12,7 +12,7 @@ HOMEPAGE="http://beagle.gel.ulaval.ca/"
SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="x86"
+KEYWORDS="~amd64 x86"
IUSE="doc static-libs"
RDEPEND="
@@ -22,7 +22,7 @@ RDEPEND="
DEPEND="${DEPEND}
doc? ( app-doc/doxygen )"
-PATCHES=( "${FILESDIR}"/${PN}-3.0.3-gcc43.patch )
+PATCHES=( "${FILESDIR}"/${PN}-3.0.3-gcc43.patch "${FILESDIR}"/${PN}-3.0.3-gcc47.patch )
AUTOTOOLS_IN_SOURCE_BUILD=1
diff --git a/sci-libs/beagle/files/beagle-3.0.3-gcc47.patch b/sci-libs/beagle/files/beagle-3.0.3-gcc47.patch
new file mode 100644
index 000000000000..cb3546c68a5c
--- /dev/null
+++ b/sci-libs/beagle/files/beagle-3.0.3-gcc47.patch
@@ -0,0 +1,10 @@
+--- beagle/include/beagle/RouletteT.hpp
++++ beagle/include/beagle/RouletteT.hpp
+@@ -87,7 +87,7 @@
+ Beagle_StackTraceBeginM();
+ Beagle_AssertM(inWeight>=0.0);
+ if(VectorType::empty()==false) inWeight += VectorType::back().first;
+- push_back(std::make_pair(inWeight,inValue));
++ this->push_back(std::make_pair(inWeight,inValue));
+ Beagle_StackTraceEndM("void RouletteT<T>::insert(const T& inValue, double inWeight)");
+ }