summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-15 12:18:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-15 12:18:55 +0000
commit28d54c6a56fbf099bb626f32aa27d2d95fe0fdb9 (patch)
tree255a11e2d8bf56085cb3a8bb404fe357e474e822 /sci-libs
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-28d54c6a56fbf099bb626f32aa27d2d95fe0fdb9.tar.gz
gentoo-2-28d54c6a56fbf099bb626f32aa27d2d95fe0fdb9.tar.bz2
gentoo-2-28d54c6a56fbf099bb626f32aa27d2d95fe0fdb9.zip
Fix building with GCC 4.4+ wrt #279160, thanks to Dominik Kapusta for patch.
(Portage version: 2.2_rc38/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/openfoam-kernel/ChangeLog8
-rw-r--r--sci-libs/openfoam-kernel/files/openfoam-kernel-1.5_p20090311-gcc44.patch42
-rw-r--r--sci-libs/openfoam-kernel/openfoam-kernel-1.5_p20090311.ebuild3
3 files changed, 51 insertions, 2 deletions
diff --git a/sci-libs/openfoam-kernel/ChangeLog b/sci-libs/openfoam-kernel/ChangeLog
index 6e7729675d04..afed352b6ba6 100644
--- a/sci-libs/openfoam-kernel/ChangeLog
+++ b/sci-libs/openfoam-kernel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/openfoam-kernel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/openfoam-kernel/ChangeLog,v 1.2 2009/04/26 13:42:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/openfoam-kernel/ChangeLog,v 1.3 2009/08/15 12:18:55 ssuominen Exp $
+
+ 14 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ openfoam-kernel-1.5_p20090311.ebuild,
+ +files/openfoam-kernel-1.5_p20090311-gcc44.patch:
+ Fix building with GCC 4.4+ wrt #279160, thanks to Dominik Kapusta for
+ patch.
26 Apr 2009; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Adding Oliver Borm to metadata
diff --git a/sci-libs/openfoam-kernel/files/openfoam-kernel-1.5_p20090311-gcc44.patch b/sci-libs/openfoam-kernel/files/openfoam-kernel-1.5_p20090311-gcc44.patch
new file mode 100644
index 000000000000..6e41bfb00a1c
--- /dev/null
+++ b/sci-libs/openfoam-kernel/files/openfoam-kernel-1.5_p20090311-gcc44.patch
@@ -0,0 +1,42 @@
+diff --git a/src/OSspecific/Unix/signals/sigFpe.C b/src/OSspecific/Unix/signals/sigFpe.C
+index e3bcf15..759f8c8 100644
+--- a/src/OSspecific/Unix/signals/sigFpe.C
++++ b/src/OSspecific/Unix/signals/sigFpe.C
+@@ -39,6 +39,7 @@ License
+
+ # include <fenv.h>
+ # include <malloc.h>
++# include <stdint.h>
+
+ #elif defined(sgiN32) || defined(sgiN32Gcc)
+
+diff --git a/src/meshTools/triSurface/surfaceFeatures/surfaceFeatures.C b/src/meshTools/triSurface/surfaceFeatures/surfaceFeatures.C
+index 9f858b9..25f2641 100644
+--- a/src/meshTools/triSurface/surfaceFeatures/surfaceFeatures.C
++++ b/src/meshTools/triSurface/surfaceFeatures/surfaceFeatures.C
+@@ -763,10 +763,11 @@ Foam::Map<Foam::label> Foam::surfaceFeatures::nearestSamples
+ const scalarField& maxDist
+ ) const
+ {
++ treeBoundBox tbb(samples);
+ // Build tree out of all samples.
+ octree<octreeDataPoint> ppTree
+ (
+- treeBoundBox(samples), // overall search domain
++ tbb, // overall search domain
+ octreeDataPoint(samples), // all information needed to do checks
+ 1, // min levels
+ 20.0, // maximum ratio of cubes v.s. cells
+@@ -864,10 +865,11 @@ Foam::Map<Foam::label> Foam::surfaceFeatures::nearestSamples
+ scalar maxSearch = max(maxDist);
+ vector span(maxSearch, maxSearch, maxSearch);
+
++ treeBoundBox tbb(samples);
+ // octree.shapes holds reference!
+ octree<octreeDataPoint> ppTree
+ (
+- treeBoundBox(samples), // overall search domain
++ tbb, // overall search domain
+ octreeDataPoint(samples), // all information needed to do checks
+ 1, // min levels
+ 20.0, // maximum ratio of cubes v.s. cells
diff --git a/sci-libs/openfoam-kernel/openfoam-kernel-1.5_p20090311.ebuild b/sci-libs/openfoam-kernel/openfoam-kernel-1.5_p20090311.ebuild
index 84f45f08e682..1b67ace7b144 100644
--- a/sci-libs/openfoam-kernel/openfoam-kernel-1.5_p20090311.ebuild
+++ b/sci-libs/openfoam-kernel/openfoam-kernel-1.5_p20090311.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/openfoam-kernel/openfoam-kernel-1.5_p20090311.ebuild,v 1.1 2009/04/25 16:19:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/openfoam-kernel/openfoam-kernel-1.5_p20090311.ebuild,v 1.2 2009/08/15 12:18:55 ssuominen Exp $
EAPI="2"
@@ -44,6 +44,7 @@ src_prepare() {
epatch "${DISTDIR}"/${MY_P}-svn.patch
epatch "${DISTDIR}"/${MY_PN}-git-${PVR}.patch
epatch "${FILESDIR}"/${MY_P}-ggi.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
}
src_compile() {