summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-07-13 04:59:56 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-07-13 04:59:56 +0000
commit1eb6d0468279c5d10431ae22dd96b717aff0ebce (patch)
tree4534f3f870247f1bb3d61ff573165ff67e546462 /sci-libs/netcdf
parentMark 0.34 stable on ia64 (diff)
downloadgentoo-2-1eb6d0468279c5d10431ae22dd96b717aff0ebce.tar.gz
gentoo-2-1eb6d0468279c5d10431ae22dd96b717aff0ebce.tar.bz2
gentoo-2-1eb6d0468279c5d10431ae22dd96b717aff0ebce.zip
updated fortran support and man page handling
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog5
-rw-r--r--sci-libs/netcdf/netcdf-3.6.1.ebuild51
2 files changed, 36 insertions, 20 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index 3dc2de67f75e..3502750e2864 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/netcdf
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.25 2006/07/12 16:05:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.26 2006/07/13 04:59:56 nerdboy Exp $
+
+ 13 Jul 2006; Steve Arnold <nerdboy@gentoo.org> netcdf-3.6.1.ebuild:
+ updated fortran support and man page handling (see bug #82431)
12 Jul 2006; Aron Griffis <agriffis@gentoo.org> netcdf-3.6.1.ebuild:
Mark 3.6.1 stable on ia64. #82431
diff --git a/sci-libs/netcdf/netcdf-3.6.1.ebuild b/sci-libs/netcdf/netcdf-3.6.1.ebuild
index 94268f75a278..0fcca222cc3a 100644
--- a/sci-libs/netcdf/netcdf-3.6.1.ebuild
+++ b/sci-libs/netcdf/netcdf-3.6.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.1.ebuild,v 1.8 2006/07/12 16:05:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.1.ebuild,v 1.9 2006/07/13 04:59:56 nerdboy Exp $
-inherit fortran eutils
+inherit fortran eutils toolchain-funcs
DESCRIPTION="Scientific library and interface for array oriented data access"
SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
@@ -17,17 +17,26 @@ S="${WORKDIR}/${P}/src"
pkg_setup() {
if use fortran ; then
- if built_with_use sys-devel/gcc fortran ; then
- FORTRAN="g77 gfortran"
- need_fortran "g77 gfortran"
- einfo "Configuring for GNU fortran..."
- elif test -f `which pgf90` ; then
- FORTRAN="pgf90"
- need_fortran "pgf90"
- einfo "Configuring for PGI fortran..."
+ if test -d /opt/intel/fortran90 ; then
+ FORTRAN="ifc"
+ need_fortran "ifc"
+ einfo "Configuring for Intel Fortran..."
+ elif [ $(gcc-major-version) -ge 4 ] \
+ && built_with_use sys-devel/gcc fortran ; then
+ FORTRAN="gfortran"
+ need_fortran "gfortran"
+ einfo "Configuring for GNU Fortran 90..."
else
- ewarn "Can't find a usable fortran compiler."
- die "Please adjust your use flags."
+ ewarn "Can't find a usable Fortran 90 compiler."
+ ewarn "No F90 interface should be built, however,"
+ ewarn "another Fortran compiler may be detected by"
+ ewarn "configure."
+ fi
+ if [ $(gcc-major-version) -eq 3 ] \
+ && built_with_use sys-devel/gcc fortran ; then
+ FORTRAN="g77"
+ need_fortran "g77"
+ einfo "Configuring for GNU Fortran 77..."
fi
else
FORTRAN=""
@@ -43,7 +52,7 @@ src_compile() {
local myconf
if use fortran ; then
- if [ ${FORTRANC} == gfortran -o ${FORTRANC} == pgf90 ] ; then
+ if [ ${FORTRANC} == gfortran ] ; then
myconf="${myconf} CPPFLAGS=-DpgiFortran"
else
myconf="${myconf} CPPFLAGS=-Df2cFortran"
@@ -51,6 +60,7 @@ src_compile() {
fi
econf ${myconf} || die "econf failed"
+
make || die "make failed"
}
@@ -60,20 +70,23 @@ src_test() {
src_install() {
dodir /usr/{lib,share} /usr/share/man/man3
- einstall MANDIR=${D}usr/share/man || die "Failed to install man pages"
- if use fortran ; then
+
+ einstall MANDIR=${D}usr/share/man || die "einstall failed"
+
+ if test -f ${D}usr/share/man/man3/netcdf.3f ; then
dodir /usr/share/man/man3f
mv ${D}usr/share/man/man3/netcdf.3f ${D}usr/share/man/man3f/ \
- || die "Failed to move man page"
+ || die "Failed to move f77 man page"
dosed "s:NETCDF 3:NETCDF 3F:g" /usr/share/man/man3f/netcdf.3f \
|| die "dosed failed"
- if [ ${FORTRANC} == gfortran -o ${FORTRANC} == pgf90 ] ; then
+ if test -f ${D}usr/share/man/man3/netcdf.3f90 ; then
dodir /usr/share/man/man3f90
mv ${D}usr/share/man/man3/netcdf.3f90 ${D}usr/share/man/man3f90/ \
- || die "Failed to move man page"
+ || die "Failed to move f90 man page"
fi
dodoc fortran/cfortran.doc || die "Failed to install fortran docs"
fi
- dodoc COPYRIGHT MANIFEST README RELEASE_NOTES VERSION \
+
+ dodoc COPYRIGHT README RELEASE_NOTES VERSION \
|| die "Failed to install docs"
}