summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-07-09 16:49:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-07-09 16:49:10 +0000
commit5a709efc60eb847b0e030231e39f4902d5281bf3 (patch)
treee4f3948f15e06680453b36f265ce6b1ce5d4f209 /sci-libs/libtifiles2
parentbump to distutils-r1 (diff)
downloadgentoo-2-5a709efc60eb847b0e030231e39f4902d5281bf3.tar.gz
gentoo-2-5a709efc60eb847b0e030231e39f4902d5281bf3.tar.bz2
gentoo-2-5a709efc60eb847b0e030231e39f4902d5281bf3.zip
Version bump. Switch to autototools-utils eclass
(Portage version: 2.2.01.22120-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/libtifiles2')
-rw-r--r--sci-libs/libtifiles2/ChangeLog9
-rw-r--r--sci-libs/libtifiles2/libtifiles2-1.1.6.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/sci-libs/libtifiles2/ChangeLog b/sci-libs/libtifiles2/ChangeLog
index 685f47b77f3a..4ce7f8ffad50 100644
--- a/sci-libs/libtifiles2/ChangeLog
+++ b/sci-libs/libtifiles2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libtifiles2
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libtifiles2/ChangeLog,v 1.8 2012/08/04 15:03:23 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libtifiles2/ChangeLog,v 1.9 2013/07/09 16:49:10 bicatali Exp $
+
+*libtifiles2-1.1.6 (09 Jul 2013)
+
+ 09 Jul 2013; Sébastien Fabbro <bicatali@gentoo.org> +libtifiles2-1.1.6.ebuild:
+ Version bump. Switch to autototools-utils eclass
04 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> -libtifiles2-1.1.3.ebuild,
libtifiles2-1.1.5.ebuild:
diff --git a/sci-libs/libtifiles2/libtifiles2-1.1.6.ebuild b/sci-libs/libtifiles2/libtifiles2-1.1.6.ebuild
new file mode 100644
index 000000000000..600d5b94e640
--- /dev/null
+++ b/sci-libs/libtifiles2/libtifiles2-1.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libtifiles2/libtifiles2-1.1.6.ebuild,v 1.1 2013/07/09 16:49:10 bicatali Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Library for TI calculator files"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc nls static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=sci-libs/libticables2-1.3.3
+ >=sci-libs/libticonv-1.1.3
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable nls)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml docs/html/*
+}