summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-17 08:11:22 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-17 08:11:22 +0000
commitd2d948de7a2c7a9acad1354b79fd69f2bf627f16 (patch)
tree065feb842c4e92b79252edb2089580939c236c6a /sci-libs/itpp
parentsci-libs/itpp: revbump, because stable automake do not like AM_PROG_AR, #426402 (diff)
downloadgentoo-2-d2d948de7a2c7a9acad1354b79fd69f2bf627f16.tar.gz
gentoo-2-d2d948de7a2c7a9acad1354b79fd69f2bf627f16.tar.bz2
gentoo-2-d2d948de7a2c7a9acad1354b79fd69f2bf627f16.zip
sci-libs/itpp: Add patch for pkg-config file creation
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog6
-rw-r--r--sci-libs/itpp/files/itpp-4.2-pkg-config.patch27
-rw-r--r--sci-libs/itpp/itpp-4.2-r1.ebuild3
-rw-r--r--sci-libs/itpp/itpp-4.2-r2.ebuild4
4 files changed, 36 insertions, 4 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 4ab8a8f6214b..b2522bd10596 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.114 2012/07/17 07:51:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.115 2012/07/17 08:11:22 jlec Exp $
+
+ 17 Jul 2012; Justin Lecher <jlec@gentoo.org> itpp-4.2-r1.ebuild,
+ itpp-4.2-r2.ebuild, +files/itpp-4.2-pkg-config.patch:
+ Add patch for pkg-config file creation
*itpp-4.2-r2 (17 Jul 2012)
diff --git a/sci-libs/itpp/files/itpp-4.2-pkg-config.patch b/sci-libs/itpp/files/itpp-4.2-pkg-config.patch
new file mode 100644
index 000000000000..5a18952707bb
--- /dev/null
+++ b/sci-libs/itpp/files/itpp-4.2-pkg-config.patch
@@ -0,0 +1,27 @@
+ configure.ac | 2 +-
+ itpp.pc.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4f06171..d3d7b76 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -322,7 +322,7 @@ test "x$FFT_LIBS" != x && LIBS="$FFT_LIBS $LIBS"
+ CPPFLAGS="`echo \"$CPPFLAGS\" | sed -e 's/ */ /g' -e 's/^ //' -e 's/ $//'`"
+ LDFLAGS="`echo \"$LDFLAGS\" | sed -e 's/ */ /g' -e 's/^ //' -e 's/ $//'`"
+ LIBS="`echo \"$LIBS\" | sed -e 's/ */ /g' -e 's/^ //' -e 's/ $//'`"
+-LDLIBS="`echo \"$LDFLAGS $LIBS\" | sed -e 's/^ //' -e 's/ $//'`"
++LDLIBS="`echo \"$LIBS\" | sed -e 's/^ //' -e 's/ $//'`"
+
+ if test $enable_explicit_deps = yes; then
+ EXPLICIT_LIBS=" $LDLIBS" # the leading space is important here...
+diff --git a/itpp.pc.in b/itpp.pc.in
+index 4018865..48a9543 100644
+--- a/itpp.pc.in
++++ b/itpp.pc.in
+@@ -9,4 +9,4 @@ Version: @PACKAGE_VERSION@
+ URL: http://itpp.sourceforge.net/
+ Libs: -L${libdir} -l@PACKAGE@@EXPLICIT_LIBS@
+ Libs.private:@PRIVATE_LIBS@
+-Cflags: -I${includedir} @CXXFLAGS_OPT@
++Cflags: -I${includedir}
diff --git a/sci-libs/itpp/itpp-4.2-r1.ebuild b/sci-libs/itpp/itpp-4.2-r1.ebuild
index a58fb8ed140b..624efcf71397 100644
--- a/sci-libs/itpp/itpp-4.2-r1.ebuild
+++ b/sci-libs/itpp/itpp-4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.13 2012/07/15 10:39:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.14 2012/07/17 08:11:22 jlec Exp $
EAPI=4
@@ -29,7 +29,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.0.7-fastica-fix-endless-loop.patch
"${FILESDIR}"/${P}-fastica-correct-dim.patch
"${FILESDIR}"/${P}-test-fftw.patch
- "${FILESDIR}"/${P}-automake-1.12.patch
)
src_prepare() {
diff --git a/sci-libs/itpp/itpp-4.2-r2.ebuild b/sci-libs/itpp/itpp-4.2-r2.ebuild
index 97b075e38d65..dba084af674e 100644
--- a/sci-libs/itpp/itpp-4.2-r2.ebuild
+++ b/sci-libs/itpp/itpp-4.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r2.ebuild,v 1.1 2012/07/17 07:51:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r2.ebuild,v 1.2 2012/07/17 08:11:22 jlec Exp $
EAPI=4
@@ -30,6 +30,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.0.7-fastica-fix-endless-loop.patch
"${FILESDIR}"/${P}-fastica-correct-dim.patch
"${FILESDIR}"/${P}-test-fftw.patch
+ "${FILESDIR}"/${P}-automake-1.12.patch
+ "${FILESDIR}"/${P}-pkg-config.patch
)
src_prepare() {