summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2005-12-23 16:21:05 +0000
committerCarsten Lohrke <carlo@gentoo.org>2005-12-23 16:21:05 +0000
commit280b1e446d06b88c61fb163958666fa522cf1700 (patch)
tree56bb8722a76d3df6a8cbda0ce49691c2d125cc93 /sci-libs/gdal
parentStable on ppc64 (diff)
downloadgentoo-2-280b1e446d06b88c61fb163958666fa522cf1700.tar.gz
gentoo-2-280b1e446d06b88c61fb163958666fa522cf1700.tar.bz2
gentoo-2-280b1e446d06b88c61fb163958666fa522cf1700.zip
Use global jpeg2k use flag.
(Portage version: 2.0.53)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog6
-rw-r--r--sci-libs/gdal/gdal-1.2.6-r4.ebuild10
-rw-r--r--sci-libs/gdal/gdal-1.3.0-r1.ebuild10
-rw-r--r--sci-libs/gdal/gdal-1.3.1.ebuild10
4 files changed, 20 insertions, 16 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 5cabaa396c66..83b229ab62d8 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.21 2005/12/16 12:13:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.22 2005/12/23 16:21:05 carlo Exp $
+
+ 23 Dec 2005; Carsten Lohrke <carlo@gentoo.org> gdal-1.2.6-r4.ebuild,
+ gdal-1.3.0-r1.ebuild, gdal-1.3.1.ebuild:
+ Use global jpeg2k use flag.
16 Dec 2005; Diego Pettenò <flameeyes@gentoo.org> gdal-1.3.1.ebuild:
Remove --with-gnu-ld option, bug #108386.
diff --git a/sci-libs/gdal/gdal-1.2.6-r4.ebuild b/sci-libs/gdal/gdal-1.2.6-r4.ebuild
index f6db3b3ea29d..5fcdae23118d 100644
--- a/sci-libs/gdal/gdal-1.2.6-r4.ebuild
+++ b/sci-libs/gdal/gdal-1.2.6-r4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6-r4.ebuild,v 1.8 2005/12/05 17:09:37 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6-r4.ebuild,v 1.9 2005/12/23 16:21:05 carlo Exp $
inherit eutils libtool gnuconfig distutils toolchain-funcs
-IUSE="jpeg png geos gif jasper netcdf hdf python postgres mysql sqlite \
+IUSE="jpeg png geos gif jpeg2k netcdf hdf python postgres mysql sqlite \
odbc ogdi fits gml doc debug"
DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
@@ -35,7 +35,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
netcdf? ( sci-libs/netcdf )
hdf? ( sci-libs/hdf )
)
- jasper? ( media-libs/jasper )
+ jpeg2k? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
geos? ( sci-libs/geos )
sqlite? ( >=dev-db/sqlite-3 )
@@ -70,7 +70,7 @@ src_compile() {
use_conf="$(use_with jpeg) $(use_with png) $(use_with mysql) \
$(use_with postgres pg) $(use_with fits cfitsio) \
$(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
- $(use_with sqlite) $(use_with jasper) $(use_with odbc) \
+ $(use_with sqlite) $(use_with jpeg2k) $(use_with odbc) \
$(use_with gml xerces)"
# It can't find this
@@ -118,7 +118,7 @@ src_install() {
pkg_postinst() {
einfo "GDAL is most useful with full graphics support enabled via various"
- einfo "USE flags: png, jpeg, gif, jasper, etc. Also python, fits, ogdi,"
+ einfo "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
einfo "geos, and support for either netcdf or HDF4 is available, as well as"
einfo "grass, and mysql, sqlite, or postgres (grass support requires newer"
einfo "gdal and gdal-grass)."
diff --git a/sci-libs/gdal/gdal-1.3.0-r1.ebuild b/sci-libs/gdal/gdal-1.3.0-r1.ebuild
index 6688d2163437..0b8ddd2d9d81 100644
--- a/sci-libs/gdal/gdal-1.3.0-r1.ebuild
+++ b/sci-libs/gdal/gdal-1.3.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.0-r1.ebuild,v 1.7 2005/12/05 17:09:37 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.0-r1.ebuild,v 1.8 2005/12/23 16:21:05 carlo Exp $
inherit eutils libtool gnuconfig distutils toolchain-funcs
-IUSE="jpeg png geos gif jasper netcdf hdf hdf5 python postgres mysql \
+IUSE="jpeg png geos gif jpeg2k netcdf hdf hdf5 python postgres mysql \
odbc sqlite ogdi fits gml doc debug"
DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
@@ -36,7 +36,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
netcdf? ( sci-libs/netcdf )
hdf? ( sci-libs/hdf )
)
- jasper? ( media-libs/jasper )
+ jpeg2k? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
geos? ( sci-libs/geos )
sqlite? ( >=dev-db/sqlite-3 )
@@ -71,7 +71,7 @@ src_compile() {
use_conf="$(use_with jpeg) $(use_with png) $(use_with mysql) \
$(use_with postgres pg) $(use_with fits cfitsio) \
$(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
- $(use_with sqlite) $(use_with jasper) $(use_with odbc) \
+ $(use_with sqlite) $(use_with jpeg2k) $(use_with odbc) \
$(use_with gml xerces) $(use_with hdf5)"
# It can't find this
@@ -119,7 +119,7 @@ src_install() {
pkg_postinst() {
einfo "GDAL is most useful with full graphics support enabled via various"
- einfo "USE flags: png, jpeg, gif, jasper, etc. Also python, fits, ogdi,"
+ einfo "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
einfo "geos, and support for either netcdf or HDF4 is available, as well as"
einfo "grass, and mysql, sqlite, or postgres (grass support requires newer"
einfo "gdal and gdal-grass)."
diff --git a/sci-libs/gdal/gdal-1.3.1.ebuild b/sci-libs/gdal/gdal-1.3.1.ebuild
index 7570bc7458d8..96c142f6fcdb 100644
--- a/sci-libs/gdal/gdal-1.3.1.ebuild
+++ b/sci-libs/gdal/gdal-1.3.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.6 2005/12/16 12:13:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.7 2005/12/23 16:21:05 carlo Exp $
inherit eutils libtool gnuconfig distutils toolchain-funcs
-IUSE="jpeg png geos gif jasper netcdf hdf hdf5 python postgres \
+IUSE="jpeg png geos gif jpeg2k netcdf hdf hdf5 python postgres \
odbc sqlite ogdi fits gml doc debug"
DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
@@ -33,7 +33,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
netcdf? ( sci-libs/netcdf )
hdf? ( sci-libs/hdf )
)
- jasper? ( media-libs/jasper )
+ jpeg2k? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
geos? ( sci-libs/geos )
sqlite? ( >=dev-db/sqlite-3 )
@@ -69,7 +69,7 @@ src_compile() {
use_conf="$(use_with jpeg) $(use_with png) \
$(use_with postgres pg) $(use_with fits cfitsio) \
$(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
- $(use_with sqlite) $(use_with jasper) $(use_with odbc) \
+ $(use_with sqlite) $(use_with jpeg2k) $(use_with odbc) \
$(use_with gml xerces) $(use_with hdf5)"
# mysql support temporarily disabled $(use_with mysql)
@@ -123,7 +123,7 @@ src_install() {
pkg_postinst() {
einfo "GDAL is most useful with full graphics support enabled via various"
- einfo "USE flags: png, jpeg, gif, jasper, etc. Also python, fits, ogdi,"
+ einfo "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
einfo "geos, and support for either netcdf or HDF4 is available, as well as"
einfo "grass, and mysql, sqlite, or postgres (grass support requires grass 6"
einfo "and the new gdal-grass ebuild). HDF5 support is now included."