summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2011-12-03 11:07:45 +0000
committerAndrey Grozin <grozin@gentoo.org>2011-12-03 11:07:45 +0000
commit38454daabde4d52f6ebab56cd7f221ca0c15ee60 (patch)
tree988cd5ea240cca1a41a57f7c9fbd1121cb549d42 /sci-geosciences
parentarm stable, bug #391411 (diff)
downloadgentoo-2-38454daabde4d52f6ebab56cd7f221ca0c15ee60.tar.gz
gentoo-2-38454daabde4d52f6ebab56cd7f221ca0c15ee60.tar.bz2
gentoo-2-38454daabde4d52f6ebab56cd7f221ca0c15ee60.zip
Version bump
(Portage version: 2.2.0_alpha79/cvs/Linux i686)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/viking/ChangeLog7
-rw-r--r--sci-geosciences/viking/viking-1.2.2.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/sci-geosciences/viking/ChangeLog b/sci-geosciences/viking/ChangeLog
index c7943dff3165..d48afb72888b 100644
--- a/sci-geosciences/viking/ChangeLog
+++ b/sci-geosciences/viking/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/viking
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/ChangeLog,v 1.17 2011/07/24 11:20:58 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/ChangeLog,v 1.18 2011/12/03 11:07:45 grozin Exp $
+
+*viking-1.2.2 (03 Dec 2011)
+
+ 03 Dec 2011; Andrey Grozin <grozin@gentoo.org> +viking-1.2.2.ebuild:
+ Version bump
24 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org> viking-1.2.1.ebuild,
+files/viking-curl-7.21.7.patch:
diff --git a/sci-geosciences/viking/viking-1.2.2.ebuild b/sci-geosciences/viking/viking-1.2.2.ebuild
new file mode 100644
index 000000000000..9b83e4b9e1a6
--- /dev/null
+++ b/sci-geosciences/viking/viking-1.2.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/viking-1.2.2.ebuild,v 1.1 2011/12/03 11:07:45 grozin Exp $
+
+EAPI=4
+
+inherit base autotools
+
+DESCRIPTION="GPS data editor and analyzer"
+HOMEPAGE="http://viking.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gps nls"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+COMMONDEPEND="dev-libs/expat
+ dev-libs/glib:2
+ net-misc/curl
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ gps? ( >=sci-geosciences/gpsd-2.96 )
+"
+RDEPEND="${COMMONDEPEND}
+ sci-geosciences/gpsbabel
+"
+DEPEND="${COMMONDEPEND}
+ app-text/gnome-doc-utils
+ app-text/rarian
+ dev-libs/libxslt
+ dev-util/pkgconfig
+ sys-devel/gettext
+"
+
+DOCS=( README doc/GEOCODED-PHOTOS doc/GETTING-STARTED doc/GPSMAPPER )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gpsd-2.96.patch
+ "${FILESDIR}"/1.2.1-autoreconf.patch
+)
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-deprecations \
+ --with-libcurl \
+ --with-expat \
+ --enable-google \
+ --enable-terraserver \
+ --enable-expedia \
+ --enable-openstreetmap \
+ --enable-bluemarble \
+ --enable-geonames \
+ --enable-geocaches \
+ --enable-spotmaps \
+ --disable-dem24k \
+ $(use_enable gps realtime-gps-tracking) \
+ $(use_enable nls)
+}