summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-22 20:01:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-22 20:01:11 +0000
commit65f5f65f0fc5e1cd0036f5087b2b78630756688d (patch)
tree5413642b098f358c6561f86c2a0bbb55e475382b /sci-chemistry
parentSort/fix incorrect/missing dependencies. (diff)
downloadgentoo-2-65f5f65f0fc5e1cd0036f5087b2b78630756688d.tar.gz
gentoo-2-65f5f65f0fc5e1cd0036f5087b2b78630756688d.tar.bz2
gentoo-2-65f5f65f0fc5e1cd0036f5087b2b78630756688d.zip
Respect CC, LDFLAGS. Move sed commands to src_prepare. Bug #333849
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gperiodic/ChangeLog10
-rw-r--r--sci-chemistry/gperiodic/gperiodic-2.0.10-r1.ebuild59
2 files changed, 67 insertions, 2 deletions
diff --git a/sci-chemistry/gperiodic/ChangeLog b/sci-chemistry/gperiodic/ChangeLog
index 7abbc7df69f8..9440ce57dcef 100644
--- a/sci-chemistry/gperiodic/ChangeLog
+++ b/sci-chemistry/gperiodic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/gperiodic
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/ChangeLog,v 1.12 2009/10/07 20:40:43 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/ChangeLog,v 1.13 2010/08/22 20:01:10 hwoarang Exp $
+
+*gperiodic-2.0.10-r1 (22 Aug 2010)
+
+ 22 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +gperiodic-2.0.10-r1.ebuild:
+ Respect CC, LDFLAGS. Move sed commands to src_prepare. Bug #333849
07 Oct 2009; Markus Meier <maekke@gentoo.org> gperiodic-2.0.10.ebuild:
amd64/x86 stable, bug #285466
diff --git a/sci-chemistry/gperiodic/gperiodic-2.0.10-r1.ebuild b/sci-chemistry/gperiodic/gperiodic-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..8cecda1924f0
--- /dev/null
+++ b/sci-chemistry/gperiodic/gperiodic-2.0.10-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gperiodic/gperiodic-2.0.10-r1.ebuild,v 1.1 2010/08/22 20:01:11 hwoarang Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Periodic table application for Linux"
+SRC_URI="http://www.frantz.fi/software/${P}.tar.gz"
+HOMEPAGE="http://www.frantz.fi/software/gperiodic.php"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ =x11-libs/gtk+-2*
+ x11-libs/cairo[X]
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i -e "s|-DGTK_DISABLE_DEPRECATED|${CFLAGS}|" \
+ -e "/make clean/d" -e "/^CC/s:^.*$:CC=$(tc-getCC):" \
+ -e "s:\$(CFLAGS):& \${LDFLAGS}:" \
+ Makefile || die
+
+ if ! use nls; then
+ sed -i -e "/make -C po/d" Makefile || die
+ fi
+ sed -i -e "s|/usr/bin|${D}/usr/bin|" \
+ -e "s|/usr/share|${D}/usr/share|" Makefile || die
+ sed -i -e "s|/usr/share|${D}/usr/share|" po/Makefile || die
+}
+
+src_install() {
+ # Create directories - Makefile is quite broken.
+ dodir /usr/bin
+ dodir /usr/share/pixmaps
+ dodir /usr/share/applications
+
+ emake install || die "make install failed."
+
+ # Fix permissions
+ chmod 644 "${D}/usr/share/pixmaps/*"
+ chmod 644 "${D}/usr/share/applications/*"
+
+ # Fix the chemistry category in the .desktop file, bug 97202.
+ sed -i -e "s|Chemestry|Chemistry|" "${D}/usr/share/applications/gperiodic.desktop"
+
+ # The man page seems to have been removed too.
+# doman man/gperiodic.1
+ dodoc AUTHORS ChangeLog README NEWS || die
+ newdoc po/README README.translation || die
+}