summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-16 08:38:38 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-16 08:38:38 +0000
commitae2ef4a0fe78ca39cb13d9b8228ff4260d33976a (patch)
treefc9f02366b4078bd252984215d42845cae24c63a /sci-biology
parentBump to EAPI=5 and fix file collision, bug #422643; thanks Martin Mokrejs con... (diff)
downloadgentoo-2-ae2ef4a0fe78ca39cb13d9b8228ff4260d33976a.tar.gz
gentoo-2-ae2ef4a0fe78ca39cb13d9b8228ff4260d33976a.tar.bz2
gentoo-2-ae2ef4a0fe78ca39cb13d9b8228ff4260d33976a.zip
Add missing dependency on cpio, bug #513420
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/rmblast/ChangeLog8
-rw-r--r--sci-biology/rmblast/rmblast-1.2-r1.ebuild9
-rw-r--r--sci-biology/rmblast/rmblast-1.2.ebuild45
3 files changed, 11 insertions, 51 deletions
diff --git a/sci-biology/rmblast/ChangeLog b/sci-biology/rmblast/ChangeLog
index 8315dc88314f..e98d9079a5fb 100644
--- a/sci-biology/rmblast/ChangeLog
+++ b/sci-biology/rmblast/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/rmblast
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rmblast/ChangeLog,v 1.5 2013/03/11 16:55:57 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rmblast/ChangeLog,v 1.6 2015/06/16 08:38:38 jlec Exp $
+
+ 16 Jun 2015; Justin Lecher <jlec@gentoo.org> -rmblast-1.2.ebuild,
+ rmblast-1.2-r1.ebuild:
+ Add missing dependency on cpio, bug #513420
11 Mar 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Drop Andrey as maintainer so that bugs get assigned to sci-biology directly
diff --git a/sci-biology/rmblast/rmblast-1.2-r1.ebuild b/sci-biology/rmblast/rmblast-1.2-r1.ebuild
index de9f206dc0e4..92f7b98ae01e 100644
--- a/sci-biology/rmblast/rmblast-1.2-r1.ebuild
+++ b/sci-biology/rmblast/rmblast-1.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rmblast/rmblast-1.2-r1.ebuild,v 1.1 2013/02/18 10:48:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rmblast/rmblast-1.2-r1.ebuild,v 1.2 2015/06/16 08:38:38 jlec Exp $
EAPI=5
@@ -17,8 +17,9 @@ SLOT="0"
IUSE=""
KEYWORDS="~amd64 ~x86"
-DEPEND="dev-libs/boost"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-libs/boost"
+DEPEND="${RDEPEND}
+ app-arch/cpio"
S="${WORKDIR}/${P}-ncbi-blast-${MY_NCBI_BLAST_V}-src/c++"
diff --git a/sci-biology/rmblast/rmblast-1.2.ebuild b/sci-biology/rmblast/rmblast-1.2.ebuild
deleted file mode 100644
index ecdfa0b11571..000000000000
--- a/sci-biology/rmblast/rmblast-1.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rmblast/rmblast-1.2.ebuild,v 1.4 2013/02/18 10:48:11 jlec Exp $
-
-EAPI="3"
-
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_NCBI_BLAST_V=2.2.23+
-
-DESCRIPTION="RepeatMasker compatible version of NCBI BLAST+"
-HOMEPAGE="http://www.repeatmasker.org/RMBlast.html"
-SRC_URI="http://www.repeatmasker.org/rmblast-${PV}-ncbi-blast-${MY_NCBI_BLAST_V}-src.tar.gz"
-
-LICENSE="OSL-2.1"
-SLOT="0"
-IUSE=""
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=dev-libs/boost-1.35.0"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}-ncbi-blast-${MY_NCBI_BLAST_V}-src/c++"
-
-src_prepare() {
- filter-ldflags -Wl,--as-needed
- sed \
- -e 's/-print-file-name=libstdc++.a//' \
- -e '/sed/ s/\([gO]\[0-9\]\)\*/\1\\+/' \
- -e "/DEF_FAST_FLAGS=/s:=\".*\":=\"${CFLAGS}\":g" \
- -i src/build-system/configure || die
- epatch "${FILESDIR}"/${P}-gcc47.patch
-}
-
-src_configure() {
- tc-export CXX CC
-
- "${S}"/configure --without-debug \
- --with-mt \
- --without-static \
- --with-dll \
- --prefix="${ED}"/opt/${PN} \
- --with-boost="${EPREFIX}/usr/include/boost" \
- || die
-}