summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-25 09:09:03 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-25 09:09:03 +0000
commit30bc15876fd942db2a627d631ea161d143354510 (patch)
treedb7251caba5489b9de4cd489202dadd33b30b046 /sci-biology
parentunmask gcc 4.4.3-r3 gcc-4.4.4-r1 for hardened (diff)
downloadgentoo-2-30bc15876fd942db2a627d631ea161d143354510.tar.gz
gentoo-2-30bc15876fd942db2a627d631ea161d143354510.tar.bz2
gentoo-2-30bc15876fd942db2a627d631ea161d143354510.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/rebase/ChangeLog8
-rw-r--r--sci-biology/rebase/rebase-1006.ebuild (renamed from sci-biology/rebase/rebase-909.ebuild)19
2 files changed, 19 insertions, 8 deletions
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index 6fd266b8f0fb..ba4a058f5b29 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/rebase
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.93 2010/01/01 21:41:53 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.94 2010/06/25 09:09:03 jlec Exp $
+
+*rebase-1006 (25 Jun 2010)
+
+ 25 Jun 2010; Justin Lecher <jlec@gentoo.org> -rebase-909.ebuild,
+ +rebase-1006.ebuild:
+ Version Bump
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org> rebase-909.ebuild:
Transfer Prefix keywords
diff --git a/sci-biology/rebase/rebase-909.ebuild b/sci-biology/rebase/rebase-1006.ebuild
index 0571747716c7..15c172c7844b 100644
--- a/sci-biology/rebase/rebase-909.ebuild
+++ b/sci-biology/rebase/rebase-1006.ebuild
@@ -1,11 +1,15 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-909.ebuild,v 1.2 2010/01/01 21:41:53 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-1006.ebuild,v 1.1 2010/06/25 09:09:03 jlec Exp $
+
+EAPI="3"
+
+MY_PV=${PV#1}
DESCRIPTION="A restriction enzyme database"
LICENSE="public-domain"
HOMEPAGE="http://rebase.neb.com"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
SLOT="0"
# Minimal build keeps only the indexed files (if applicable) and the
@@ -13,15 +17,16 @@ SLOT="0"
IUSE="emboss minimal"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-DEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
-RDEPEND="${DEPEND}"
+RDEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
+DEPEND="${RDEPEND}
+ || ( app-arch/xz-utils app-arch/lzma-utils )"
src_compile() {
if use emboss; then
echo; einfo "Indexing Rebase for usage with EMBOSS."
mkdir REBASE
- EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${PV} \
- -protofile proto.${PV} -equivalences \
+ EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${MY_PV} \
+ -protofile proto.${MY_PV} -equivalences \
|| die "Indexing Rebase failed."
echo
fi
@@ -30,7 +35,7 @@ src_compile() {
src_install() {
if ! use minimal; then
insinto /usr/share/${PN}
- doins withrefm.${PV} proto.${PV} || die \
+ doins withrefm.${MY_PV} proto.${MY_PV} || die \
"Failed to install raw database."
fi
newdoc REBASE.DOC README || die "Failed to install documentation."