summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-06-26 15:47:50 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-06-26 15:47:50 +0000
commitdea6963dfb4e5e7a27c0816ed8c3f31830462689 (patch)
tree90238284f2e8f3e64dab2430586ca8c41673b17f /sci-biology/rebase
parentStable on sparc (diff)
downloadgentoo-2-dea6963dfb4e5e7a27c0816ed8c3f31830462689.tar.gz
gentoo-2-dea6963dfb4e5e7a27c0816ed8c3f31830462689.tar.bz2
gentoo-2-dea6963dfb4e5e7a27c0816ed8c3f31830462689.zip
New upstream version
(Portage version: 2.1-r1)
Diffstat (limited to 'sci-biology/rebase')
-rw-r--r--sci-biology/rebase/ChangeLog7
-rw-r--r--sci-biology/rebase/files/digest-rebase-6063
-rw-r--r--sci-biology/rebase/rebase-606.ebuild43
3 files changed, 52 insertions, 1 deletions
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index 7ea0bbf07704..5ea9610c1f40 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/rebase
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.65 2006/05/24 20:45:09 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.66 2006/06/26 15:47:49 ribosome Exp $
+
+*rebase-606 (26 Jun 2006)
+
+ 26 Jun 2006; Olivier Fisette <ribosome@gentoo.org> +rebase-606.ebuild:
+ New upstream version.
24 May 2006; Michael Hanselmann <hansmi@gentoo.org> rebase-603.ebuild:
Stable on ppc.
diff --git a/sci-biology/rebase/files/digest-rebase-606 b/sci-biology/rebase/files/digest-rebase-606
new file mode 100644
index 000000000000..5affcf9a02e8
--- /dev/null
+++ b/sci-biology/rebase/files/digest-rebase-606
@@ -0,0 +1,3 @@
+MD5 e071d9fe97267a63979b35196297d9f1 rebase-606.tar.bz2 183617
+RMD160 7dea5a428a797b359c5bd34c698f093927a94be0 rebase-606.tar.bz2 183617
+SHA256 13ccca9937b7053ddda2f1cdeac88cc39eb5938540507089ff249d30f403244e rebase-606.tar.bz2 183617
diff --git a/sci-biology/rebase/rebase-606.ebuild b/sci-biology/rebase/rebase-606.ebuild
new file mode 100644
index 000000000000..caaed56c6774
--- /dev/null
+++ b/sci-biology/rebase/rebase-606.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-606.ebuild,v 1.1 2006/06/26 15:47:50 ribosome Exp $
+
+DESCRIPTION="A restriction enzyme database"
+LICENSE="public-domain"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~x86 ~ppc ~amd64 ~ppc-macos ~ppc64"
+
+DEPEND="emboss? ( >=sci-biology/emboss-3.0.0-r1 )"
+
+src_compile() {
+ if use emboss; then
+ echo
+ einfo "Indexing ${PN} for usage with EMBOSS."
+ mkdir REBASE
+ EMBOSS_DATA=. rebaseextract -auto -infile withrefm.${PV} \
+ -protofile proto.${PV} || die "Indexing ${PN} failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${PV} proto.${PV} || die \
+ "Failed to install raw database."
+ fi
+ newdoc REBASE.DOC README || die "Failed to install documentation."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/{embossre.enz,embossre.ref,embossre.sup} || die \
+ "Failed to install EMBOSS data files."
+ insinto /usr/share/EMBOSS/data
+ doins embossre.equ || die "Failed to install enzyme prototypes file."
+ fi
+}