summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-05 02:07:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-05 02:07:29 +0000
commit5b51afb07c05dc03cdaa634a15fa8ed46755fc4d (patch)
tree25f9e843431f6b623e270367dfacfe0f338e716b /net-zope
parentVersion bump. (diff)
downloadgentoo-2-5b51afb07c05dc03cdaa634a15fa8ed46755fc4d.tar.gz
gentoo-2-5b51afb07c05dc03cdaa634a15fa8ed46755fc4d.tar.bz2
gentoo-2-5b51afb07c05dc03cdaa634a15fa8ed46755fc4d.zip
Initial addition.
(Portage version: 14926-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope-componentvocabulary/ChangeLog10
-rw-r--r--net-zope/zope-componentvocabulary/metadata.xml6
-rw-r--r--net-zope/zope-componentvocabulary/zope-componentvocabulary-1.0.ebuild34
3 files changed, 50 insertions, 0 deletions
diff --git a/net-zope/zope-componentvocabulary/ChangeLog b/net-zope/zope-componentvocabulary/ChangeLog
new file mode 100644
index 000000000000..547f18cb2afb
--- /dev/null
+++ b/net-zope/zope-componentvocabulary/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zope-componentvocabulary
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-componentvocabulary/ChangeLog,v 1.1 2009/12/05 02:07:29 arfrever Exp $
+
+*zope-componentvocabulary-1.0 (05 Dec 2009)
+
+ 05 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-componentvocabulary-1.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zope-componentvocabulary/metadata.xml b/net-zope/zope-componentvocabulary/metadata.xml
new file mode 100644
index 000000000000..ecc751f37510
--- /dev/null
+++ b/net-zope/zope-componentvocabulary/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/net-zope/zope-componentvocabulary/zope-componentvocabulary-1.0.ebuild b/net-zope/zope-componentvocabulary/zope-componentvocabulary-1.0.ebuild
new file mode 100644
index 000000000000..531480365d63
--- /dev/null
+++ b/net-zope/zope-componentvocabulary/zope-componentvocabulary-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-componentvocabulary/zope-componentvocabulary-1.0.ebuild,v 1.1 2009/12/05 02:07:29 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Component vocabularies"
+HOMEPAGE="http://pypi.python.org/pypi/zope.componentvocabulary"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-zope/zope-component
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-schema
+ net-zope/zope-security"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"