summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-12-06 02:04:23 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-12-06 02:04:23 +0000
commitc3ab9f6f4c7cef863a2bae646559058122e9fa1c (patch)
tree97c40d9c706d1cf92c5c6577796edd1c02ede1bd /net-www/opera
parentaddpredicts to fix dri bugs (diff)
downloadgentoo-2-c3ab9f6f4c7cef863a2bae646559058122e9fa1c.tar.gz
gentoo-2-c3ab9f6f4c7cef863a2bae646559058122e9fa1c.tar.bz2
gentoo-2-c3ab9f6f4c7cef863a2bae646559058122e9fa1c.zip
Update to 6.11.
Diffstat (limited to 'net-www/opera')
-rw-r--r--net-www/opera/ChangeLog6
-rw-r--r--net-www/opera/files/digest-opera-6.113
-rw-r--r--net-www/opera/opera-6.11.ebuild110
3 files changed, 118 insertions, 1 deletions
diff --git a/net-www/opera/ChangeLog b/net-www/opera/ChangeLog
index af9f319914cf..c5198dba122f 100644
--- a/net-www/opera/ChangeLog
+++ b/net-www/opera/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-www/opera
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/opera/ChangeLog,v 1.11 2002/11/25 07:10:07 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/opera/ChangeLog,v 1.12 2002/12/06 02:04:23 agenkin Exp $
+*opera-6.11 (5 Dec 2002)
+ 05 Dec 2002; Arcady Genkin <agenkin@gentoo.org> opera-6.11.ebuild :
+ Version bump.
+
*opera-6.1-r1 (25 Nov 2002)
25 Nov 2002; Arcady Genkin <agenkin@gentoo.org> opera-6.1-r1.ebuild :
diff --git a/net-www/opera/files/digest-opera-6.11 b/net-www/opera/files/digest-opera-6.11
new file mode 100644
index 000000000000..28c5449b036f
--- /dev/null
+++ b/net-www/opera/files/digest-opera-6.11
@@ -0,0 +1,3 @@
+MD5 b1a67ed7ffd4973a68edf4fb6fc1a6a5 opera-6.11-20021129.1-static-qt.i386.tar.gz 5835636
+MD5 5199c90bf9424806c9f81fd33d59cd72 opera-6.11-20021129.2-shared-qt.i386.tar.gz 3361817
+MD5 94fd3a4453ece084efc35787968fc936 opera-6.11-20021129.4-shared-qt.i386.tar.gz 3539421
diff --git a/net-www/opera/opera-6.11.ebuild b/net-www/opera/opera-6.11.ebuild
new file mode 100644
index 000000000000..13150d341725
--- /dev/null
+++ b/net-www/opera/opera-6.11.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/opera/opera-6.11.ebuild,v 1.1 2002/12/06 02:04:23 agenkin Exp $
+#
+# By default, the statically linked version of opera will be
+# installed. There are two other variations of the package that this
+# ebuild can install. To pick one, set OPERA_VARIANT environment
+# variable to one of the following:
+#
+# 1. static-2.95 # Statically linked libraries, compiled with gcc 2.95.
+# # (Default)
+# 2. shared-2.95 # Dynamically linked libaries, compiled with gcc 2.95.
+# 3. shared-3.2 # Dynamically linked libraries, compiled with gcc 3.2.
+#
+# Note that the default variant should work for everybody, and is the
+# least likely to cause you any grief. Only change the variant if you
+# know what you are doing.
+#
+# Example of compiling a non-default variant:
+#
+# env OPERA_VARIANT=shared-3.2 emerge opera
+#
+
+DESCRIPTION="Opera web browser."
+HOMEPAGE="http://www.opera.com/linux/"
+LICENSE="OPERA"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}
+ virtual/x11
+ x11-libs/lesstif"
+
+KEYWORDS="~x86"
+SLOT="0"
+
+case "${OPERA_VARIANT}" in
+ shared-3.2)
+ RDEPEND="${RDEPEND} =x11-libs/qt-3*"
+ OPERA_VERSION="4-shared-qt"
+ URL_DIR="shared/gcc-3.2/"
+ ;;
+ shared-2.95)
+ RDEPEND="${RDEPEND} =x11-libs/qt-3*"
+ OPERA_VERSION="2-shared-qt"
+ URL_DIR="shared/gcc-2.95/"
+ ;;
+ *)
+ OPERA_VERSION="1-static-qt"
+ URL_DIR="static/"
+ ;;
+esac
+
+NV=6.11-20021129.${OPERA_VERSION}.i386
+SRC_URI="http://www.panix.com/opera/files/linux/611/final/en/i386/${URL_DIR}/opera-${NV}.tar.gz"
+S=${WORKDIR}/opera-${NV}
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ sed -e "s:/etc:${D}/etc:g" \
+ -e "s:config_dir=\"/etc\":config_dir=\"${D}/etc/\":g" \
+ -e "s:read install_config:install_config=yes:" \
+ -e "s:/usr/share/applnk:${D}/usr/share/applnk:g" \
+ -e "s:/usr/share/pixmaps:${D}/usr/share/pixmaps:g" \
+ -e "s:/usr/share/icons:${D}/usr/share/icons:g" \
+ -e "s:/etc/X11:${D}/etc/X11:g" \
+ -e "s:/usr/share/gnome:${D}/usr/share/gnome:g" \
+ -e 's:#\(LD_PRELOAD=.*libawt.so\):\1:' \
+ -e 's:#\(OPERA_FORCE_JAVA_ENABLED=\):\1:' \
+ -e 's:#\(export LD_PRELOAD OPERA_FORCE_JAVA_ENABLED\):\1:' \
+ < install.sh >install.sh.hacked || die
+ mv install.sh.hacked install.sh
+ chmod +x install.sh
+
+}
+
+
+src_compile() {
+ # Nothing to compile.
+ true
+}
+
+
+src_install() {
+
+ dodir /etc
+ ./install.sh --prefix="${D}"/opt/opera || die
+ rm ${D}/opt/opera/share/doc/opera/help
+ dosym /opt/share/doc/opera/help /opt/opera/share/opera/help
+ dosed /opt/opera/bin/opera
+ dosed /opt/opera/share/opera/java/opera.policy
+
+ #install the icon
+ insinto /usr/share/icons /etc/X11/wmconfig /etc/X11/applnk/Internet \
+ /usr/share/pixmaps /usr/share/gnome/pixmaps
+ doins images/opera.xpm
+
+ if [ "`use gnome`" ]
+ then
+ insinto /usr/share/gnome/pixmaps
+ doins images/opera.xpm
+ fi
+
+ # Install a symlink /usr/bin/opera
+ dodir /usr/bin
+ dosym /opt/opera/bin/opera /usr/bin/opera
+
+}