summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2004-09-14 21:18:54 +0000
committerBrad Laue <brad@gentoo.org>2004-09-14 21:18:54 +0000
commit1e3c2fa5d74e4f025b20bdd33749aee93035bf2d (patch)
treedaa4a146a5d1fa18fb2206586df0c8364103b85f /net-www/mozilla-bin
parentMarked 4.0.2-r1 stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-1e3c2fa5d74e4f025b20bdd33749aee93035bf2d.tar.gz
gentoo-2-1e3c2fa5d74e4f025b20bdd33749aee93035bf2d.tar.bz2
gentoo-2-1e3c2fa5d74e4f025b20bdd33749aee93035bf2d.zip
Bump to 1.7.3
Diffstat (limited to 'net-www/mozilla-bin')
-rw-r--r--net-www/mozilla-bin/ChangeLog7
-rw-r--r--net-www/mozilla-bin/files/digest-mozilla-bin-1.7.31
-rw-r--r--net-www/mozilla-bin/mozilla-bin-1.7.3.ebuild81
3 files changed, 88 insertions, 1 deletions
diff --git a/net-www/mozilla-bin/ChangeLog b/net-www/mozilla-bin/ChangeLog
index 5710fb1f1aea..2072775afd07 100644
--- a/net-www/mozilla-bin/ChangeLog
+++ b/net-www/mozilla-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mozilla-bin
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-bin/ChangeLog,v 1.1 2004/08/05 03:06:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-bin/ChangeLog,v 1.2 2004/09/14 21:18:54 brad Exp $
+
+*mozilla-bin-1.7.3 (14 Sep 2004)
+
+ 14 Sep 2004; Brad Laue <brad@gentoo.org> +mozilla-bin-1.7.3.ebuild:
+ Update to Mozilla Suite 1.7.3
*mozilla-bin-1.7.2 (04 Aug 2004)
diff --git a/net-www/mozilla-bin/files/digest-mozilla-bin-1.7.3 b/net-www/mozilla-bin/files/digest-mozilla-bin-1.7.3
new file mode 100644
index 000000000000..6001db9d05f8
--- /dev/null
+++ b/net-www/mozilla-bin/files/digest-mozilla-bin-1.7.3
@@ -0,0 +1 @@
+MD5 048cf272e7bad57d56cc4d8c1136c4ed mozilla-i686-pc-linux-gnu-1.7.3.tar.gz 12940221
diff --git a/net-www/mozilla-bin/mozilla-bin-1.7.3.ebuild b/net-www/mozilla-bin/mozilla-bin-1.7.3.ebuild
new file mode 100644
index 000000000000..ecb8f3afa625
--- /dev/null
+++ b/net-www/mozilla-bin/mozilla-bin-1.7.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-bin/mozilla-bin-1.7.3.ebuild,v 1.1 2004/09/14 21:18:54 brad Exp $
+
+inherit nsplugins eutils mozilla-launcher
+
+IUSE=""
+
+# handle _rc versions
+MY_PV=${PV/_alpha/a} # handle alpha
+MY_PV=${MY_PV/_beta/b} # handle beta
+MY_PV=${MY_PV/_rc/rc} # handle rc
+
+MY_PN=${PN/-bin/}
+S=${WORKDIR}/mozilla
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+HOMEPAGE="http://www.mozilla.org"
+# Mirrors have it in one of the following places, depending on what
+# mirror you check and when you check it... :-(
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla${PV}/mozilla-i686-pc-linux-gnu-${PV}.tar.gz"
+RESTRICT="nostrip"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/x11
+ x86? (
+ >=sys-libs/lib-compat-1.0-r2
+ =x11-libs/gtk+-1.2*
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ )
+ virtual/x11
+ >=net-www/mozilla-launcher-1.13"
+
+src_install() {
+ # Install mozilla in /opt
+ dodir /opt
+ mv ${S} ${D}/opt/mozilla
+
+ # Plugin path setup (rescuing the existing plugins)
+ src_mv_plugins /opt/mozilla/plugins
+
+ # Fixing permissions
+ chown -R root:root ${D}/opt/mozilla
+
+ # mozilla-launcher-1.8 supports -bin versions
+ dodir /usr/bin
+ dosym /usr/libexec/mozilla-launcher /usr/bin/mozilla-bin
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/mozilla-bin-icon.png
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozilla-bin.desktop
+}
+
+pkg_preinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/mozilla
+
+ # Remove the old plugins dir
+ pkg_mv_plugins ${MOZILLA_FIVE_HOME}/plugins
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/mozilla
+
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}