summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-06-14 02:18:17 +0000
committerChuck Short <zul@gentoo.org>2004-06-14 02:18:17 +0000
commitde59b1624bdcd07f24735762f1dcb685e6bd4b8e (patch)
tree99f578b075cf74261faa8b9301eedf25852e0328 /net-www/mod_log_sql
parentmarked 26 as stable and 27_pre22 as testing on amd64 (Manifest recommit) (diff)
downloadgentoo-2-de59b1624bdcd07f24735762f1dcb685e6bd4b8e.tar.gz
gentoo-2-de59b1624bdcd07f24735762f1dcb685e6bd4b8e.tar.bz2
gentoo-2-de59b1624bdcd07f24735762f1dcb685e6bd4b8e.zip
Removed apache2 support. borked right now.
Diffstat (limited to 'net-www/mod_log_sql')
-rw-r--r--net-www/mod_log_sql/ChangeLog6
-rw-r--r--net-www/mod_log_sql/Manifest6
-rw-r--r--net-www/mod_log_sql/mod_log_sql-1.98.ebuild18
3 files changed, 13 insertions, 17 deletions
diff --git a/net-www/mod_log_sql/ChangeLog b/net-www/mod_log_sql/ChangeLog
index ad80a782460d..301b0bbe27a6 100644
--- a/net-www/mod_log_sql/ChangeLog
+++ b/net-www/mod_log_sql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mod_log_sql
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/ChangeLog,v 1.9 2004/05/14 14:40:00 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/ChangeLog,v 1.10 2004/06/14 02:16:47 zul Exp $
+
+ 13 Jun 2004; Chuck Short <zul@gentoo.org> mod_log_sql-1.98.ebuild:
+ Removed apache2 support. Ebuild does not detect where are our header files are
+ properly. Closes #52739.
15 May 2004; Chuck Short <zul@gentoo.org> mod_log_sql-1.96.ebuild:
Removed old version.
diff --git a/net-www/mod_log_sql/Manifest b/net-www/mod_log_sql/Manifest
index a2e90cb52faf..55457e08490f 100644
--- a/net-www/mod_log_sql/Manifest
+++ b/net-www/mod_log_sql/Manifest
@@ -1,6 +1,6 @@
-MD5 8785ce79dc43800adf31c021554d990f mod_log_sql-1.98.ebuild 3112
-MD5 5230dc7484c89406a21e2c9a4efc333f mod_log_sql-1.97.ebuild 3110
-MD5 26ccb6049eba0cc303a074bbb447cf12 ChangeLog 1562
+MD5 45cb99ac742f0a1e024f7a9390aa60b4 mod_log_sql-1.98.ebuild 2845
+MD5 71861f63f003e5f4e98889bfff41e249 mod_log_sql-1.97.ebuild 3109
+MD5 aac713f177072d6a1034ac9252d4986e ChangeLog 1740
MD5 5b6dd438f81019e56fa641841c0c13fe metadata.xml 501
MD5 7a6e57cfb8898c79734fcf40291206cb files/digest-mod_log_sql-1.97 68
MD5 37cf2cb766664bd12fc8af5c9dd4444f files/digest-mod_log_sql-1.98 68
diff --git a/net-www/mod_log_sql/mod_log_sql-1.98.ebuild b/net-www/mod_log_sql/mod_log_sql-1.98.ebuild
index 6e8b85db2dc3..7084cec34bb5 100644
--- a/net-www/mod_log_sql/mod_log_sql-1.98.ebuild
+++ b/net-www/mod_log_sql/mod_log_sql-1.98.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/mod_log_sql-1.98.ebuild,v 1.1 2004/05/14 14:34:08 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_log_sql/mod_log_sql-1.98.ebuild,v 1.2 2004/06/14 02:16:47 zul Exp $
inherit eutils
@@ -11,11 +11,10 @@ SRC_URI="http://www.outoforder.cc/downloads/mod_log_sql/${P}.tar.gz"
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-IUSE=""
+IUSE="ssl"
DEPEND=">=dev-db/mysql-3.23.15
- apache2? ( =net-www/apache-2* )
- !apache2? ( >=net-www/apache-1* )"
+ >=net-www/apache-1*"
detectapache() {
local domsg=
@@ -73,9 +72,7 @@ src_compile() {
src_install() {
detectapache
exeinto ${APACHE_MODULES_DIR}
- doexe .libs/${PN}.so .libs/mod_log_sql_mysql.so
-
- use ssl && doexe .libs/mod_log_sql_ssl.so
+ doexe mod_log_sql_mysql.so
cat ${CONFIG_FILE} | sed -e "s#machine_id#`hostname -f`#" > 10_mod_log_sql.conf
insinto ${APACHE_MODULES_CONFIG_DIR}
@@ -87,12 +84,7 @@ src_install() {
}
pkg_postinst() {
- detectapache
- if [ "$APACHEVER" == "2" ]; then
- einfo "Please add '-D LOG_SQL' to your /etc/conf.d/apache2 APACHE2_OPTS setting."
- else
- einfo "Please add '-D LOG_SQL' to your /etc/conf.d/apache APACHE_OPTS setting"
- fi
+ einfo "Please add '-D LOG_SQL' to your /etc/conf.d/apache APACHE_OPTS setting"
einfo "Do not forget to adapt ${APACHE_MODULES_CONFIG_DIR}/10_mod_log_sql.conf to your needs."
einfo "See /usr/share/doc/${PF}/contrib/create_tables.sql.gz on how to create logging tables.\n"