summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-09-08 17:09:50 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-09-08 17:09:50 +0000
commitcf392c34c67261e3661f99d0582f8e4beb695f3a (patch)
tree4e1759350e21d187bdeb1663aee7b8375fee8be5 /net-www/mod_auth_mysql
parentcomplete bug #11254 (diff)
downloadgentoo-2-cf392c34c67261e3661f99d0582f8e4beb695f3a.tar.gz
gentoo-2-cf392c34c67261e3661f99d0582f8e4beb695f3a.tar.bz2
gentoo-2-cf392c34c67261e3661f99d0582f8e4beb695f3a.zip
complete bug #11254
Diffstat (limited to 'net-www/mod_auth_mysql')
-rw-r--r--net-www/mod_auth_mysql/ChangeLog8
-rw-r--r--net-www/mod_auth_mysql/Manifest5
-rw-r--r--net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510-r11
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild49
4 files changed, 59 insertions, 4 deletions
diff --git a/net-www/mod_auth_mysql/ChangeLog b/net-www/mod_auth_mysql/ChangeLog
index f65d621c328f..399f86f6a427 100644
--- a/net-www/mod_auth_mysql/ChangeLog
+++ b/net-www/mod_auth_mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mod_auth_mysql
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.3 2003/05/25 08:31:56 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.4 2003/09/08 17:09:44 robbat2 Exp $
+
+*mod_auth_mysql-20030510-r1 (08 Sep 2003)
+
+ 08 Sep 2003; Robin Johnson,,604-339-5621,604-298-8414 <robbat2@gentoo.org>
+ mod_auth_mysql-20030510-r1.ebuild:
+ complete bug #11254
*mod_auth_mysql-20030510 (25 May 2003)
diff --git a/net-www/mod_auth_mysql/Manifest b/net-www/mod_auth_mysql/Manifest
index 8295782fc2e7..10430d95e9b2 100644
--- a/net-www/mod_auth_mysql/Manifest
+++ b/net-www/mod_auth_mysql/Manifest
@@ -1,8 +1,7 @@
MD5 7558bd0cff76d9d99775340cfe8166ae mod_auth_mysql-20030510.ebuild 1091
-MD5 3e2a5739ea7fe284fedb587260634a38 mod_auth_mysql-20030510-r1.ebuild 1308
-MD5 b8c71d1a8cd96041895b4c15af43e0ab mod_auth_mysql-20030510-r1.ebuild~ 1320
+MD5 f3f510bb20c8bbb803ae214e448f0c22 mod_auth_mysql-20030510-r1.ebuild 1349
MD5 09fb204c261078f0b369ae499b255582 mod_auth_mysql-1.11.ebuild 934
-MD5 8bf15d2aed440920638d44f00a589244 ChangeLog 533
+MD5 907815865e62110f1425818d70b3dc88 ChangeLog 713
MD5 01cc878ba30a6e2ad327de787e21a999 files/12_mod_auth_mysql.conf 3571
MD5 3513e598048c0060eb3758c19c4e4c60 files/digest-mod_auth_mysql-1.11 77
MD5 a9f56734948e06d5ed5f4b7eea9f6cd5 files/digest-mod_auth_mysql-20030510-r1 61
diff --git a/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510-r1 b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510-r1
new file mode 100644
index 000000000000..7acd1a88ef08
--- /dev/null
+++ b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-20030510-r1
@@ -0,0 +1 @@
+MD5 b6646a117703b3704091e8f19f02e43e mod_auth_mysql.tgz 9953
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild
new file mode 100644
index 000000000000..35842f38fb3c
--- /dev/null
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild,v 1.1 2003/09/08 17:09:44 robbat2 Exp $
+
+DESCRIPTION="Basic authentication for Apache using a MySQL database"
+HOMEPAGE="http://modauthmysql.sourceforge.net/"
+
+S=${WORKDIR}/${PN}
+SRC_URI="mirror://sourceforge/modauthmysql/${PN}.tgz"
+DEPEND="dev-db/mysql
+ net-www/apache
+ apache2? ( >=net-www/apache-2* )"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE="apache2"
+SLOT="0"
+
+if use apache2 ; then
+ APXS="apxs2 -D APACHE2"
+ DESTDIR=/usr/lib/apache2-extramodules
+ CONFDIR=/etc/apache2/conf/modules.d
+else
+ APXS="apxs -D APACHE1"
+ DESTDIR=/usr/lib/apache-extramodules
+ CONFDIR=/etc/apache/conf/addon-modules
+fi
+
+src_compile() {
+ $APXS -c ${PN}.c -I/usr/include/mysql -lmysqlclient -lm -lz || die
+}
+
+src_install() {
+ exeinto $DESTDIR
+ doexe ${PN}.so
+ insinto ${CONFDIR}
+ doins ${FILESDIR}/mod_auth_mysql.conf
+ cat mod_auth_mysql.c | head -81 \
+ | cut -c 4- > mod_auth_mysql.txt
+ dodoc ${FILESDIR}/mod_auth_mysql.conf \
+ README
+}
+
+pkg_postinst() {
+ if use apache2; then
+ einfo "Please add '-D AUTH_MYSQL' to your /etc/conf.d/apache2 APACHE2_OPTS setting"
+ else
+ einfo "Please add '-D AUTH_MYSQL' to your /etc/conf.d/apache APACHE_OPTS setting"
+ fi
+}