summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-02-18 00:01:47 +0000
committerAlin Năstac <mrness@gentoo.org>2009-02-18 00:01:47 +0000
commit97beef1ba9a22669cd210e81487055cd8d8478ab (patch)
tree59d90a9f8285f05d7c7218727fe94a3981fb1930 /net-proxy/tsocks
parentold (diff)
downloadgentoo-2-97beef1ba9a22669cd210e81487055cd8d8478ab.tar.gz
gentoo-2-97beef1ba9a22669cd210e81487055cd8d8478ab.tar.bz2
gentoo-2-97beef1ba9a22669cd210e81487055cd8d8478ab.zip
Fix LD_PRELOAD setup, thanks to Yuval Hager <yuval at avramzon dot net> (#255960).
(Portage version: 2.1.6.4/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'net-proxy/tsocks')
-rw-r--r--net-proxy/tsocks/ChangeLog13
-rw-r--r--net-proxy/tsocks/files/tsocks-1.8_beta5-gentoo-r2.patch133
-rw-r--r--net-proxy/tsocks/files/tsocks-1.8_beta5-gentoo.patch65
-rw-r--r--net-proxy/tsocks/tsocks-1.8_beta5-r4.ebuild (renamed from net-proxy/tsocks/tsocks-1.8_beta5-r2.ebuild)15
4 files changed, 150 insertions, 76 deletions
diff --git a/net-proxy/tsocks/ChangeLog b/net-proxy/tsocks/ChangeLog
index 37e1d315f41c..2c570312c241 100644
--- a/net-proxy/tsocks/ChangeLog
+++ b/net-proxy/tsocks/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-proxy/tsocks
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/tsocks/ChangeLog,v 1.27 2008/08/22 21:58:52 maekke Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/tsocks/ChangeLog,v 1.28 2009/02/18 00:01:46 mrness Exp $
+
+*tsocks-1.8_beta5-r4 (18 Feb 2009)
+
+ 18 Feb 2009; Alin Năstac <mrness@gentoo.org>
+ -files/tsocks-1.8_beta5-gentoo.patch,
+ +files/tsocks-1.8_beta5-gentoo-r2.patch, -tsocks-1.8_beta5-r2.ebuild,
+ +tsocks-1.8_beta5-r4.ebuild:
+ Fix LD_PRELOAD setup, thanks to Yuval Hager <yuval at avramzon dot net>
+ (#255960).
22 Aug 2008; Markus Meier <maekke@gentoo.org> metadata.xml,
tsocks-1.8_beta5-r3.ebuild:
diff --git a/net-proxy/tsocks/files/tsocks-1.8_beta5-gentoo-r2.patch b/net-proxy/tsocks/files/tsocks-1.8_beta5-gentoo-r2.patch
new file mode 100644
index 000000000000..adb1206367a7
--- /dev/null
+++ b/net-proxy/tsocks/files/tsocks-1.8_beta5-gentoo-r2.patch
@@ -0,0 +1,133 @@
+diff -Naur tsocks-1.8.orig/Makefile.in tsocks-1.8/Makefile.in
+--- tsocks-1.8.orig/Makefile.in 2002-03-16 12:12:40.000000000 +0200
++++ tsocks-1.8/Makefile.in 2009-01-22 10:30:17.000000000 +0200
+@@ -28,6 +28,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ INCLUDES = -I.
+ LIBS = @LIBS@
+ SPECIALLIBS = @SPECIALLIBS@
+@@ -41,16 +42,16 @@
+ all: ${TARGETS}
+
+ ${VALIDATECONF}: ${VALIDATECONF}.c ${COMMON}.o ${PARSER}.o
+- ${SHCC} ${CFLAGS} ${INCLUDES} -o ${VALIDATECONF} ${VALIDATECONF}.c ${COMMON}.o ${PARSER}.o ${LIBS}
++ ${SHCC} ${LDFLAGS} ${INCLUDES} -o ${VALIDATECONF} ${VALIDATECONF}.c ${COMMON}.o ${PARSER}.o ${LIBS}
+
+ ${INSPECT}: ${INSPECT}.c ${COMMON}.o
+- ${SHCC} ${CFLAGS} ${INCLUDES} -o ${INSPECT} ${INSPECT}.c ${COMMON}.o ${LIBS}
++ ${SHCC} ${LDFLAGS} ${INCLUDES} -o ${INSPECT} ${INSPECT}.c ${COMMON}.o ${LIBS}
+
+ ${SAVE}: ${SAVE}.c
+- ${SHCC} ${CFLAGS} ${INCLUDES} -static -o ${SAVE} ${SAVE}.c
++ ${SHCC} ${LDFLAGS} ${INCLUDES} -static -o ${SAVE} ${SAVE}.c
+
+ ${SHLIB}: ${OBJS} ${COMMON}.o ${PARSER}.o
+- ${SHCC} ${CFLAGS} ${INCLUDES} -nostdlib -shared -o ${SHLIB} ${OBJS} ${COMMON}.o ${PARSER}.o ${DYNLIB_FLAGS} ${SPECIALLIBS} ${LIBS}
++ ${SHCC} ${LDFLAGS} ${INCLUDES} -nostdlib -shared -o ${SHLIB} ${OBJS} ${COMMON}.o ${PARSER}.o ${DYNLIB_FLAGS} ${SPECIALLIBS} ${LIBS}
+ ln -sf ${SHLIB} ${LIB_NAME}.so
+
+ %.so: %.c
+diff -Naur tsocks-1.8.orig/tsocks tsocks-1.8/tsocks
+--- tsocks-1.8.orig/tsocks 2002-03-16 12:27:18.000000000 +0200
++++ tsocks-1.8/tsocks 2009-01-22 10:30:34.000000000 +0200
+@@ -46,14 +46,14 @@
+ on)
+ if [ -z "$LD_PRELOAD" ]
+ then
+- export LD_PRELOAD="/usr/lib/libtsocks.so"
++ export LD_PRELOAD="/lib/libtsocks.so"
+ else
+- echo $LD_PRELOAD | grep -q "/usr/lib/libtsocks\.so" || \
+- export LD_PRELOAD="/usr/lib/libtsocks.so $LD_PRELOAD"
++ echo $LD_PRELOAD | grep -q "/lib/libtsocks\.so" || \
++ export LD_PRELOAD="/lib/libtsocks.so $LD_PRELOAD"
+ fi
+ ;;
+ off)
+- export LD_PRELOAD=`echo -n $LD_PRELOAD | sed 's/\/usr\/lib\/libtsocks.so \?//'`
++ export LD_PRELOAD=`echo -n $LD_PRELOAD | sed 's/\/lib\/libtsocks.so \?//'`
+ if [ -z "$LD_PRELOAD" ]
+ then
+ unset LD_PRELOAD
+@@ -68,10 +68,10 @@
+ *)
+ if [ -z "$LD_PRELOAD" ]
+ then
+- export LD_PRELOAD="/usr/lib/libtsocks.so"
++ export LD_PRELOAD="/lib/libtsocks.so"
+ else
+- echo $LD_PRELOAD | grep -q "/usr/lib/libtsocks\.so" || \
+- export LD_PRELOAD="/usr/lib/libtsocks.so $LD_PRELOAD"
++ echo $LD_PRELOAD | grep -q "/lib/libtsocks\.so" || \
++ export LD_PRELOAD="/lib/libtsocks.so $LD_PRELOAD"
+ fi
+
+ if [ $# = 0 ]
+diff -Naur tsocks-1.8.orig/tsocks.8 tsocks-1.8/tsocks.8
+--- tsocks-1.8.orig/tsocks.8 2002-03-16 12:20:51.000000000 +0200
++++ tsocks-1.8/tsocks.8 2009-01-22 10:30:17.000000000 +0200
+@@ -127,8 +127,8 @@
+ libtsocks in /etc/ld.so.preload. Please make sure you correctly enter the
+ full path to the library in this file if you do this. If you get it wrong,
+ you will be UNABLE TO DO ANYTHING with the machine and will have to boot
+-it with a rescue disk and remove the file (or try the saveme program, see
+-the INSTALL file for more info). THIS IS A ***WARNING***, please be
++it with a rescue disk and remove the file (or try the tsocks-saveme program,
++simply unlinks /etc/ld.so.preload ). THIS IS A ***WARNING***, please be
+ careful. Also be sure the library is in the root filesystem as all hell
+ will break loose if the directory it is in is not available at boot time.
+
+diff -Naur tsocks-1.8.orig/tsocks.conf.5 tsocks-1.8/tsocks.conf.5
+--- tsocks-1.8.orig/tsocks.conf.5 2002-05-18 05:13:08.000000000 +0300
++++ tsocks-1.8/tsocks.conf.5 2009-01-22 10:30:17.000000000 +0200
+@@ -139,21 +139,20 @@
+ the version that server supports.
+
+ .TP
+-validateconf
+-validateconf can be used to verify the configuration file. It checks the format
+-of the file and also the contents for errors. Having read the file it dumps
+-the configuration to the screen in a formatted, readable manner. This can be
+-extremely useful in debugging problems.
+-
+-validateconf can read a configuration file from a location other than the
+-location specified at compile time with the -f <filename> command line
+-option.
+-
+-Normally validateconf simply dumps the configuration read to the screen (in
+-a nicely readable format), however it also has a useful 'test' mode. When
+-passed a hostname/ip on the command line like -t <hostname/ip>, validateconf
+-determines which of the SOCKS servers specified in the configuration file
+-would be used by tsocks to access the specified host.
++tsocks-validateconf
++tsocks-validateconf can be used to verify the configuration file. It checks
++the format of the file and also the contents for errors. Having read the file
++it dumps the configuration to the screen in a formatted, readable manner.
++This can be extremely useful in debugging problems.
++
++tsocks-validateconf can read a configuration file from a location other than the
++location specified at compile time with the -f <filename> command line option.
++
++Normally tsocks-validateconf simply dumps the configuration read to the screen
++(in a nicely readable format), however it also has a useful 'test' mode. When
++passed a hostname/ip on the command line like -t <hostname/ip>,
++tsocks-validateconf determines which of the SOCKS servers specified in the
++configuration file would be used by tsocks to access the specified host.
+
+ .SH SEE ALSO
+ tsocks(8)
+diff -Naur tsocks-1.8.orig/validateconf.c tsocks-1.8/validateconf.c
+--- tsocks-1.8.orig/validateconf.c 2002-02-07 12:49:59.000000000 +0200
++++ tsocks-1.8/validateconf.c 2009-01-22 10:30:17.000000000 +0200
+@@ -23,7 +23,7 @@
+ */
+
+ /* Global configuration variables */
+-char *progname = "validateconf"; /* Name for error msgs */
++char *progname = "tsocks-validateconf"; /* Name for error msgs */
+
+ /* Header Files */
+ #include <config.h>
diff --git a/net-proxy/tsocks/files/tsocks-1.8_beta5-gentoo.patch b/net-proxy/tsocks/files/tsocks-1.8_beta5-gentoo.patch
deleted file mode 100644
index aee2d06fdb75..000000000000
--- a/net-proxy/tsocks/files/tsocks-1.8_beta5-gentoo.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff -Nru tsocks-1.8.orig/tsocks.8 tsocks-1.8/tsocks.8
---- tsocks-1.8.orig/tsocks.8 2002-03-16 12:20:51.000000000 +0200
-+++ tsocks-1.8/tsocks.8 2006-09-22 15:01:13.005417500 +0300
-@@ -127,8 +127,8 @@
- libtsocks in /etc/ld.so.preload. Please make sure you correctly enter the
- full path to the library in this file if you do this. If you get it wrong,
- you will be UNABLE TO DO ANYTHING with the machine and will have to boot
--it with a rescue disk and remove the file (or try the saveme program, see
--the INSTALL file for more info). THIS IS A ***WARNING***, please be
-+it with a rescue disk and remove the file (or try the tsocks-saveme program,
-+simply unlinks /etc/ld.so.preload ). THIS IS A ***WARNING***, please be
- careful. Also be sure the library is in the root filesystem as all hell
- will break loose if the directory it is in is not available at boot time.
-
-diff -Nru tsocks-1.8.orig/tsocks.conf.5 tsocks-1.8/tsocks.conf.5
---- tsocks-1.8.orig/tsocks.conf.5 2002-05-18 05:13:08.000000000 +0300
-+++ tsocks-1.8/tsocks.conf.5 2006-09-22 15:03:49.063170500 +0300
-@@ -139,21 +139,20 @@
- the version that server supports.
-
- .TP
--validateconf
--validateconf can be used to verify the configuration file. It checks the format
--of the file and also the contents for errors. Having read the file it dumps
--the configuration to the screen in a formatted, readable manner. This can be
--extremely useful in debugging problems.
--
--validateconf can read a configuration file from a location other than the
--location specified at compile time with the -f <filename> command line
--option.
--
--Normally validateconf simply dumps the configuration read to the screen (in
--a nicely readable format), however it also has a useful 'test' mode. When
--passed a hostname/ip on the command line like -t <hostname/ip>, validateconf
--determines which of the SOCKS servers specified in the configuration file
--would be used by tsocks to access the specified host.
-+tsocks-validateconf
-+tsocks-validateconf can be used to verify the configuration file. It checks
-+the format of the file and also the contents for errors. Having read the file
-+it dumps the configuration to the screen in a formatted, readable manner.
-+This can be extremely useful in debugging problems.
-+
-+tsocks-validateconf can read a configuration file from a location other than the
-+location specified at compile time with the -f <filename> command line option.
-+
-+Normally tsocks-validateconf simply dumps the configuration read to the screen
-+(in a nicely readable format), however it also has a useful 'test' mode. When
-+passed a hostname/ip on the command line like -t <hostname/ip>,
-+tsocks-validateconf determines which of the SOCKS servers specified in the
-+configuration file would be used by tsocks to access the specified host.
-
- .SH SEE ALSO
- tsocks(8)
-diff -Nru tsocks-1.8.orig/validateconf.c tsocks-1.8/validateconf.c
---- tsocks-1.8.orig/validateconf.c 2002-02-07 12:49:59.000000000 +0200
-+++ tsocks-1.8/validateconf.c 2006-09-22 15:04:10.368502000 +0300
-@@ -23,7 +23,7 @@
- */
-
- /* Global configuration variables */
--char *progname = "validateconf"; /* Name for error msgs */
-+char *progname = "tsocks-validateconf"; /* Name for error msgs */
-
- /* Header Files */
- #include <config.h>
diff --git a/net-proxy/tsocks/tsocks-1.8_beta5-r2.ebuild b/net-proxy/tsocks/tsocks-1.8_beta5-r4.ebuild
index 33a3d5b68476..df9c2c409024 100644
--- a/net-proxy/tsocks/tsocks-1.8_beta5-r2.ebuild
+++ b/net-proxy/tsocks/tsocks-1.8_beta5-r4.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/tsocks/tsocks-1.8_beta5-r2.ebuild,v 1.7 2007/04/22 08:26:07 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/tsocks/tsocks-1.8_beta5-r4.ebuild,v 1.1 2009/02/18 00:01:46 mrness Exp $
inherit multilib eutils autotools toolchain-funcs
DESCRIPTION="Transparent SOCKS v4 proxying library"
HOMEPAGE="http://tsocks.sourceforge.net/"
SRC_URI="mirror://sourceforge/tsocks/${PN}-${PV/_}.tar.gz
- tordns? ( mirror://gentoo/${PN}-${PV/_beta/b}-tordns1-gentoo.patch.gz )"
+ tordns? ( mirror://gentoo/${PN}-${PV/_beta/b}-tordns1-gentoo-r1.patch.gz )"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="tordns"
S="${WORKDIR}/${P%%_*}"
@@ -20,9 +20,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-gentoo-r2.patch"
epatch "${FILESDIR}/${P}-bsd.patch"
- use tordns && epatch "../${PN}-${PV/_beta/b}-tordns1-gentoo.patch"
+ use tordns && epatch "../${PN}-${PV/_beta/b}-tordns1-gentoo-r1.patch"
eautoconf
}
@@ -48,9 +48,6 @@ src_install() {
doins tsocks.conf.*.example
dodoc FAQ
use tordns && dodoc README*
- # tsocks script is buggy so we need this symlink
- dodir /usr/$(get_libdir)
- dosym /$(get_libdir)/libtsocks.so /usr/$(get_libdir)/libtsocks.so
}
pkg_postinst() {