summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-27 10:00:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-27 10:00:54 +0000
commit4595ac005a07f64fdee72f6be0069f4822aa7dd1 (patch)
tree306d0fedd0deda7a747c349bf3081c09415b4964 /net-p2p
parentStable for HPPA (bug #288967). (diff)
downloadgentoo-2-4595ac005a07f64fdee72f6be0069f4822aa7dd1.tar.gz
gentoo-2-4595ac005a07f64fdee72f6be0069f4822aa7dd1.tar.bz2
gentoo-2-4595ac005a07f64fdee72f6be0069f4822aa7dd1.zip
Version bump wrt #281536, thanks to Nico R. Wohlgemuth for reporting.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/hrktorrent/ChangeLog8
-rw-r--r--net-p2p/hrktorrent/hrktorrent-0.3.5.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/net-p2p/hrktorrent/ChangeLog b/net-p2p/hrktorrent/ChangeLog
index 847c51e3dd84..8e683178e4a7 100644
--- a/net-p2p/hrktorrent/ChangeLog
+++ b/net-p2p/hrktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/hrktorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/ChangeLog,v 1.16 2009/05/23 13:43:46 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/ChangeLog,v 1.17 2009/10/27 10:00:54 ssuominen Exp $
+
+*hrktorrent-0.3.5 (27 Oct 2009)
+
+ 27 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +hrktorrent-0.3.5.ebuild:
+ Version bump wrt #281536, thanks to Nico R. Wohlgemuth for reporting.
23 May 2009; Markus Meier <maekke@gentoo.org> hrktorrent-0.3.4.ebuild:
amd64 stable, bug #268815
diff --git a/net-p2p/hrktorrent/hrktorrent-0.3.5.ebuild b/net-p2p/hrktorrent/hrktorrent-0.3.5.ebuild
new file mode 100644
index 000000000000..1474638ebac8
--- /dev/null
+++ b/net-p2p/hrktorrent/hrktorrent-0.3.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/hrktorrent-0.3.5.ebuild,v 1.1 2009/10/27 10:00:54 ssuominen Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a light console torrent client written in C++, using rasterbar's libtorrent"
+HOMEPAGE="http://50hz.ws/hrktorrent/"
+SRC_URI="http://50hz.ws/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=net-libs/rb_libtorrent-0.14*"
+DEPEND="${RDEPEND}
+ dev-cpp/asio
+ dev-util/pkgconfig"
+
+src_compile() {
+ tc-export CXX
+ emake || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1
+ dodoc CHANGELOG CONTRIBUTORS README ${PN}.rc.example
+}