summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-07-01 14:37:57 +0000
committerJon Hood <squinky86@gentoo.org>2006-07-01 14:37:57 +0000
commitfdca1fd04e6e5d8d0d3dff4ae36cb84a39749922 (patch)
tree4b09412633f6112be1de633225c1574c5cd286d9 /net-p2p/transmission/transmission-0.6.1.ebuild
parentRevision bump to use new Java system. (diff)
downloadgentoo-2-fdca1fd04e6e5d8d0d3dff4ae36cb84a39749922.tar.gz
gentoo-2-fdca1fd04e6e5d8d0d3dff4ae36cb84a39749922.tar.bz2
gentoo-2-fdca1fd04e6e5d8d0d3dff4ae36cb84a39749922.zip
Version bump, #138667
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'net-p2p/transmission/transmission-0.6.1.ebuild')
-rw-r--r--net-p2p/transmission/transmission-0.6.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-p2p/transmission/transmission-0.6.1.ebuild b/net-p2p/transmission/transmission-0.6.1.ebuild
new file mode 100644
index 000000000000..1c137e4bc1c7
--- /dev/null
+++ b/net-p2p/transmission/transmission-0.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-0.6.1.ebuild,v 1.1 2006/07/01 14:37:57 squinky86 Exp $
+
+inherit eutils
+
+MY_PN="${PN/t/T}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="a lightweight BitTorrent client"
+HOMEPAGE="http://transmission.m0k.org/"
+SRC_URI="http://download.m0k.org/transmission/files/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk ssl"
+
+DEPEND="sys-devel/gettext
+ gtk? ( >=x11-libs/gtk+-2.6 )
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable ssl openssl) \
+ $(use_enable gtk) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin cli/transmissioncli
+
+ if use gtk ; then
+ dobin gtk/transmission-gtk
+
+ doicon "${FILESDIR}/transmission.png"
+ make_desktop_entry "transmission-gtk" "${MY_PN}" "${PN}.png" \
+ "Network;Internet;GNOME;GTK;X-Red-Hat-Base"
+ fi
+ dodoc AUTHORS NEWS README
+}