summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-02-26 15:55:00 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-02-26 15:55:00 +0000
commitf680ee23fb38421d840be7c080b5fae47ccae74d (patch)
tree0a6e5b6fb588bb5048523e020aed43a7f8214cdb /net-p2p/nicotine+
parentBug 167890, many thanks to Jan for the patch (diff)
downloadgentoo-2-f680ee23fb38421d840be7c080b5fae47ccae74d.tar.gz
gentoo-2-f680ee23fb38421d840be7c080b5fae47ccae74d.tar.bz2
gentoo-2-f680ee23fb38421d840be7c080b5fae47ccae74d.zip
Version bump, bug 168467
(Portage version: 2.1.2-r11)
Diffstat (limited to 'net-p2p/nicotine+')
-rw-r--r--net-p2p/nicotine+/ChangeLog7
-rw-r--r--net-p2p/nicotine+/files/digest-nicotine+-1.2.73
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.7.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index 4942e34e3b8d..a32b8a24ad00 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.9 2007/02/19 12:20:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.10 2007/02/26 15:55:00 armin76 Exp $
+
+*nicotine+-1.2.7 (26 Feb 2007)
+
+ 26 Feb 2007; Raúl Porcel <armin76@gentoo.org> +nicotine+-1.2.7.ebuild:
+ Version bump, bug 168467
19 Feb 2007; Raúl Porcel <armin76@gentoo.org> -nicotine+-1.2.3.ebuild:
Drop old
diff --git a/net-p2p/nicotine+/files/digest-nicotine+-1.2.7 b/net-p2p/nicotine+/files/digest-nicotine+-1.2.7
new file mode 100644
index 000000000000..7d77fc95d14d
--- /dev/null
+++ b/net-p2p/nicotine+/files/digest-nicotine+-1.2.7
@@ -0,0 +1,3 @@
+MD5 09c41ba320f61b70ee1ee8840fbf1a1d nicotine+-1.2.7.tar.bz2 721490
+RMD160 fa51f5ef635a9bff3a503d44fc4b58e2a8f465d7 nicotine+-1.2.7.tar.bz2 721490
+SHA256 739dc783bb749d0d0933ffae2bf9337a71628283158728dc2eaf5da7c034c3cc nicotine+-1.2.7.tar.bz2 721490
diff --git a/net-p2p/nicotine+/nicotine+-1.2.7.ebuild b/net-p2p/nicotine+/nicotine+-1.2.7.ebuild
new file mode 100644
index 000000000000..d81906173574
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.7.ebuild,v 1.1 2007/02/26 15:55:00 armin76 Exp $
+
+inherit distutils eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://www.nicotine-plus.org"
+SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="vorbis geoip"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2
+ vorbis? ( >=dev-python/pyvorbis-1.4-r1
+ >=dev-python/pyogg-1 )
+ geoip? ( >=dev-python/geoip-python-0.2.0
+ >=dev-libs/geoip-1.2.1 )
+ !net-p2p/nicotine"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+src_compile() {
+ distutils_src_compile
+
+ cd "${S}"/trayicon/
+ sed -i -e "s:/lib/:/$(get_libdir)/:" \
+ Makefile.in || die "sed failed"
+ ./autogen.py
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ distutils_python_version
+ distutils_src_install --install-lib \
+ /usr/$(get_libdir)/python${PYVER}/site-packages
+
+ cd "${S}"/trayicon/
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon ${FILESDIR}/nicotine-n.png
+ domenu ${FILESDIR}/${PN}.desktop
+}