summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-28 18:44:46 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-28 18:44:46 +0000
commit76386560018954e414cd13f700a2325b889a53fe (patch)
tree6bb1f07272dd686b6733fbeeb1c5803309ae66a9 /net-p2p/bittorrent
parentAdded ~x86-fbsd keyword. (diff)
downloadgentoo-2-76386560018954e414cd13f700a2325b889a53fe.tar.gz
gentoo-2-76386560018954e414cd13f700a2325b889a53fe.tar.bz2
gentoo-2-76386560018954e414cd13f700a2325b889a53fe.zip
Version bump #154103 by Loïc Ludwig and Robert Smith. Also fixes #153482 and #152944.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'net-p2p/bittorrent')
-rw-r--r--net-p2p/bittorrent/ChangeLog8
-rw-r--r--net-p2p/bittorrent/bittorrent-5.0.3.ebuild78
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-5.0.33
3 files changed, 88 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 42d23c6d04df..dbb82abefe1c 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.92 2006/12/28 18:14:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.93 2006/12/28 18:44:46 vapier Exp $
+
+*bittorrent-5.0.3 (28 Dec 2006)
+
+ 28 Dec 2006; Mike Frysinger <vapier@gentoo.org> +bittorrent-5.0.3.ebuild:
+ Version bump #154103 by Loïc Ludwig and Robert Smith. Also fixes #153482
+ and #152944.
28 Dec 2006; Mike Frysinger <vapier@gentoo.org> bittorrent-4.26.0.ebuild:
Die, dont warn, if dependency checks fail #153875 by Jory A. Pratt.
diff --git a/net-p2p/bittorrent/bittorrent-5.0.3.ebuild b/net-p2p/bittorrent/bittorrent-5.0.3.ebuild
new file mode 100644
index 000000000000..a3a5fe2237ba
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-5.0.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.0.3.ebuild,v 1.1 2006/12/28 18:44:46 vapier Exp $
+
+inherit distutils fdo-mime eutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://download.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="gtk"
+
+RDEPEND=">=dev-lang/python-2.3
+ gtk? (
+ >=x11-libs/wxGTK-2.6
+ >=dev-python/wxpython-2.6
+ )
+ >=dev-python/pycrypto-2.0
+ >=dev-python/twisted-2
+ dev-python/twisted-web
+ net-zope/zopeinterface
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+PROVIDE="virtual/bittorrent"
+
+DOCS="README.txt TRACKERLESS.txt public.key credits.txt"
+PYTHON_MODNAME="BitTorrent"
+
+pkg_setup() {
+ if use gtk ; then
+ if ! built_with_use x11-libs/wxGTK unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ if ! built_with_use dev-python/wxpython unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # path for documentation is in lowercase #109743
+ sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
+}
+
+src_install() {
+ distutils_src_install
+ use gtk || rm -f "${D}"/usr/bin/bittorrent
+ dohtml redirdonate.html
+
+ if use gtk ; then
+ newicon images/logo/bittorrent_icon_32.png bittorrent.png
+ make_desktop_entry "bittorrent" "BitTorrent" bittorrent.png "Network"
+ echo "MimeType=application/x-bittorrent" \
+ >> "${D}"/usr/share/applications/bittorrent-${PN}.desktop
+ fi
+
+ newinitd "${FILESDIR}"/bttrack.rc bttrack
+ newconfd "${FILESDIR}"/bttrack.conf bttrack
+}
+
+pkg_postinst() {
+ einfo "Remember that BitTorrent has changed file naming scheme"
+ einfo "To run BitTorrent just execute /usr/bin/bittorrent"
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-5.0.3 b/net-p2p/bittorrent/files/digest-bittorrent-5.0.3
new file mode 100644
index 000000000000..302fb719f820
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-5.0.3
@@ -0,0 +1,3 @@
+MD5 592363a33c35e9f66759a736dbf7e038 BitTorrent-5.0.3.tar.gz 2483161
+RMD160 792b0a00cb20cfe64c0bd402a7442464578fc335 BitTorrent-5.0.3.tar.gz 2483161
+SHA256 38a59459ee5bf323c0f3a0e6d2f358f6de00a0036c5593372558315f9c2f7f3f BitTorrent-5.0.3.tar.gz 2483161